1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

joomla appliance and initial passwords missing

Discussion in 'Proxmox VE 1.x: Installation and configuration' started by jarcher, Sep 25, 2011.

  1. jarcher

    jarcher Member

    Joined:
    Mar 15, 2009
    Messages:
    53
    Likes Received:
    0
    Hi All...

    I have been fighting with the Joomla appliance. I can install it, but when I try to find the randomized passwords as explained int he wiki, I see no reference to them in my log. I'll paste my log below. I am installing on Proxmox VE 1.7. MySql is running...

    Thanks...

    starting init logger
    INIT: version 2.88 booting
    stty: standard input: Invalid argument
    Using makefile-style concurrent boot in runlevel S.
    Activating swap...done.
    mount: permission denied
    Cleaning up ifupdown....
    Setting up networking....
    Fast boot enabled, so skipping file system check. ... (warning).
    Mounting local filesystems...done.
    Activating swapfile swap...done.
    Cleaning up temporary files....
    Configuring network interfaces...done.
    Starting portmap daemon....
    Cleaning up temporary files....
    Setting kernel variables ...done.
    INIT: Entering runlevel: 2
    stty: standard input: Invalid argument
    Using makefile-style concurrent boot in runlevel 2.
    Starting portmap daemon...Already running..
    Starting enhanced syslogd: rsyslogd.
    Starting web server: apache2.
    Starting deferred execution scheduler: atd.
    Starting periodic command scheduler: cron.
    Starting MySQL database server: mysqld.
    Checking for corrupt, not cleanly closed and upgrade needing tables..
    Starting Postfix Mail Transport Agent: postfix.
    Starting OpenBSD Secure Shell server: sshd.
    INIT: no more processes left in this runlevel
     
  2. tom

    tom Proxmox Staff Member
    Staff Member

    Joined:
    Aug 29, 2006
    Messages:
    11,056
    Likes Received:
    49
    which password do you miss?
     
  3. jarcher

    jarcher Member

    Joined:
    Mar 15, 2009
    Messages:
    53
    Likes Received:
    0
    The auto-generated passwords for MySql and Joomla. According to the wiki, these are supposed to be auto-genned and reported in the log file that is created on the initial run of the appliance. There is a screen shot in the wiki, but the lines referenced in the screen shot do not appear in my logs.
     
  4. tom

    tom Proxmox Staff Member
    Staff Member

    Joined:
    Aug 29, 2006
    Messages:
    11,056
    Likes Received:
    49
    I assume you use the official joomla template: http://pve.proxmox.com/wiki/Joomla!

    there is no autogenerated mysql password. if you run the joomla web installer you will be prompted for the joomla password.
     
  5. apmuthu

    apmuthu Member

    Joined:
    Feb 26, 2009
    Messages:
    726
    Likes Received:
    1
    The default MySQL root password is admin for the ProxMox Team's Joomla Template. The MySQL Joomla User, password and joomla have to be created first to be usable during the Joomla web install page if not intending to use the root MySQL user for it.

    If you are using my appliances, then the first init.log on the pve-manager web gui will display all access info. The random MySQL root user password will be archived in /root/.my.cnf .
     

Share This Page