Issues with Spice

Discussion in 'Proxmox VE: Installation and configuration' started by Rhongomiant, Nov 12, 2013.

  1. Rhongomiant

    Rhongomiant New Member

    Joined:
    Aug 4, 2012
    Messages:
    22
    Likes Received:
    0
    Hello,

    Since updating to the latest version, I have been having issues with Spice. I was on 3.1 plus the first update listed in announcements. Now I am on the latest update listed in announcements.


    1) It seems that the arg "addr=0x18" in the vm conf file is an issue with the multi-monitor spice options. I could change it to "addr=0x19" and the dual monitor option would work and maybe 3 monitor option, but not 4 monitor option and if I changed the value to "addr=0x20", I would get the following message.

    kvm: -device intel-hda,id=sound5,bus=pci.0,addr=0x20: Property 'intel-hda.addr' doesn't take value '0x20'



    2) I cannot connect to a VM via spice. Below is the output of remote-viewer with the --debug option and the other is the . The remote-viewer version is below and I am running Spice in Windows 7 x64. I have attached the contents of the spice file that proxmox generated and a screen shot of the message that the remote-viewer GUI displays.


    Code:
    
    remote-viewer version 0.5.7-1.fc19.berrange1375272046
    
    
    
    C:\Program Files\VirtViewer\bin>remote-viewer.exe --debug "C:\Users\cmirchandani
    \Downloads\spiceproxy"
    
    
    C:\Program Files\VirtViewer\bin>(remote-viewer.exe:4908): remote-viewer-DEBUG: I
    nsert window 0 000000000080C000
    (remote-viewer.exe:4908): remote-viewer-DEBUG: fullscreen display 0: 0
    (remote-viewer.exe:4908): remote-viewer-DEBUG: Opening display to C:\Users\cmirc
    handani\Downloads\spiceproxy
    (remote-viewer.exe:4908): remote-viewer-DEBUG: Guest C:\Users\cmirchandani\Downl
    oads\spiceproxy has a spice display
    (remote-viewer.exe:4908): remote-viewer-DEBUG: After open connection callback fd
    =-1
    (remote-viewer.exe:4908): remote-viewer-DEBUG: Opening connection to display at
    C:\Users\cmirchandani\Downloads\spiceproxy
    (remote-viewer.exe:4908): remote-viewer-DEBUG: New spice channel 000000000084FB6
    0 SpiceMainChannel 0
    (remote-viewer.exe:4908): remote-viewer-DEBUG: Checking full screen auto-conf
    (remote-viewer.exe:4908): remote-viewer-DEBUG: auto-conf disabled
    (remote-viewer.exe:4908): remote-viewer-DEBUG: notebook show status 000000000080
    B150
    
    
    (remote-viewer.exe:4908): GSpice-WARNING **: loading ca certs from C:\Users\cmir
    chandani/.spicec/spice_truststore.pem failed
    ((null):4908): Spice-Warning **: ../../../spice-common/common/ssl_verify.c:484:o
    penssl_verify: ssl: hostname 'pvespiceproxy:52825606:100:vms01::111a230dc2d05033
    367bd77a0a60071b50d2b8aa' verification failed
    ((null):4908): Spice-Warning **: ../../../spice-common/common/ssl_verify.c:487:o
    penssl_verify: ssl: subject 'C=US,postalCode=33602,ST=FL,L=Tampa,street=400 Nort
    h Tampa Street,street=Suite 1000,O=E Solutions Corporation,OU=Data Center Operat
    ions,OU=Hosted by E Solutions Networks, Inc.,OU=Multi-Domain SSL' verification f
    ailed
    ((null):4908): Spice-Warning **: ../../../spice-common/common/ssl_verify.c:489:o
    penssl_verify: ssl: verification failed
    
    
    (remote-viewer.exe:4908): GSpice-WARNING **: main-1:0: SSL_connect: error:000000
    01:lib(0):func(0):reason(1)
    (remote-viewer.exe:4908): remote-viewer-DEBUG: Disposing window 000000000080C000
    
    
    
    
    (remote-viewer.exe:4908): remote-viewer-DEBUG: Set connect info: (null),(null),(
    null),-1,(null),(null),(null),0
    


    I looked up the error and that lead me to the following url. This URL does not really help given the way that Spice is initiated with Proxmox.

    http://www.spice-space.org/page/SSLConnection





    3) Finally, I rebooted a proxmox server server today because I added a network. Now the multimonitor Spice options are missing. I had not installed updates since I rebooted after installing the updates listed in announcements. I checked before the reboot and there were no updates. I am not sure what changed other than me adding a network.

    Code:
    root@vms01:~# pveversion -v
    proxmox-ve-2.6.32: 3.1-114 (running kernel: 2.6.32-26-pve)
    pve-manager: 3.1-24 (running version: 3.1-24/060bd5a6)
    pve-kernel-2.6.32-26-pve: 2.6.32-114
    pve-kernel-2.6.32-23-pve: 2.6.32-109
    lvm2: 2.02.98-pve4
    clvm: 2.02.98-pve4
    corosync-pve: 1.4.5-1
    openais-pve: 1.1.4-3
    libqb0: 0.11.1-2
    redhat-cluster-pve: 3.2.0-2
    resource-agents-pve: 3.9.2-4
    fence-agents-pve: 4.0.0-2
    pve-cluster: 3.0-8
    qemu-server: 3.1-8
    pve-firmware: 1.0-23
    libpve-common-perl: 3.0-9
    libpve-access-control: 3.0-8
    libpve-storage-perl: 3.0-18
    pve-libspice-server1: 0.12.4-2
    vncterm: 1.1-6
    vzctl: 4.0-1pve4
    vzprocps: 2.0.11-2
    vzquota: 3.1-2
    pve-qemu-kvm: 1.4-17
    ksm-control-daemon: 1.1-1
    glusterfs-client: 3.4.1-1
    


    UPDATE:

    I have finally been able to test Spice in Linux and I am getting a different error than I am in Windows.


    Code:
    [/COLOR]cmirchandani@tpa01-cmirch-l:~> remote-viewer --debug "/home/cmirchandani/Downloads/spiceproxy"
    (remote-viewer:7083): remote-viewer-DEBUG: Insert window 0 0xd71810
    (remote-viewer:7083): remote-viewer-DEBUG: fullscreen display 0: 0
    (remote-viewer:7083): remote-viewer-DEBUG: Opening display to /home/cmirchandani/Downloads/spiceproxy
    (remote-viewer:7083): remote-viewer-DEBUG: Guest /home/cmirchandani/Downloads/spiceproxy has a spice display
    remote-viewer: relocation error: remote-viewer: symbol spice_smartcard_manager_get_readers, version SPICEGTK_1 not defined in file libspice-client-glib-2.0.so.8 with link time reference
    



    Linux Distro:

    openSUSE 12.3 (x86_64)
    VERSION = 12.3
    CODENAME = Dartmouth


    remote-viewer version 0.5.7
    virt-viewer version 0.5.7


    Related installed software:
    libspice-client-glib-2_0-8-0.14-3.4.1.x86_64
    libspice-client-gtk-2_0-4-0.14-3.4.1.x86_64
    libspice-controller0-0.14-3.4.1.x86_64
    libvirt-client-1.0.2-1.10.1.x86_64
    virt-viewer-0.5.7-4.1.x86_64


    Thank you for your help!

     

    Attached Files:

    #1 Rhongomiant, Nov 12, 2013
    Last edited: Nov 12, 2013
  2. dietmar

    dietmar Proxmox Staff Member
    Staff Member

    Joined:
    Apr 28, 2005
    Messages:
    16,484
    Likes Received:
    314
    Seems you use a custom ssl cert:

    'C=US,postalCode=33602,ST=FL,L=Tampa,street=400 Nort
    h Tampa Street,street=Suite 1000,O=E Solutions Corporation,OU=Data Center Operat
    ions,OU=Hosted by E Solutions Networks, Inc.,OU=Multi-Domain SSL' verification f
    ailed

    Did you install the correct CA file for that?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Rhongomiant

    Rhongomiant New Member

    Joined:
    Aug 4, 2012
    Messages:
    22
    Likes Received:
    0
    dietmar,

    I will run some openssl checks and double check the instructions, but I believe it is installed correctly. The process is a bit strange compared to say installing a cert/CA for apache, so has the process changed due to the updates released for 3.1? If it was not installed correctly, wouldn't I be having issues with the VNC console? In the past when I did not have my SSL cert/CA installed correctly the VNC console had a certificate issue, has this changed?
     
  4. dietmar

    dietmar Proxmox Staff Member
    Staff Member

    Joined:
    Apr 28, 2005
    Messages:
    16,484
    Likes Received:
    314
    I do not know whats wrong, so it would help if you test without modified ssl certificates. Spice has its own certificate handling, and that is different from what we have in VNC.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. woodgee

    woodgee New Member

    Joined:
    Sep 22, 2010
    Messages:
    8
    Likes Received:
    0
    i think you must edit the /etc/pve/pve-root-ca.pem with your ca.pem, then spice works
     
  6. mlanner

    mlanner Member

    Joined:
    Apr 1, 2009
    Messages:
    184
    Likes Received:
    1
    I have the same/similar issue. I'm using a cert issued by a commercial entity (DigiCert). It's giving me "Spice-Warning **: ssl_verify.c:489:eek:penssl_verify: ssl: verification failed", which I highly doubt, as the cert validates fine in all browsers. I did replace the self-signed Proxmox certs as described in http://pve.proxmox.com/wiki/HTTPSCertificateConfiguration. It's been working fine, except with now that I started testing SPICE.

    Any suggestions/ideas appreciated. Thanks in advance.
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice