Issue with upgrade from 7.0 to 7.1

agit8or

Member
Aug 1, 2018
17
0
6
51
There is a similar thread, but it did not fix my issue.

Code:
Starting system upgrade: apt-get dist-upgrade
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Calculating upgrade... Error!
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libpve-common-perl : Breaks: qemu-server (< 7.0-19) but 7.0-14 is to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

System not fully up to date (found 3 new packages)


Info:

Code:
pveversion -v
proxmox-ve: 7.1-1 (running kernel: 5.13.19-1-pve)
pve-manager: 7.1-6 (running version: 7.1-6/4e61e21c)
pve-kernel-5.13: 7.1-4
pve-kernel-helper: 7.1-4
pve-kernel-5.11: 7.0-10
pve-kernel-5.3: 6.1-6
pve-kernel-5.13.19-1-pve: 5.13.19-3
pve-kernel-5.11.22-7-pve: 5.11.22-12
pve-kernel-5.3.18-3-pve: 5.3.18-3
pve-kernel-5.3.10-1-pve: 5.3.10-1
ceph-fuse: 14.2.21-1
corosync: 3.1.5-pve2
criu: 3.15-1+pve-1
glusterfs-client: 9.2-1
ifupdown: residual config
ifupdown2: 3.1.0-1+pmx3
ksm-control-daemon: 1.4-1
libjs-extjs: 7.0.0-1
libknet1: 1.22-pve2
libproxmox-acme-perl: 1.4.0
libproxmox-backup-qemu0: 1.2.0-1
libpve-access-control: 7.1-4
libpve-apiclient-perl: 3.2-1
libpve-common-perl: 7.0-10
libpve-guest-common-perl: 4.0-3
libpve-http-server-perl: 4.0-3
libpve-storage-perl: 7.0-15
libqb0: 1.0.5-1
libspice-server1: 0.14.3-2.1
lvm2: 2.03.11-2.1
lxc-pve: 4.0.9-4
lxcfs: 4.0.8-pve2
novnc-pve: 1.2.0-3
proxmox-backup-client: 2.1.2-1
proxmox-backup-file-restore: 2.1.2-1
proxmox-mini-journalreader: 1.2-1
proxmox-widget-toolkit: 3.4-3
pve-cluster: 7.1-2
pve-container: 4.1-2
pve-docs: 7.1-2
pve-edk2-firmware: 3.20210831-2
pve-firewall: 4.2-5
pve-firmware: 3.3-3
pve-ha-manager: 3.3-1
pve-i18n: 2.6-2
pve-qemu-kvm: 6.1.0-2
pve-xtermjs: 4.12.0-1
qemu-server: 7.0-14
smartmontools: 7.2-pve2
spiceterm: 3.2-2
swtpm: 0.7.0-1
vncterm: 1.7-1
zfsutils-linux: 2.1.1-pve3

Code:
apt full-upgrade
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Calculating upgrade... Error!
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libpve-common-perl : Breaks: qemu-server (< 7.0-19) but 7.0-14 is to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
 

tom

Proxmox Staff Member
Staff member
Aug 29, 2006
15,500
890
163
Please post the full output of:

> apt update
 

agit8or

Member
Aug 1, 2018
17
0
6
51
Code:
 apt update
Hit:1 http://security.debian.org bullseye-security InRelease
Hit:2 http://ftp.us.debian.org/debian bullseye InRelease                     
Get:3 http://ftp.us.debian.org/debian bullseye-updates InRelease [39.4 kB]   
Hit:4 http://download.proxmox.com/debian/pve bullseye InRelease
Fetched 39.4 kB in 1s (59.1 kB/s)
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
3 packages can be upgraded. Run 'apt list --upgradable' to see them.
root@pve01:~# apt upgrade
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
  libpve-common-perl qemu-server
The following packages will be upgraded:
  libpve-access-control
1 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.
Need to get 64.6 kB of archives.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://download.proxmox.com/debian/pve bullseye/pve-no-subscription amd64 libpve-access-control all 7.1-5 [64.6 kB]
Fetched 64.6 kB in 0s (357 kB/s)                 
Reading changelogs... Done
(Reading database ... 79639 files and directories currently installed.)
Preparing to unpack .../libpve-access-control_7.1-5_all.deb ...
Unpacking libpve-access-control (7.1-5) over (7.1-4) ...
Setting up libpve-access-control (7.1-5) ...
Processing triggers for pve-manager (7.1-6) ...
Processing triggers for man-db (2.9.4-2) ...
Processing triggers for pve-ha-manager (3.3-1) ...


So I ran update/upgrade again:


Code:
 apt update
Hit:1 http://security.debian.org bullseye-security InRelease
Hit:2 http://ftp.us.debian.org/debian bullseye InRelease     
Hit:3 http://ftp.us.debian.org/debian bullseye-updates InRelease
Hit:4 http://download.proxmox.com/debian/pve bullseye InRelease
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
2 packages can be upgraded. Run 'apt list --upgradable' to see them.
root@pve01:~# apt upgrade
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
  libpve-common-perl qemu-server
0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.
 

agit8or

Member
Aug 1, 2018
17
0
6
51
This was done after the fact. This was broken just with clicking update

To be honest and blunt, if support was more reasonable, I'd be glad to pay for it. To pay $630USD PER server for just 3 support tickets per year seems really steep. That averages to $210 per support ticket.
 

sherminator

Well-Known Member
Oct 28, 2013
217
28
48
To pay $630USD PER server for just 3 support tickets per year seems really steep. That averages to $210 per support ticket.
Hey agit8or,
I guess, you write about buying a basic subscription for two CPUs. In this case, you would get six support tickets per year.

And back to topic: Could you please post your repository configuration (the *.list files from /etc/apt/sources.list.d)?

Greets
Stephan
 

Fabian_E

Proxmox Staff Member
Staff member
Aug 1, 2019
1,743
306
88
Hi,
Hi Tom

Seriously..., 'apt-get upgrade' should be considered safer than 'apt upgrade'?
I get that upgrading in general can go wrong, but could you elaborate a bit on this?

Danish greetings
Hans Otto
The point is that you should always use dist-upgrade (or equivalently full-upgrade) like the documentation states. The reason is that dist-upgrade will also remove a package when that is necessary to upgrade the system as a whole, while upgrade doesn't.
 

agit8or

Member
Aug 1, 2018
17
0
6
51
Hey agit8or,
I guess, you write about buying a basic subscription for two CPUs. In this case, you would get six support tickets per year.

And back to topic: Could you please post your repository configuration (the *.list files from /etc/apt/sources.list.d)?

Greets
Stephan
The only file in that directory is pve-enterprise.list:

Code:
deb https://enterprise.proxmox.com/debian/pve bullseye pve-enterprise

That repository is disabled as it doesn't have a subscription.
 

agit8or

Member
Aug 1, 2018
17
0
6
51
Nothing out of the ordinary....

Code:
deb http://ftp.us.debian.org/debian bullseye main contrib

deb http://ftp.us.debian.org/debian bullseye-updates main contrib

deb http://download.proxmox.com/debian/pve bullseye pve-no-subscription

# security updates
deb http://security.debian.org bullseye-security main contrib
 

sherminator

Well-Known Member
Oct 28, 2013
217
28
48
Yes, that looks correct. Maybe you should comment out the line in /etc/apt/sources.list.d/pve-enterprise.list or delete this file. It's cleaner but probably not the cause of your problem.

In /var/log/apt/ you can find the history of upgrading your packages. Could you post the content of the latest history* files?
 

agit8or

Member
Aug 1, 2018
17
0
6
51
Did you already try apt -f install? If not, please try.
Code:
apt -f install
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.
 

agit8or

Member
Aug 1, 2018
17
0
6
51
Yes, that looks correct. Maybe you should comment out the line in /etc/apt/sources.list.d/pve-enterprise.list or delete this file. It's cleaner but probably not the cause of your problem.

In /var/log/apt/ you can find the history of upgrading your packages. Could you post the content of the latest history* files?


Code:
Start-Date: 2021-11-18  12:19:30
Commandline: apt upgrade
Install: libjs-qrcodejs:amd64 (1.20201119-pve1, automatic), libposix-strptime-perl:amd64 (0.13-1+b7, automatic), libzpool5linux:amd64 (2.1.1-pve3, automatic), pve-kernel-5.13.19-1-pve:amd64 (5.13.19-2, automatic), pve-kernel-5.13:amd64 (7.1-4, automatic), pve-kernel-5.11>
Upgrade: pve-docs:amd64 (7.0-5, 7.1-2), bind9-host:amd64 (1:9.16.15-1, 1:9.16.22-1~deb11u1), proxmox-widget-toolkit:amd64 (3.3-6, 3.4-2), libpve-rs-perl:amd64 (0.2.3, 0.3.2), corosync:amd64 (3.1.5-pve1, 3.1.5-pve2), pve-firmware:amd64 (3.3-2, 3.3-3), tzdata:amd64 (2021a->
End-Date: 2021-11-18  12:21:54

Start-Date: 2021-11-18  12:23:10
Commandline: apt autoremove
Remove: pve-kernel-5.4.114-1-pve:amd64 (5.4.114-1), libzpool4linux:amd64 (2.0.5-pve1), pve-kernel-5.4.124-1-pve:amd64 (5.4.124-1), pve-kernel-5.4.119-1-pve:amd64 (5.4.119-1), pve-kernel-5.4:amd64 (6.4-4), pve-kernel-5.11.22-1-pve:amd64 (5.11.22-2), pve-kernel-5.11.22-2-p>
End-Date: 2021-11-18  12:23:57

Start-Date: 2021-11-18  12:37:37
Commandline: apt upgrade dist
Install: dist:amd64 (1:3.5-236-1)
End-Date: 2021-11-18  12:37:41

Start-Date: 2021-11-24  15:40:40
Commandline: apt upgrade
Upgrade: proxmox-widget-toolkit:amd64 (3.4-2, 3.4-3), libpve-rs-perl:amd64 (0.3.2, 0.4.4), proxmox-backup-file-restore:amd64 (2.0.14-1, 2.1.2-1), libpve-access-control:amd64 (7.1-2, 7.1-4), pve-kernel-5.13.19-1-pve:amd64 (5.13.19-2, 5.13.19-3), pve-i18n:amd64 (2.6-1, 2.6>
End-Date: 2021-11-24  15:41:32

Start-Date: 2021-11-24  15:42:08
Commandline: apt autoremove
Remove: pve-kernel-5.11.22-5-pve:amd64 (5.11.22-10)
End-Date: 2021-11-24  15:42:15

Start-Date: 2021-11-25  09:50:56
Commandline: apt upgrade
Upgrade: libpve-access-control:amd64 (7.1-4, 7.1-5)
End-Date: 2021-11-25  09:51:02

Ill unzip the previous ones if you want to see those.
 

agit8or

Member
Aug 1, 2018
17
0
6
51
history.log.1

Code:
Start-Date: 2021-10-22  12:29:54
Commandline: apt-get dist-upgrade
Install: pve-kernel-5.11.22-5-pve:amd64 (5.11.22-10, automatic)
Upgrade: reportbug:amd64 (7.10.3, 7.10.3+deb11u1), libperl5.32:amd64 (5.32.1-4+deb11u1, 5.32.1-4+deb11u2), libpam-runtime:amd64 (1.4.0-9, 1.4.0-9+deb11u1), krb5-locales:amd64 (1.18.3-6, 1.18.3-6+deb11u1), libgssapi-krb5-2:amd64 (1.18.3-6, 1.18.3-6+deb11u1), pve-firmware:>
End-Date: 2021-10-22  12:31:36




Start-Date: 2021-10-22  12:29:54
Commandline: apt-get dist-upgrade
Install: pve-kernel-5.11.22-5-pve:amd64 (5.11.22-10, automatic)
Upgrade: reportbug:amd64 (7.10.3, 7.10.3+deb11u1), libperl5.32:amd64 (5.32.1-4+deb11u1, 5.32.1-4+deb11u2), libpam-runtime:amd64 (1.4.0-9, 1.4.0-9+deb11u1), krb5-locales:amd64 (1.18.3-6, 1.18.3-6+deb11u1), libgssapi-krb5-2:amd64 (1.18.3-6, 1.18.3-6+deb11u1), pve-firmware:>
End-Date: 2021-10-22  12:31:36
 

sherminator

Well-Known Member
Oct 28, 2013
217
28
48
It seems that in October you did apt-get dist-upgrade like recommended. On November 18th you started using apt uprade followed by apt autoremove. I'm not sure, but I strongly believe this could have damaged your system.
Could you also post the related term* files? Maybe here we can see when things started going wrong.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!