iscsi connection lost after reboot

Sereno

Member
Aug 10, 2018
7
0
21
40
Hello!

We have a QNAP with a LUN and we would like to connect to this device using iscsi so we can send all the backups to that storage.

root@pbs:~# iscsiadm -m discovery -t st -p 192.168.65.3 -o update
192.168.65.3:3260,1 iqn.2004-04.com.qnap:es1686dc:iscsi.backup.4e4451.1
root@pbs:~# iscsiadm --mode discoverydb --type sendtargets --portal 192.168.65.3 --discover
192.168.65.3:3260,1 iqn.2004-04.com.qnap:es1686dc:iscsi.backup.4e4451.1
root@pbs:~# iscsiadm --mode node
192.168.65.3:3260,1 iqn.2004-04.com.qnap:es1686dc:iscsi.backup.4e4451.1
root@pbs:~# iscsiadm -m node -P 1
Target: iqn.2004-04.com.qnap:es1686dc:iscsi.backup.4e4451.1
Portal: 192.168.65.3:3260,1
Iface Name: default
root@pbs:~# iscsiadm -m node --login
Logging in to [iface: default, target: iqn.2004-04.com.qnap:es1686dc:iscsi.backup.4e4451.1, portal: 192.168.65.3,3260]
Login to [iface: default, target: iqn.2004-04.com.qnap:es1686dc:iscsi.backup.4e4451.1, portal: 192.168.65.3,3260] successful.
root@pbs:~# iscsiadm -m session -o show
tcp: [1] 192.168.65.3:3260,1 iqn.2004-04.com.qnap:es1686dc:iscsi.backup.4e4451.1 (non-flash)

The problem is that this connection is not restored after rebooting the machine. Is there any log we can find in order to troubleshoot the issue?

Another test we made is that we perform the connection, we restart the iscsi. service and the connection is restored.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!