[SOLVED] Intel integrated GPU passthrough not working after upgrade

challenge

New Member
Jan 10, 2019
1
0
1
33
SOLVED: Ignore this, it was a defective EDID that triggered a chain reaction of problems trying to fix that... :mad:
Proxmox 6 works great and IGD passthrough works fine as before!

Hello, I pass the host's integrated gpu (Intel G4400 cpu, skylake) to some vms, linux and win ones.
They were working great for months, even the HD Audio through HDMI. It was a pain to setup but in 5.4 everything worked fine, IIRC in legacy mode.
Until I did a dist upgrade before upgrading to 6 and that broke it.
Stupidly went through the 6 upgrade instead of trying to trace the problem, so now everything is different.

The linux guests don't load the card no matter legacy or upt mode or whatever combo of args i provide. No output to the HDMI monitor, black screen, no display, errors like "EDID is invalid", HDMI or DP shows as disconnected, "[i915]] *ERROR* DC state mismatch (0x0 -> 0x2)", detecting wrong monitor resolution are some of the things I'm getting.
If I don't pass the integrated card, vms work correctly.

More likely something qemu/i915/IGD specific.

Updated to proxmox 6 and still broken. Except a win7 vm that still runs perfectly and weirdly was unaffected by all of this, it outputs fine to the displayport and everything works. Tried to use its args/conf in other vms but no way.
The ubuntu and win10 ones don't want to use the card. Win7 is the only one working.

Anyone with similar experience?
 
Last edited:

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!