Installation from PXE: "the initrd is too big"

sacarias

Member
Oct 2, 2019
49
0
11
I'm using this script
https://github.com/morph027/pve-iso-2-pxe
by @morph027 to install PVE from PXE (and USB as well).

This method works perfectly for PVE 6.0, but for latest PVE 6.2 it stopped working for me, even when github page says it's fully working for 6.2.

With PVE 6.2, trying to boot the generated initrd results in this error:
Code:
error: the initrd is too big
Press any key to continue

The script-generated initrd image for PVE 6.0 is 760 Mb size, and there was no problem.
The initrd for PVE 6.2 is 880 Mb size, and I got the above error.

All I could find around internet regarding the aforementioned error were some *very old* threads in forums suggesting to "disable Memory Hole option" in BIOS/UEFI setup. However none of the PCs I tested in have such option in their configurations.

The only way I could "fix" the error with PVE 6.2 was changing this
Code:
linux http://${webserver}/proxmox/${version}/linux26
initrd http://${webserver}/proxmox/${version}/initrd.iso.img
for this
Code:
linuxefi http://${webserver}/proxmox/${version}/linux26
initrdefi http://${webserver}/proxmox/${version}/initrd.iso.img

However this has the drawback of not being able to install on legacy BIOS machines.

Tested on 2 servers, HP ProLiant ML110 G7 (BIOS) and ProLiant ML30 Gen9 (UEFI), each with 16 Gb RAM.

Could someone help with this, by chance?
Thanks.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!