Install Proxmox with bonded and trunked nic's

Discussion in 'Proxmox VE: Installation and configuration' started by Damian Busicchia, Aug 9, 2016.

Tags:
  1. Damian Busicchia

    Damian Busicchia New Member

    Joined:
    Jul 28, 2016
    Messages:
    2
    Likes Received:
    0
    I am installing Proxmox on an HP DL360p Gen9 with a 2 port 10G nic that has a trunked LACP config on the switch side and have the below as my /etc/network/interfaces file:

    auto lo
    iface lo inet loopback

    iface eth0 inet manual

    iface eth1 inet manual

    auto bond0
    iface bond0 inet manual
    slaves eth0 eth1
    bond-miimon 100
    bond_mode 802.3ad
    bond_rate 1

    auto vlan1040
    iface vlan1040 inet manual
    vlan-raw-device bond0

    auto vmbr0
    iface vmbr0 inet static
    address 172.27.188.7
    netmask 255.255.255.0
    gateway 172.27.188.1
    bridge_ports vlan1040
    bridge_stp off
    bridge_fd 0

    STP is not enabled ion my enviornment.

    vmbr0 is listed with the correct IP in ifconfig but no packets are passing and when cat /proc/net/bonding/bond0 it shows the LACP rate as being slow instead of fast.

    What am I doing wrong?

    BTW, new to Debian
     
  2. mir

    mir Well-Known Member
    Proxmox Subscriber

    Joined:
    Apr 14, 2012
    Messages:
    3,481
    Likes Received:
    96
    Replace this line: bond_rate 1
    with this line: bond_lacp_rate fast
     
  3. Damian Busicchia

    Damian Busicchia New Member

    Joined:
    Jul 28, 2016
    Messages:
    2
    Likes Received:
    0
    Thank you , that solved the issue
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice