[SOLVED] Inconsistent TCP connection timeout on VM's over internet

Corwin

Well-Known Member
Jan 26, 2016
37
0
46
FR
Hello,

I'm facing the following issue:
The proxmox host seems to work like a charm, it is located in a datacenter.
TCP connections started from the host to the VM's are okay
TCP connections started from my office or any other location not always : I got very frequent timeout on TCP connections to several lxc VM's, eg. SSH, HTTP and FTP, suddendly I cannot connect, just waiting a few seconds before retry and the connection is back again !
Firewall was active, so to be sure I disabled the 3 levels, same issue
Installing a new VM from a template gives also the same troubles

I'm a bit lost, could it be related to proxmox or do I have to dig further on the hardware side or network with my provider ?

pveversion -v
proxmox-ve: 6.1-2 (running kernel: 5.3.13-1-pve)
pve-manager: 6.1-5 (running version: 6.1-5/9bf06119)
pve-kernel-5.3: 6.1-1
pve-kernel-helper: 6.1-1
pve-kernel-5.0: 6.0-11
pve-kernel-4.15: 5.4-9
pve-kernel-5.3.13-1-pve: 5.3.13-1
pve-kernel-5.0.21-5-pve: 5.0.21-10
pve-kernel-4.15.18-21-pve: 4.15.18-48
ceph-fuse: 12.2.11+dfsg1-2.1+b1
corosync: 3.0.2-pve4
criu: 3.11-3
glusterfs-client: 5.5-3
ifupdown: 0.8.35+pve1
ksm-control-daemon: 1.3-1
libjs-extjs: 6.0.1-10
libknet1: 1.13-pve1
libpve-access-control: 6.0-5
libpve-apiclient-perl: 3.0-2
libpve-common-perl: 6.0-9
libpve-guest-common-perl: 3.0-3
libpve-http-server-perl: 3.0-3
libpve-storage-perl: 6.1-3
libqb0: 1.0.5-1
libspice-server1: 0.14.2-4~pve6+1
lvm2: 2.03.02-pve3
lxc-pve: 3.2.1-1
lxcfs: 3.0.3-pve60
novnc-pve: 1.1.0-1
proxmox-mini-journalreader: 1.1-1
proxmox-widget-toolkit: 2.1-1
pve-cluster: 6.1-2
pve-container: 3.0-15
pve-docs: 6.1-3
pve-edk2-firmware: 2.20191127-1
pve-firewall: 4.0-9
pve-firmware: 3.0-4
pve-ha-manager: 3.0-8
pve-i18n: 2.0-3
pve-qemu-kvm: 4.1.1-2
pve-xtermjs: 3.13.2-1
qemu-server: 6.1-4
smartmontools: 7.0-pve2
spiceterm: 3.1-1
vncterm: 1.6-1
zfsutils-linux: 0.8.2-pve2
 
hi,

afaik, there's no known bug or issue about this and you seem to have the latest versions.
so i'd first start testing the network and hardware for problems. that way we know right away, if the problem is proxmox-related.
 
In proxmox console, run
ifconfig | grep 'errors'
to investigate about some network problems.
 
Thank you for your hints, what a difficult story... But it appears to be a public IP routing issue, 100% internal to my cloud provider. Topic solved.
 
glad your problem is gone.

could you also mark the thread as [SOLVED] so others know what to expect when they click?
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!