i40e Bug - will there be kernel updates soon?

t.lamprecht

Proxmox Staff Member
Staff member
Jul 28, 2015
2,721
418
103
South Tyrol/Italy
shop.maurer-it.com
Which kernel version did you used previously? I.e., did it worked in another 4.15 release or did you use 4.13, or something else?

What's the exact symptoms/errors you observer? Please do not just say "same as linked bug report", I'd like to have your first hand information here, thanks.
We'll not update to 4.18 in PVE 5.X but we'll naturally backport the fixes once we tracked the exact ones down, I have a few candidates but I'd like to be a bit more sure about them.
 

t.lamprecht

Proxmox Staff Member
Staff member
Jul 28, 2015
2,721
418
103
South Tyrol/Italy
shop.maurer-it.com
Dec 27, 2013
13
0
21

t.lamprecht

Proxmox Staff Member
Staff member
Jul 28, 2015
2,721
418
103
South Tyrol/Italy
shop.maurer-it.com
Hi, i40e driver included in proxmox 4.15.xx.xx kernel is obsolete.
Upgrade to Proxmox VE 6.x which features the 5.4 kernel with a much more recent i40e driver.

Also note you cannot compare the sourceforge version with the one from the kernel, they are just two different things..

Actually an Intel Engineer recommended us also away from that driver, which is mostly for legacy distributions stuck on kernels from the 3.x or 4.4 era. https://sourceforge.net/p/e1000/bugs/620/#66b0

Note, that Proxmox VE 5.x will EOL in a few weeks anyway, so please upgrade sooner than later.
 
Dec 27, 2013
13
0
21
Thank you for your reply, but i wrote about i40e driver for XL710 40Gbe Nic NOT about igb Nic (1Gbit ethenet product).
These products use different drivers.

Actually i can't upgrade server until october, i'd like to solve problem with actual configuration.

Please check version about my driver.
Thank you
Paolo
 

t.lamprecht

Proxmox Staff Member
Staff member
Jul 28, 2015
2,721
418
103
South Tyrol/Italy
shop.maurer-it.com
Thank you for your reply, but i wrote about i40e driver for XL710 40Gbe Nic NOT about igb Nic (1Gbit ethenet product).
These products use different drivers.
Yeah, I know... But the project you and I linked are providing both and more drivers for older kernels. ;)
Thus, the recommendation from the Intel engineers to favor running a current's Kernels built in driver holds also for i40e...

Actually i can't upgrade server until october,
Then you'll run an end-of-life version for August to October, which I heavily recommend against.

We will not switch over to an out-of-tree driver for a version which is already in maintenance mode and will go EOL in two months.
Especially as then others come and complain that the out-of-tree doesn't work with their specific HW/firmware.

Note, that you can also compile this external module yourself - if you really want it.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!