[SOLVED] I can't find any way to mount Hetzner's StorageBox as CIFS

Razva

Active Member
Dec 3, 2013
243
7
38
Romania
cncted.com
Hello,

I'm struggling to mount Hetzner's StorageBox as CIFS, no idea what I'm doing wrong. As specified in a previous thread I can access the share via smbclient but mount.cifs is failing.

Here's SMBCLIENT:
Bash:
# smbclient //XXX-sub2.your-storagebox.de/XXX-sub2 -d 0 -m smb3 -U XXX-sub2 -c 'l'
Enter WORKGROUP\XXX-sub2's password:
  .                                   D        0  Sat Aug 17 14:12:24 2019
  ..                                  D        0  Fri May  3 16:02:31 2019
  dump                                D        0  Wed Sep 11 10:42:43 2019

As you can see Hetzner fully accepts SMB3, so it's not because of a legacy SMB versions or Hetzner "doing something wrong".


Here's MOUNT.CIFS:
Bash:
# mount.cifs -o user=XXX-sub2,pass=AAA //XXX-sub2.your-storagebox.de/XXX-sub2/ /root/stbox-pmx1/
mount error(2): No such file or directory
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)


Here's /var/log/messages when running mount.cifs:
Bash:
Dec 27 12:05:26 pmx1 kernel: [3433496.288722] CIFS: Attempting to mount //u135588-sub2.your-storagebox.de/u135588-sub2/

Dec 27 12:05:26 pmx1 kernel: [3433496.288735] No dialect specified on mount. Default has changed to a more secure dialect, SMB2.1 or later (e.g. SMB3), from CIFS (SMB1). To use the less secure SMB1 dialect to access old servers which do not support SMB3 (or SMB2.1) specify vers=1.0 on mount.


When trying to use the GUI to add the CIFS I'm getting Dec 27 12:13:41 pmx1-lim kernel: [3433991.541867] CIFS: Attempting to mount //XXX-sub2.your-storagebox.de/XXX-sub2 in the logs, and mount error: Refer to the mount.cifs(8) manual page (e.g. man mount.cifs) (500) in the GUI.

Can somebody please give me a hint here?

Thank you!
 

oguz

Proxmox Retired Staff
Retired Staff
Nov 19, 2018
5,207
704
118
hi,

# mount.cifs -o user=XXX-sub2,pass=AAA //XXX-sub2.your-storagebox.de/XXX-sub2/ /root/stbox-pmx1/ mount error(2): No such file or directory

without the extra / at the end of share name too.
 

Razva

Active Member
Dec 3, 2013
243
7
38
Romania
cncted.com
without the extra / at the end of share name too.

Still not working:
Code:
# mount.cifs -o user=XXX-sub2,pass=AAA //XXX-sub2.your-storagebox.de/XXX-sub2 /backup/stbox-pmx1/
mount error(2): No such file or directory
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

# mount.cifs -o user=XXX-sub2,pass=AAA //XXX-sub2.your-storagebox.de/XXX-sub2 /backup/stbox-pmx1
mount error(2): No such file or directory
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

Dec 27 12:44:13 pmx1-lim kernel: [3435822.718256] CIFS: Attempting to mount //XXX-sub2.your-storagebox.de/XXX-sub2
Dec 27 12:44:13 pmx1-lim kernel: [3435822.718288] No dialect specified on mount. Default has changed to a more secure dialect, SMB2.1 or later (e.g. SMB3), from CIFS (SMB1). To use the less secure SMB1 dialect to access old servers which do not support SMB3 (or SMB2.1) specify vers=1.0 on mount.

So unfortunately no, it's not working with or without /.

For testing purposes I've created some temporary credentials here. I would really, really appreciate a solution, as I'm struggling with this for more than 3 months.

Thank you very much!
 

oguz

Proxmox Retired Staff
Retired Staff
Nov 19, 2018
5,207
704
118
just to be sure of the syntax, can you try like in the manpage: mount.cifs {service} {mount-point} [-o options]
 

oguz

Proxmox Retired Staff
Retired Staff
Nov 19, 2018
5,207
704
118
Is this a Proxmox bug that we're just discovering...?

the error mount error(2): No such file or directory makes me think maybe just the /backup/stbox-pmx1 directory isn't present... is it there?

otherwise please post your pveversion -v
 

Razva

Active Member
Dec 3, 2013
243
7
38
Romania
cncted.com
the error mount error(2): No such file or directory makes me think maybe just the /backup/stbox-pmx1 directory isn't present... is it there?

otherwise please post your pveversion -v

The directory is present:
Bash:
# ls /backup/stbox-pmx1/
root@pmx1:/#

Here's the version of the host that I'm currently testing, but the issue is present on any PVE6.X hosts, including the latest 6.1.
Bash:
# pveversion -v
proxmox-ve: 6.0-2 (running kernel: 5.0.21-5-pve)
pve-manager: 6.0-11 (running version: 6.0-11/2140ef37)
pve-kernel-helper: 6.0-12
pve-kernel-5.0: 6.0-11
pve-kernel-5.0.21-5-pve: 5.0.21-10
pve-kernel-5.0.15-1-pve: 5.0.15-1
ceph-fuse: 12.2.11+dfsg1-2.1+b1
corosync: 3.0.2-pve4
criu: 3.11-3
glusterfs-client: 5.5-3
ksm-control-daemon: 1.3-1
libjs-extjs: 6.0.1-10
libknet1: 1.13-pve1
libpve-access-control: 6.0-3
libpve-apiclient-perl: 3.0-2
libpve-common-perl: 6.0-7
libpve-guest-common-perl: 3.0-2
libpve-http-server-perl: 3.0-3
libpve-storage-perl: 6.0-9
libqb0: 1.0.5-1
lvm2: 2.03.02-pve3
lxc-pve: 3.2.1-1
lxcfs: 3.0.3-pve60
novnc-pve: 1.1.0-1
proxmox-mini-journalreader: 1.1-1
proxmox-widget-toolkit: 2.0-8
pve-cluster: 6.0-7
pve-container: 3.0-10
pve-docs: 6.0-8
pve-edk2-firmware: 2.20190614-1
pve-firewall: 4.0-7
pve-firmware: 3.0-4
pve-ha-manager: 3.0-3
pve-i18n: 2.0-3
pve-qemu-kvm: 4.0.1-5
pve-xtermjs: 3.13.2-1
qemu-server: 6.0-13
smartmontools: 7.0-pve2
spiceterm: 3.1-1
vncterm: 1.6-1
zfsutils-linux: 0.8.2-pve2

Please feel free to get the credentials from the Gist and try on your own machine.

Any hints are really appreciated!
 

oguz

Proxmox Retired Staff
Retired Staff
Nov 19, 2018
5,207
704
118
Please feel free to get the credentials from the Gist and try on your own machine.
works fine here.

maybe something to do with your network configuration?
 

Razva

Active Member
Dec 3, 2013
243
7
38
Romania
cncted.com
works fine here.

maybe something to do with your network configuration?
I'm using a standard OVH server for the hosts, with no firewall in place. The test VM I'm using is - itself - hosted on the PVE host that I'm trying to connect.

So a VM on the PVE host can connect, but the PVE host itself cannot. This basically removes any suspicions of OVH filtering traffic or any other network related issues.
 

Razva

Active Member
Dec 3, 2013
243
7
38
Romania
cncted.com
works fine here.

maybe something to do with your network configuration?
Here's some food for thought.

This is working:
Bash:
# mount.cifs //XXX-sub1.your-storagebox.de/XXX-sub1 /backup/stbox-pmx1 -o user=XXX-sub1,pass=AAA,vers=1.0

This is not working:
Bash:
# mount.cifs //XXX-sub1.your-storagebox.de/XXX-sub1 /backup/stbox-pmx1 -o user=XXX-sub1,pass=AAA,vers=2.0
 

oguz

Proxmox Retired Staff
Retired Staff
Nov 19, 2018
5,207
704
118
hi,

are you still having this issue?
 

oguz

Proxmox Retired Staff
Retired Staff
Nov 19, 2018
5,207
704
118
Maybe I need some kernel modules active? Please note that I'm not using any "installer" provided by OVH but I've used the official ISO.

if you've used the official ISO there shouldn't be any missing drivers.

mount.cifs //XXX-sub1.your-storagebox.de/XXX-sub1 /backup/stbox-pmx1 -o user=XXX-sub1,pass=AAA,vers=1.0

so you can mount it with v1 but not v2.. that's weird. can you mount it with v2 on the debian box?
 

Razva

Active Member
Dec 3, 2013
243
7
38
Romania
cncted.com
if you've used the official ISO there shouldn't be any missing drivers.
I know. I've tried to us the official ISO, plus OVH's template. It's the same exact issue.

so you can mount it with v1 but not v2.. that's weird. can you mount it with v2 on the debian box?
I can mount any version on everything except Proxmox.

I've also tried to make a fresh new server, with a fresh ISO, without touching anything else beyond the installer. It's the same result for everything inside OVH. I've contacted OVH and obviously they asked me if - on the same servers - I have the same issue, and I don't, so there's no network limitation on their side.

So OVH is sending me back to Proxmox (as I can connect to Hetzner via any other OS, except Proxmox). Hetzner sent me back to Proxmox (as I can connect to them via any other OS, except Proxmox) and Proxmox is basically offering no solution because it can't reproduce it on a large scale.

Still, this issue is affecting anybody who wants to mount Hetzner's StorageBox on a OVH server that uses Proxmox. And yes, I've asked a colleague who has the same setup, he has the same exact issue on a totally different OVH data-center.

If required I can offer full access to one of the servers so you can investigate this further.
 

oguz

Proxmox Retired Staff
Retired Staff
Nov 19, 2018
5,207
704
118
hi,

I can mount any version on everything except Proxmox.

to debug this further, please do the following:

* upgrade your proxmox host to use the newest kernel (atm 5.3.13-1-pve. check the running kernel with pveversion -v)

* using the --verbose flag of mount.cifs run the mount command both on proxmox and debian host:
- without any version specified
- with 3.0
- with 2.0
- with 1.0

and post the outputs.
 

oguz

Proxmox Retired Staff
Retired Staff
Nov 19, 2018
5,207
704
118
any update?
 

spyfly

Active Member
Jul 22, 2017
30
0
31
22
any update?

Hi, I can replicate the issue on my OVH host as well. With SMBv1 it mounts, with v2 or v3 it doesn't. I am running pve-kernel-5.3.18-2-pve.

Here are the outpots of the cifs mount command with --verbose
1.0
Code:
mount.cifs //***.your-storagebox.de/backup /mnt/pve/storage-box -o user=***,pass=***,vers=1.0 --verbose
mount.cifs kernel mount options: ip=195.201.***.***,unc=\\***.your-storagebox.de\backup,vers=1.0,user=***,pass=********

2.0
Code:
mount.cifs //***.your-storagebox.de/backup /mnt/pve/storage-box -o user=***,pass=***,vers=2.0 --verbose
mount.cifs kernel mount options: ip=195.201.***.***,unc=\\***.your-storagebox.de\backup,vers=2.0,user=***,pass=********
mount error(2): No such file or directory
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

3.0
Code:
mount.cifs //***.your-storagebox.de/backup /mnt/pve/storage-box -o user=***,pass=***,vers=3.0 --verbose
mount.cifs kernel mount options: ip=195.201.***.***,unc=\\***.your-storagebox.de\backup,vers=3.0,user=***,pass=********
mount error(2): No such file or directory
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

No version specified
Code:
mount.cifs //***.your-storagebox.de/backup /mnt/pve/storage-box -o user=***,pass=*** --verbose
mount.cifs kernel mount options: ip=195.201.***.***,unc=\\***.your-storagebox.de\backup,user=***,pass=********
mount error(2): No such file or directory
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

Edit: Using Kernel Version 5.4.24-1-pve lead to the same results
 
Last edited:

dcsapak

Proxmox Staff Member
Staff member
Feb 1, 2016
8,631
1,121
174
34
Vienna
based on the first post, the assumption of the whole thread is wrong

I'm struggling to mount Hetzner's StorageBox as CIFS, no idea what I'm doing wrong. As specified in a previous thread I can access the share via smbclient but mount.cifs is failing.

Here's SMBCLIENT:
Bash:
# smbclient //XXX-sub2.your-storagebox.de/XXX-sub2 -d 0 -m smb3 -U XXX-sub2 -c 'l'
Enter WORKGROUP\XXX-sub2's password:
. D 0 Sat Aug 17 14:12:24 2019
.. D 0 Fri May 3 16:02:31 2019
dump D 0 Wed Sep 11 10:42:43 2019
As you can see Hetzner fully accepts SMB3, so it's not because of a legacy SMB versions or Hetzner "doing something wrong".

the '-m' flag of smbclient defines the 'maxprotocol' so it will happily fallback to an older version.... it seems the server simply does not support protocols >1
 

spyfly

Active Member
Jul 22, 2017
30
0
31
22
based on the first post, the assumption of the whole thread is wrong



the '-m' flag of smbclient defines the 'maxprotocol' so it will happily fallback to an older version.... it seems the server simply does not support protocols >1


I wouldn't say so.

I can mount the Hetzner storage box on one of my Hetzner Proxmox Hosts and on my homelab servers without any issues using the Proxmox GUI.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!