hyper-v to zfs zvol

flexyz

Well-Known Member
Sep 22, 2016
154
9
58
53
Hi

Any suggestions on how I can migrate windows and linux hyper-v images to my proxmox running ZFS - when I create a VM and specify a disk it will create a zvol (I think)

can I use qemu-img convert to raw or something like that and if so how?

Thanks a mill
 
Hi,

i use StarWind V2V Converter to convert VMware or Hyper-V Images to Raw. It is a free application for Windows.

Then i create a new VM on an filesystem based storage, replace the disk with the converted one and migrate the disk to the final storage (zfs/lvm/...).

Hope this helps.
 
I am still struggling and It looks like my main issue is that my VM are generation 2 windows - but still not sure.

So I am still trying, I will try CloneZilla today when I have some thing that works and will update here.

Thanks again
 
I tried CloneZilla, but still no go but I think is related to UEFI bios - I tried this :

**********

qemu-img check -r all '/saspool/shares/temp/BuildMachine.vhdx'

qemu-img convert -f vhdx /saspool/shares/temp/BuildMachine.vhdx /saspool/shares/temp/BuildMachine.raw

dd if=//saspool/shares/temp/BuildMachine.raw of=/dev/zvol/saspool/vms/vm-101-disk-1 bs=1M

(I am using ZFS ZVOLs)

**********

fdisk -l /saspool/shares/temp/BuildMachine.raw

Disk /saspool/shares/temp/BuildMachine.raw: 127 GiB, 136365211648 bytes, 266338304 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 26BB161F-D658-452F-B1F2-6C556322798E

***********

If I configure disk as IDE and SCSI controller default LSI my windows is booting...

Virtio drivers are installed but I can't figure out how to change to VirtiO drivers - when I do, it will not boot :(

Any suggestions?

Thanks!
 

Attachments

  • Screen Shot 2017-02-15 at 17.03.48.png
    Screen Shot 2017-02-15 at 17.03.48.png
    133.6 KB · Views: 16
  • Screen Shot 2017-02-15 at 17.04.10.png
    Screen Shot 2017-02-15 at 17.04.10.png
    94 KB · Views: 13
Thanks :)

I ended up with this approach :

01. created a new KVM with same disk size and disk type IDE, BIOS = UEFI and Virtio ISO mounted to CDROM

02. copy vhdx to proxmox

03. qemu-img check -r all xxxxxxx.vhdx

04. qemu-img convert -f vhdx xxxxxxx.vhdx /dev/zvol/saspool/vms/vmxxx

05. verify boot option points to "ide0" and "qemu agent" = YES

06. boot windows

07. add device drivers "PCI communications" -> CDROM\vioserial\xx\yy

08. install qemu-agent

09. add legacy device drivers; balloon, kvmnet, storio, scsi

10. shutdown windows

11. add "virtio" disk 1GB

12. change network to "virtio"

13. boot windows

14. verify windows detects new (virtio) disk

15. shutdown

16. remove, remove virto 1GB disk

17. remove ide0 disk

18. change ide0 to Virtio

19.change boot options -> virtio0

20. start windows

21. done
 
  • Like
Reactions: Jens Kl

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!