HP DL 380 G8 cant boot with Proxmox and H240 HBA

Daniel Luyckx

Member
Jul 23, 2019
31
2
13
23
Hello, i have a DL 380 G8 with a HP H240 which i set in linux in HBA mode.

Proxmox setup aknowledges all drives and its fine in setup.

With Proxmox 7.1 the Problem was, that proxmox bootet exactly 1 time after the install and then the grub is no longer found.

With Proxmox 7.2 the Problem is now, that Proxmox doesnt boot anymore after the install.

i just tryed it with a LSI 9210-8i but which configuration i dont know yet. it doesnt work either.

In the BIOS i set the Boot Device order with the "Mass Storage" to the top and its the single one there. i disabled onboard SATA.

Please.. i am fighting since december last year to get it run on the HP Server.. Wanna abandon ESXI..

Any Suggestion?

Greetings
 

Daniel Luyckx

Member
Jul 23, 2019
31
2
13
23
Just some Screenshots of the LSI Config.. Downloading Ubuntuu right now. But i think it wont work too.
 

Attachments

  • Unbenannt3.png
    Unbenannt3.png
    77.6 KB · Views: 8
  • Unbenannt2.png
    Unbenannt2.png
    105.6 KB · Views: 8
  • Unbenannt.png
    Unbenannt.png
    118.4 KB · Views: 8

Daniel Luyckx

Member
Jul 23, 2019
31
2
13
23
You will not be able to boot from NVMe with G8 HP servers, you need UEFI for that, and DL 380P G8 is BIOS only.
Hello,
i got it working.

i used a Delock 3 Port SATA und 2 Slot M.2 Key B PCI Express x4 Karte - Low Profile (https://www.ebay.de/itm/373165712808) and a 4x SATA to 1x SAS adapter cable to connect it to the motherboard.

Its working great. Im using 2 HP SSDs in ZFS RAID 1. Even the SMART Values are transmitted.

Thanks
 

Attachments

  • Unbenannt.png
    Unbenannt.png
    54.1 KB · Views: 5

POleszkiewicz

New Member
May 26, 2022
3
0
1
I guess you would get a lot more performance from H240 HBA + boot partition on SD Card , but I am happy you got it working :)
 

Daniel Luyckx

Member
Jul 23, 2019
31
2
13
23
I guess you would get a lot more performance from H240 HBA + boot partition on SD Card , but I am happy you got it working :)
I have a H240 in HBA mode. I cant boot from it. I can boot one Time and then no more. it took 6 months to get proxmox running on that server.
The H240 doesnt transmit SMART values either. But ZFS should be able to report a failed Hard Drive, i hope.

I was said that i should avoid SD Card because of the write cycles.

Greeings
 

POleszkiewicz

New Member
May 26, 2022
3
0
1
You should not RUN from SD card, however a /boot partition and a bootloader on an SD card work well. you write to /boot only when you change boot config or upgrade kernel :) When the machine boots and loads the kernel from SD it will start the kernel and continue to boot from the HBA, the normal system operation will be backed by HBA then :)
 

Daniel Luyckx

Member
Jul 23, 2019
31
2
13
23
Yes i understand. Thank you.
Im glad its now working good. And i can change all "Arrays" without moving the Proxmox OS to another array.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!