How do I backup and restore VMs and CTs?

Ryan210

New Member
Sep 17, 2021
2
0
1
24
Some background information:
I have 1 server connecting 4 Proxmox Nodes. They were all on the 5.0 version, but I wanted to upgrade them to 6.1. I upgraded 1 node to 6.1 and I want to backup VMs from the other 3 nodes on the 5.0 version into the 6.0 version. I also do not have any internet access. I read that I have to do it externally, but I am having trouble on that.

Thanks in advance!
 

Ryan210

New Member
Sep 17, 2021
2
0
1
24

I went through it and I can backup successfully but when I attempt to restore from GUI or command line, I get the error of:

Job for rpc-statd.service failed because the control process exited with error code.
See "systemctl status rpc-statd.service" and "journalctl -xe" for details.
mount.nfs: rpc.statd is not running but is required for remote locking.
TASK ERROR: mount error: mount.nfs: Either use '-o nolock' to keep locks local, or start statd.

To read on a previous forum that I should enable rpcbind.service so I ran the command:
systemctl enable rpcbind.service

Then I ran the command:
systemctl start rpcbind.service

I received the message:
Job for rpcbind.service failed because the control process exited with error code.
See "systemctl status rpcbind.services" and "journalctl -xe" for details.

When I run "systemctl static rpcbind.services":
rpcbind.service - RPC bind portmap service
Loaded: loaded (/lib/systemd/system/rpcbind.service; enabled; vender preset: enabled)
Active: failed (Result: exit-code) since Thu 2021-09-23 09:37P:00 CDT; 9s ago
Docs: man:rpcbind(8)
Process: 23439 ExecStart=/sbin/rpcbind -f $OPTIONS (code=exited, status=1/FAILURE)
Main PID: 23439 (code=exited, status=1/FAILURE)
rpcbind.service: Service restartSec=100ms expired scheduling start.
rpcbind.service: Scheduled restart job, restart counter is at 5.
Stopped RPC bind portmap service.
rpcbind.service: Start request repeated too quickly.
rpcbind.service: Failed with result 'exit-code'.
Failed to start RPC bind portmap service.

I am unsure what to do at this stage. Backing up vms and cts works well, but restoring has just given me those errors as of now.
As a side note, I am running on root.

Thank you and I appreciate your help.
 

dcsapak

Proxmox Staff Member
Staff member
Feb 1, 2016
6,516
735
133
33
Vienna
check the syslog / journal. there should be more information about why that service fails.

it seems the node is not able to mount your nfs server?
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!