Host not reachable on 2nd NIC / network

e36Alex

New Member
Jan 1, 2021
5
0
1
38
Hello,

I added a 10G NIC to my Proxmox host a few days ago and changed the IP of the host to another VLAN (10) at the 10G NIC.
Now I can access the host at the new ip (192.168.10.151) and everything works fine, so far.

But I want to remain the access to the webgui at the "old" ip (192.168.1.151 - no VLAN). I tried out different configurations but sadly it doesn't work.

Can you help me to configure the network so I can reach the webgui on 192.168.1.151 and 192.168.10.151 ?

Thanks a lot!

Here is my actual config:

/etc/hosts
Code:
127.0.0.1 localhost.localdomain localhost
192.168.10.151 pve1.home.mydomain.de pve1
192.168.1.151 pve1

/etc/network/interfaces
Code:
auto lo
iface lo inet loopback

iface enp4s0 inet manual

iface enp5s0 inet manual
#1G - Port1

iface enp6s0 inet manual
#1G - Port2

iface ens4f0 inet manual
#10G - Port1

iface ens4f1 inet manual
#10G - Port2

auto vmbr0
iface vmbr0 inet static
        address 192.168.10.151/24
        gateway 192.168.10.1
        bridge-ports ens4f0.10
        bridge-stp off
        bridge-fd 0
#10G - Port1

auto vmbr1
iface vmbr1 inet manual
        bridge-ports enp6s0
        bridge-stp off
        bridge-fd 0
#1G - Port2

auto vmbr3
iface vmbr3 inet manual
        bridge-ports ens4f1
        bridge-stp off
        bridge-fd 0
#10G - Port2

auto vmbr2
iface vmbr2 inet static
        address 192.168.1.151/24
        bridge-ports enp5s0
        bridge-stp off
        bridge-fd 0
#1G - Port1

ip route
Code:
default via 192.168.10.1 dev vmbr0 proto kernel onlink
192.168.1.0/24 dev vmbr2 proto kernel scope link src 192.168.1.151
192.168.10.0/24 dev vmbr0 proto kernel scope link src 192.168.10.151
 
Last edited:

patch

Member
Aug 5, 2021
44
3
8
32
configure the network so I can reach the webgui on
The GUI should be available on
  • any bridge with a IP address set
  • and NIC/VLAN connected
  • Set via Proxmox -> Datacenter -> <pve> -> Network -> vmbr2 -> Edit -> Set IPv4/CIDR & Bridge ports

To access the GUI you then need to
  • Connect to the specified NIC/Vlan
  • At the specified Hypervisor IP address
  • From an IP address in the mask range

So what specifically is not working in particular which combination of NIC, VLAN, target (Hypervisor) IP address, source (PC) IP address
 
Last edited:

e36Alex

New Member
Jan 1, 2021
5
0
1
38
The GUI should be available on
  • any bridge with a IP address set
  • and NIC/VLAN connected
  • Set via Proxmox -> Datacenter -> <pve> -> Network -> vmbr2 -> Edit -> Set IPv4/CIDR & Bridge ports

To access the GUI you then need to
  • Connect to the specified NIC/Vlan
  • At the specified Hypervisor IP address
  • From an IP address in the mask range

So what specifically is not working in particular which combination of NIC, VLAN, target (Hypervisor) IP address, source (PC) IP address
Thanks for your reply.

This is already my configuration:
Bildschirmfoto 2021-12-20 um 19.50.59.png

I tried to ping from a host from the same subnet (192.168.1.2/24), but I don't get a connection.

Bildschirmfoto 2021-12-20 um 19.53.32.png

In my Unifi Controller I can see the ne NIC/MAC-Adress and the IP, but I can't get connected to it.
 

e36Alex

New Member
Jan 1, 2021
5
0
1
38
Hi,

its been a time now, but i still got the same problem. Anyone who can help me?

Thanks in advance,
Alex
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!