HELP: Failed to start Boot0001 "UEFI QEMU DVD-ROM" Time out

technician

New Member
Feb 2, 2021
5
0
1
20
I'm following this guide to set up GPU passthrough: https://www.reddit.com/r/homelab/comments/b5xpua/the_ultimate_beginners_guide_to_gpu_passthrough/

All was going great, I installed windows 10, and decided to remove the installer ISO device. Suddenly, I was getting weird install errors and decided to start over since I assumed I had broken the windows install. Bad idea I guess, because now all I get is this error:
1612323537042.png

I've added the ISO file and it is the first boot device. I really want to test GPU passthrough but now I can't even get to the installer. :(

Any idea what to do here?
 

technician

New Member
Feb 2, 2021
5
0
1
20
Update:

Pressing Escape let me manually select the drive. Still not sure why this error showed up when it didn't the first time, though.
 

relaydenied

New Member
Nov 3, 2021
5
0
1
60
Is this post still alive? I get this same message. I am not able to boot OVFM no matter what I try. I have selected every option available in the UEFI menu after pressing escape. This is happening to me on both an AMD and Intel box. As soon as I chose OVMF and q35 this is always the result when trying to load Windows 10 .iso as ide2. Here is my vm.conf:

root@PVE-Glass:/# cat /etc/pve/nodes/PVE-Glass/qemu-server/100.conf
agent: 1
bios: ovmf
boot: order=ide2;ide0;net0
cores: 4
cpu: host
efidisk0: local-lvm:vm-100-disk-1,size=4M
ide0: local:iso/virtio-win-0.1.208.iso,media=cdrom,size=543390K
ide2: local:iso/Win10_1909_English_x64.iso,media=cdrom
machine: pc-q35-6.0
memory: 10240
name: Win10Virt01
net0: e1000=B2:F6:B5:5F:CE:77,bridge=vmbr0,firewall=1
numa: 1
ostype: win10
scsi0: local-lvm:vm-100-disk-0,cache=writeback,discard=on,size=100G
scsihw: virtio-scsi-pci
smbios1: uuid=df4122bb-b651-43f0-8aae-e3b78e05c431
sockets: 1
vmgenid: 90107803-ac78-45cc-bd74-8c16f64a3906

Thank you for ANY input. I have been chasing this for two weeks for hours on end. I will supply any information you like.
 
Last edited:

dcsapak

Proxmox Staff Member
Staff member
Feb 1, 2016
8,039
986
163
34
Vienna
can you boot into any iso ? could you test with some linux live cd? (just to rule out a bad windows iso)
is anything visible in the journal when you try to boot ? (maybe attach that here)
 

relaydenied

New Member
Nov 3, 2021
5
0
1
60
can you boot into any iso ? could you test with some linux live cd? (just to rule out a bad windows iso)
is anything visible in the journal when you try to boot ? (maybe attach that here)
Thank YOU for responding. Have not abandoned post! Finding time to get you more information. Please stay tuned! Working on list of hardware configuration of both machines. Have tried multiple windows ISO and now trying Mint 20 Cinnamon.
 

relaydenied

New Member
Nov 3, 2021
5
0
1
60
Here is the info from the two machines. I have upgraded to 7.1-7. I have downloaded Win10, Win 11, and Mint 20 ISO's. Mint 20 works but neither windows ISO's will boot. I get the message above from OP. Proxmox 7.1-7 even defaults to OVMF & Q35 for Win 11 and I checked TPM. Attached is the output from an attempted Win11 boot to ISO for install. Which logs would you like to see? Again, thank you for the help.

MACHINE 1 (HyperHome)

CPU Data:
NUMA node(s): 1
Vendor ID: GenuineIntel
CPU family: 6
Model: 158
Model name: Intel(R) Core(TM) i7-8700K CPU @ 3.70GHz
Stepping: 10
CPU MHz: 3700.000
CPU max MHz: 4700.0000
CPU min MHz: 800.0000
BogoMIPS: 7399.70
Virtualization: VT-x
L1d cache: 192 KiB
L1i cache: 192 KiB
L2 cache: 1.5 MiB
L3 cache: 12 MiB
NUMA node0 CPU(s): 0-11


Memory:
RANGE SIZE STATE REMOVABLE BLOCK
0x0000000000000000-0x000000005fffffff 1.5G online yes 0-11
0x0000000100000000-0x0000000887ffffff 30.1G online yes 32-272

Memory block size: 128M
Total online memory: 31.6G
Total offline memory: 0B


GRUB:
GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet intel_iommu=on rd.modules-load=vfio-pci i915.enable_hd_vgaarb=1 libata.noacpi=1 hugepages=4096"
GRUB_CMDLINE_LINUX=""


vfio:
vfio_pci 57344 2
vfio_virqfd 16384 1 vfio_pci
irqbypass 16384 12 vfio_pci,kvm
vfio_iommu_type1 40960 1
vfio 36864 6 vfio_iommu_type1,vfio_pci


IOMMU:
root@HyperHome:~# dmesg | grep 'remapping'
[ 0.119334] DMAR-IR: Queued invalidation will be enabled to support x2apic and Intr-remapping.
[ 0.120750] DMAR-IR: Enabled IRQ remapping in x2apic mode

root@HyperHome:/usr/bin# find /sys/kernel/iommu_groups/ -type l
/sys/kernel/iommu_groups/17/devices/0000:07:00.0
/sys/kernel/iommu_groups/17/devices/0000:05:03.0
/sys/kernel/iommu_groups/7/devices/0000:00:1c.0
/sys/kernel/iommu_groups/15/devices/0000:04:00.0
/sys/kernel/iommu_groups/5/devices/0000:00:17.0
/sys/kernel/iommu_groups/13/devices/0000:02:00.0
/sys/kernel/iommu_groups/3/devices/0000:00:14.2
/sys/kernel/iommu_groups/3/devices/0000:00:14.0
/sys/kernel/iommu_groups/11/devices/0000:00:1f.2
/sys/kernel/iommu_groups/11/devices/0000:00:1f.0
/sys/kernel/iommu_groups/11/devices/0000:00:1f.3
/sys/kernel/iommu_groups/11/devices/0000:00:1f.4
/sys/kernel/iommu_groups/1/devices/0000:00:01.0
/sys/kernel/iommu_groups/1/devices/0000:01:00.0
/sys/kernel/iommu_groups/1/devices/0000:01:00.1
/sys/kernel/iommu_groups/18/devices/0000:05:05.0
/sys/kernel/iommu_groups/8/devices/0000:00:1c.2
/sys/kernel/iommu_groups/16/devices/0000:05:01.0
/sys/kernel/iommu_groups/16/devices/0000:06:00.0
/sys/kernel/iommu_groups/6/devices/0000:00:1b.0
/sys/kernel/iommu_groups/14/devices/0000:03:00.0
/sys/kernel/iommu_groups/4/devices/0000:00:16.0
/sys/kernel/iommu_groups/12/devices/0000:00:1f.6
/sys/kernel/iommu_groups/2/devices/0000:00:02.0
/sys/kernel/iommu_groups/20/devices/0000:0a:00.0
/sys/kernel/iommu_groups/10/devices/0000:00:1d.0
/sys/kernel/iommu_groups/0/devices/0000:00:00.0
/sys/kernel/iommu_groups/19/devices/0000:09:00.0
/sys/kernel/iommu_groups/19/devices/0000:05:07.0
/sys/kernel/iommu_groups/9/devices/0000:00:1c.4



Machine 2 (PVE-Glass)

CPU Data:
NUMA node(s): 1
Vendor ID: AuthenticAMD
CPU family: 23
Model: 113
Model name: AMD Ryzen 7 3800X 8-Core Processor
Stepping: 0
Frequency boost: enabled
CPU MHz: 3900.000
CPU max MHz: 4558.8862
CPU min MHz: 2200.0000
BogoMIPS: 7785.36
Virtualization: AMD-V
L1d cache: 256 KiB
L1i cache: 256 KiB
L2 cache: 4 MiB
L3 cache: 32 MiB
NUMA node0 CPU(s): 0-15


Memory:
Memory:
RANGE SIZE STATE REMOVABLE BLOCK
0x0000000000000000-0x000000107fffffff 66G online yes 0-32

Memory block size: 2G
Total online memory: 66G
Total offline memory: 0B


GRUB:
GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet amd_iommu=on"
GRUB_CMDLINE_LINUX=""


vfio:
vfio_pci 57344 1
vfio_virqfd 16384 1 vfio_pci
irqbypass 16384 11 vfio_pci,kvm
vfio_iommu_type1 36864 1
vfio 36864 5 vfio_iommu_type1,vfio_pci


IOMMU:
root@PVE-Glass:/usr/bin# dmesg | grep 'remapping'
[ 0.710109] AMD-Vi: Interrupt remapping enabled


root@PVE-Glass:/usr/bin# find /sys/kernel/iommu_groups -type l
/sys/kernel/iommu_groups/17/devices/0000:0c:00.4
/sys/kernel/iommu_groups/7/devices/0000:00:08.0
/sys/kernel/iommu_groups/15/devices/0000:0c:00.1
/sys/kernel/iommu_groups/5/devices/0000:00:07.0
/sys/kernel/iommu_groups/13/devices/0000:0b:00.0
/sys/kernel/iommu_groups/3/devices/0000:00:04.0
/sys/kernel/iommu_groups/11/devices/0000:00:14.3
/sys/kernel/iommu_groups/11/devices/0000:00:14.0
/sys/kernel/iommu_groups/1/devices/0000:00:02.0
/sys/kernel/iommu_groups/18/devices/0000:0d:00.0
/sys/kernel/iommu_groups/8/devices/0000:00:08.1
/sys/kernel/iommu_groups/16/devices/0000:0c:00.3
/sys/kernel/iommu_groups/6/devices/0000:00:07.1
/sys/kernel/iommu_groups/14/devices/0000:0c:00.0
/sys/kernel/iommu_groups/4/devices/0000:00:05.0
/sys/kernel/iommu_groups/12/devices/0000:00:18.3
/sys/kernel/iommu_groups/12/devices/0000:00:18.1
/sys/kernel/iommu_groups/12/devices/0000:00:18.6
/sys/kernel/iommu_groups/12/devices/0000:00:18.4
/sys/kernel/iommu_groups/12/devices/0000:00:18.2
/sys/kernel/iommu_groups/12/devices/0000:00:18.0
/sys/kernel/iommu_groups/12/devices/0000:00:18.7
/sys/kernel/iommu_groups/12/devices/0000:00:18.5
/sys/kernel/iommu_groups/2/devices/0000:00:03.1
/sys/kernel/iommu_groups/2/devices/0000:09:00.0
/sys/kernel/iommu_groups/2/devices/0000:0a:00.0
/sys/kernel/iommu_groups/2/devices/0000:00:03.2
/sys/kernel/iommu_groups/2/devices/0000:09:00.1
/sys/kernel/iommu_groups/2/devices/0000:00:03.0
/sys/kernel/iommu_groups/2/devices/0000:0a:00.1
/sys/kernel/iommu_groups/10/devices/0000:00:08.3
/sys/kernel/iommu_groups/0/devices/0000:03:00.0
/sys/kernel/iommu_groups/0/devices/0000:00:01.2
/sys/kernel/iommu_groups/0/devices/0000:00:01.0
/sys/kernel/iommu_groups/0/devices/0000:08:00.0
/sys/kernel/iommu_groups/0/devices/0000:02:03.0
/sys/kernel/iommu_groups/0/devices/0000:01:00.0
/sys/kernel/iommu_groups/0/devices/0000:07:00.0
/sys/kernel/iommu_groups/0/devices/0000:02:09.0
/sys/kernel/iommu_groups/0/devices/0000:06:00.0
/sys/kernel/iommu_groups/0/devices/0000:02:0a.0
/sys/kernel/iommu_groups/0/devices/0000:05:00.0
/sys/kernel/iommu_groups/0/devices/0000:02:08.0
/sys/kernel/iommu_groups/0/devices/0000:04:00.0
/sys/kernel/iommu_groups/0/devices/0000:02:01.0
/sys/kernel/iommu_groups/0/devices/0000:06:00.3
/sys/kernel/iommu_groups/0/devices/0000:02:04.0
/sys/kernel/iommu_groups/0/devices/0000:06:00.1
/sys/kernel/iommu_groups/19/devices/0000:0e:00.0
/sys/kernel/iommu_groups/9/devices/0000:00:08.2
 

Attachments

  • Screen Shot 2021-12-05 at 12.06.44 AM.png
    Screen Shot 2021-12-05 at 12.06.44 AM.png
    52.8 KB · Views: 9
Last edited:

dmayle

New Member
Dec 6, 2021
1
2
3
44
I had the same problem, but with a NixOS installation CD. In my case, the iso is not signed, and can't be started using SecureBoot (which is the default on the latest OVMF shipped with Proxmox). If you hit the escape key while it says 'Startup boot options' (and before it says the UEFI message about saying hitting escape that doesn't actually work), then you get into the UEFI menu which you can use to disable Secure Boot and then boot the iso
 

relaydenied

New Member
Nov 3, 2021
5
0
1
60
I had the same problem, but with a NixOS installation CD. In my case, the iso is not signed, and can't be started using SecureBoot (which is the default on the latest OVMF shipped with Proxmox). If you hit the escape key while it says 'Startup boot options' (and before it says the UEFI message about saying hitting escape that doesn't actually work), then you get into the UEFI menu which you can use to disable Secure Boot and then boot the iso
HHOOO OOOO LLLLYY CRAP! Thank YOU!

Mine was just a touch different though. I had to wait until the 'Boot Options' passed, then hit escape on the next screen and WOW! If I hit escape on the 'Boot Options' it took me to 'Boot Manager'. I had been there many times without success. Windows 11 is now installed. I am sure I will have a few pass through challenges, but Nice!

Thank YOU!!
 

Kamotz

New Member
Dec 24, 2020
1
0
1
39
THIS IS THE WAY!

I've been struggling to install TrueNAS. I have another VM that I created years ago, and I had no issues with the installer. But now that I've migrated to v7, I could not get the ISO to work. I've been googling for hours. Thank you.
 

relaydenied

New Member
Nov 3, 2021
5
0
1
60
@dmayle @relaydenied @Kamotz Was there anything else to configure? I'm running into the exact same issue, but I've already disabled 'secure boot' in the VM but still running into the issue.
It turns out my problem was very embarrassing. When it boots the Windows ISO there is a message in the console "Press any key to boot from CD or DVD". I was ignoring it with the impression it wasn't required and that the console would move forward. Turns out,,, it really does require you hit any key. I just hit enter.
 
Last edited:

WinManx2000

New Member
Apr 15, 2022
1
0
1
I had the same problem, but with a NixOS installation CD. In my case, the iso is not signed, and can't be started using SecureBoot (which is the default on the latest OVMF shipped with Proxmox). If you hit the escape key while it says 'Startup boot options' (and before it says the UEFI message about saying hitting escape that doesn't actually work), then you get into the UEFI menu which you can use to disable Secure Boot and then boot the iso
So, I have been lurking here for almost a year, getting ready to build my server. Finally got my r730XD and started setting things up and simply could not get true nas to install. Being new to servers, I am pulling my hair out thinking stuff is just plain broken.

Whelp.... not the case at all. This is 100% the solution to not being able to boot from CDROM. I have spent the better part of 1/2 day searching for the issue, thinking the sky was falling. Simply hit escape while the damn thing is booting, but before the actual escape message as that one does nothing.

I simply had to register to give you kudos for this solution. First Post!
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!