Having issues with cloud init ubnt 2004

ahmza

New Member
Aug 14, 2021
1
0
1
20
Hi Team,

been working with PVE for a few days now, I am looking into setting up a template for ubuntu 2004 that uses cloud init. However I'm having issues !!

So to start with its not an issue with PVE per say because when I used a cloud image from the ubuntu site everything worked fine, hostnames were changed as well as network settings etc ...

However I need a few base applications installed as well as zsh config etc on the template so I tried to create an image from scratch.

Steps were as follows:
  • create vm
    • added serial
    • added cloud-init drive
    • q35 (if that makes a difference)
    • default bios
  • installed ubuntu 2004 (server) as you normally would
  • made a few changed to cloud.cfg following this: https://www.youtube.com/watch?v=8qwnXd1yRK4
  • shutdown the machine
  • converted to template
  • cloned the template (full clone)
I'm not sure if I missed a step but when I cloned the template with a different vm name the hostname did not change and it did not set the IP Address.
before starting the VM I went into the cloud init tab and regenerated the image.
I tried without regenerating the image too but that did not work either.

I have attacehd the cloud.cfg

Thanks,
Hamza
 

Attachments

  • cloud.txt
    3.5 KB · Views: 4

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!