GUI issues with Firefox after upgrade

stacktrace

New Member
Sep 5, 2012
14
0
1
Germany
proxmox.stacktrace.de
Hi,

I have some strange issues after an 'apt dist-upgrade' today. The login mask behaves strange: I can neither change language nor realm. If I try I get an error message that the username is not given (via (!)-sign next to the input field. Then sometimes the Login-Button works, sometimes not. If it works, I see the GUI, but it does not react to clicks.

Tried on two different machines. In Chrome everything works fine.

Server is a standalone PVE upgraded from 4.3 today.

No error messages in /var/log/syslog

pveversion:
Code:
root@proxlab:~# pveversion -v
proxmox-ve: 4.4-79 (running kernel: 4.4.35-2-pve)
pve-manager: 4.4-12 (running version: 4.4-12/e71b7a74)
pve-kernel-4.4.35-1-pve: 4.4.35-77
pve-kernel-4.4.35-2-pve: 4.4.35-79
pve-kernel-4.4.21-1-pve: 4.4.21-71
pve-kernel-4.4.19-1-pve: 4.4.19-66
lvm2: 2.02.116-pve3
corosync-pve: 2.4.0-1
libqb0: 1.0-1
pve-cluster: 4.0-48
qemu-server: 4.0-107
pve-firmware: 1.1-10
libpve-common-perl: 4.0-90
libpve-access-control: 4.0-23
libpve-storage-perl: 4.0-73
pve-libspice-server1: 0.12.8-1
vncterm: 1.2-1
pve-docs: 4.4-3
pve-qemu-kvm: 2.7.1-1
pve-container: 1.0-93
pve-firewall: 2.0-33
pve-ha-manager: 1.0-40
ksm-control-daemon: 1.2-1
glusterfs-client: 3.5.2-2+deb8u3
lxc-pve: 2.0.7-1
lxcfs: 2.0.6-pve1
criu: 1.6.0-1
novnc-pve: 0.5-8
smartmontools: 6.5+svn4324-1~pve80
zfsutils: 0.6.5.8-pve14~bpo80
openvswitch-switch: 2.6.0-2

Someone any ideas?
 

Q-wulf

Well-Known Member
Mar 3, 2013
609
31
48
my test location
t.lamprecht said:
Hi,
Can you try to reload the page first with empty browser cache (Shift + F5 or CTRL + R should do this).

If that does not help please post the output of
Code:
systemctl status pve-manager

See if this is a quick-fix for your issue. (i typically force refresh the gui after it and get prompted for login credentials.
 
Dec 18, 2016
101
32
33
Hi,
If you have upgraded to Firefox 51.0.1 (I did on ubuntu 16.04) you probably have e10s enabled, it's enabled by default now.
I had similar issues too since the FF update: objects in the proxmox webgui dont respond, missing scroll bars.

In Chrome this issue wasn't there, same as in your case.
You can check if e10s is enabled in FF by going to about:support
If Multiprocess-windows has a higher number than 1, it's enabled.

I solved it for now by disabling e10s in FF:
Goto:
about:config
Goto:
browser.tabs.remote.autostart.2
switch it to false, restart FF

Don't know if this is the correct bug # for Ubuntu but this one comes close:
https://bugs.launchpad.net/ubuntu/+source/firefox/+bug/1627239
 
Dec 18, 2016
101
32
33
That's great! glad to help.
But eventually e10s should be able to work with the proxmox webgui.
I don't think the bug is in proxmox webgui.

I'm also a little puzzled where the real issue comes from.
Just tested with FF 51.0.1 in a Windows 10 VM, with e10s enabled, no issue.
On Ubuntu 16.04 on my laptop with e10s enabled, still an issue.
Created a new user and logged in with it, so completely new FF profile, issue exists (e10s enabled).

After reading the linked bug report again, I noticed that apparmor is not enabled by default on 16.04 for FF, so this bug report does not apply here.
That bug is specifically related to FF with apparmor enabled. I tested also with apparmor enabled and got same results as in the bug report, so much worse results than we got now. Still not usable enough.

While I was at it, tested with a fresh Ubuntu 16.04 VM on proxmox, with all latest updates, so FF 51.0.1, no issues with the webgui.

One other thing to mention. I have a Sophos UTM VM running inside proxmox.
When logging on to the UTM webgui some elements also don't work in FF, f.e. the Open Live Log Menu.
So even more reason its not a proxmox but FF issue, maybe in combination with Ubuntu.
 
Last edited:

blueduckdock

Member
Mar 18, 2016
16
0
6
116
Had the same issues but not in Linux. Not sure why but my Windows boxes are sucking with it but not FF on Linux (Fedora.) I'll try to check if e10 is enabled on just Windows for some reason (kinda makes no sense as both sides have the same addons.)

Edit- My windows does NOT have e10 enabled (already false- addons most likely) but won't work.
 
Last edited:
Dec 18, 2016
101
32
33
So, after some more testing I narrowed it down to FF in combinaton with a touch screen.
My laptop is a Dell XPS 13 with touch screen.
Testing with touch screen disabled in bios: issue is fixed.
This explaines why there was no issue when testing with the Ubuntu 16.04 VM, it has no touch screen.

But off course I want my touch screen enabled.
Found the following setting in FF:

dom.w3c_touch_events.enabled

It defaults to 2 (auto-detect).
Set it to 0 (disabled)
And the issue is fixed, touch screen enabled, e10s enabled.

It's still a workaround.
May this has something to do with detecting the regular webgui for desktops and the mobile webgui.
 
  • Like
Reactions: InQuize and aciueug

aciueug

New Member
Mar 10, 2017
1
0
1
38
So, after some more testing I narrowed it down to FF in combinaton with a touch screen.
My laptop is a Dell XPS 13 with touch screen.
Testing with touch screen disabled in bios: issue is fixed.
This explaines why there was no issue when testing with the Ubuntu 16.04 VM, it has no touch screen.

But off course I want my touch screen enabled.
Found the following setting in FF:

dom.w3c_touch_events.enabled

It defaults to 2 (auto-detect).
Set it to 0 (disabled)
And the issue is fixed, touch screen enabled, e10s enabled.

It's still a workaround.
May this has something to do with detecting the regular webgui for desktops and the mobile webgui.
Hi,
I had the same issue with Firefox 52 on Windows 10 1607 Enterprise.
Your solution worked, thank you!
 

Gapodo

New Member
Jun 6, 2017
1
0
1
24
Still a thing with FF 53.0.3 but fixable by setting the dom.w3c_touch_events.enabled to 0 (big thanks to janssensm for the fix)
My pveversion -v (if anyone is interested in the versions I'm currently using)
Code:
proxmox-ve: 4.4-88 (running kernel: 4.4.62-1-pve)
pve-manager: 4.4-13 (running version: 4.4-13/7ea56165)
pve-kernel-4.4.62-1-pve: 4.4.62-88
lvm2: 2.02.116-pve3
corosync-pve: 2.4.2-2~pve4+1
libqb0: 1.0.1-1
pve-cluster: 4.0-50
qemu-server: 4.0-110
pve-firmware: 1.1-11
libpve-common-perl: 4.0-95
libpve-access-control: 4.0-23
libpve-storage-perl: 4.0-76
pve-libspice-server1: 0.12.8-2
vncterm: 1.3-2
pve-docs: 4.4-4
pve-qemu-kvm: 2.7.1-4
pve-container: 1.0-100
pve-firewall: 2.0-33
pve-ha-manager: 1.0-40
ksm-control-daemon: 1.2-1
glusterfs-client: 3.5.2-2+deb8u3
lxc-pve: 2.0.7-4
lxcfs: 2.0.6-pve1
criu: 1.6.0-1
novnc-pve: 0.5-9
smartmontools: 6.5+svn4324-1~pve80
openvswitch-switch: 2.6.0-2

Thank you for your work, I were almost at the point of starting up "internet explorer"...
Hoping this gets fixed in the near future...
 

dcsapak

Proxmox Staff Member
Staff member
Feb 1, 2016
4,894
486
103
32
Vienna
we already track this bug here:

https://bugzilla.proxmox.com/show_bug.cgi?id=1223

but this is not easily fixed from our side since the bug is in extjs (or firefox even?), so until either fixes it (and sencha releases a gpl version of their framework; which does not happen often) we cannot really do anything
 
Dec 18, 2016
101
32
33
Apparently Firefox 56 resets the value of dom.w3c_touch_events.enabled to default (2).
The package upgrade was released on OpenSUSE Tumbleweed this morning.
After the upgrade on my system the issue reappeared, but setting the value to 0 fixed it again.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!