GlusterFS throwing mem_pools_init_early lookup error


Active Member
Jun 17, 2017
I am trying to get two of my GlusterFS clusters to mount to my proxmox host and I keep running into undefined symbol: mem_pools_init_early lookup errors. This is the output when I try running mounting the clusters:
/usr/sbin/glusterfs: symbol lookup error: /usr/sbin/glusterfs: undefined symbol: mem_pools_init_early
Mount failed. Please check the log file for more details.
The same output happens when I try running glusterfs command:
root@vhost1:~# glusterfs
glusterfs: symbol lookup error: glusterfs: undefined symbol: mem_pools_init_early
Here's the list of packages for GlusterFS:
root@vhost1:~# dpkg -l | grep gluster
ii  glusterfs-client                     5.5-3                       amd64        clustered file-system (client package)
ii  glusterfs-common                     5.5-3                       amd64        GlusterFS common libraries and translator modules
ii  libglusterfs-dev                     6.6-ubuntu1~focal1          amd64        Development files for GlusterFS libraries
ii  libglusterfs0:amd64                  6.6-ubuntu1~focal1          amd64        GlusterFS shared library
I noticed the last two shouldn't be there according to some articles I came across when trying to solve this problem.

There are a number of steps I tried to fix the problem:
1) Tried removing glusterfs-client and glusterfs-common and reinstalling them. Couldn't do that without having to remove all of Proxmox's installed packages.
2) Tried installing glusterfs packages via .deb from GlusterFS website and the conflict errors prevented me from doing so:

root@vhost1:~# dpkg -i glusterfs-common_6.5-1_amd64.deb
dpkg: considering removing libglusterfs-dev in favour of glusterfs-common ...
dpkg: no, cannot proceed with removal of libglusterfs-dev (--auto-deconfigure will help):
 glusterfs-common depends on libglusterfs-dev
  libglusterfs-dev is to be removed.

dpkg: regarding glusterfs-common_6.5-1_amd64.deb containing glusterfs-common:
 glusterfs-common conflicts with libglusterfs-dev
  libglusterfs-dev (version 6.6-ubuntu1~focal1) is present and installed.

dpkg: error processing archive glusterfs-common_6.5-1_amd64.deb (--install):
 conflicting packages - not installing glusterfs-common
Errors were encountered while processing:

I could not seem to find a way on how to fix the packages without having to nuke Proxmox host and reinstall it from scratch. Is there any suggestions you guys may have to solve this? I believe this error is created when I tried using GlusterFS v6.5 instead of the built-in one that came with Proxmox. I was hoping to use v6.5 as my clusters are running on v6.5.

For your reference, I am running Proxmox v6.0-11.

Thank you and much appreciated.
Reinstalling Proxmox seems to fix the issue. Using Proxmox's built-in GlusterFS v5.5 works fine with my GlusterFS cluster that's running on v6.0.


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!