[GELÖST] X-SPAM-LEVEL bei ham-Mails

Discussion in 'Proxmox Mail Gateway (Deutsch)' started by ojaksch, Sep 24, 2018.

  1. ojaksch

    ojaksch Member

    Joined:
    Oct 11, 2015
    Messages:
    62
    Likes Received:
    7
    Ahoi!
    Ich habe das PMG 5.x als vorgelagertes Relay für ein Postfix/Dovecot-Gespann nun seit etwas über einen Monat laufen und bin sehr zufrieden.
    Aber da man ja immer etwas zu schrauben hat: Ich würde gerne X-SPAM-LEVEL für ham-Mails einbauen, aber fürchte, ich verstehe den Wald vor lauter Bäumen nicht. Als Ideen-Vorlage bin ich nach https://forum.proxmox.com/threads/adding-flag-to-the-spam-mail-header.415/ gegangen, aber es funktioniert nicht und scheint keinerlei Auswirkungen zu haben.

    Auf dem Postfix/Dovecot-Gespann hatte ich dies über amavisd gelöst und würde es gerne zeitweise auch beim PMG so handhaben können.
     
  2. tom

    tom Proxmox Staff Member
    Staff Member

    Joined:
    Aug 29, 2006
    Messages:
    13,028
    Likes Received:
    333
    Einfach die Regel "Modify Spam Level" aktivieren?

    Damit wird im Email Header das Ergebnis der Spam Analyse in die Email Headers geschrieben.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. ojaksch

    ojaksch Member

    Joined:
    Oct 11, 2015
    Messages:
    62
    Likes Received:
    7
    Hmm, ist aktiv. Ich meine sogar, dass sie das per Default war. Spam's tragen den X-SPAM-LEVEL Header ja auch, ich hätte den Header nur gerne auch in Ham's drinne...
     
  4. tom

    tom Proxmox Staff Member
    Staff Member

    Joined:
    Aug 29, 2006
    Messages:
    13,028
    Likes Received:
    333
    Dann ist die Regel oder die Priorität falsch.

    Sollte so aussehen, damit es in allen emails gesetzt wird.
     

    Attached Files:

    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. ojaksch

    ojaksch Member

    Joined:
    Oct 11, 2015
    Messages:
    62
    Likes Received:
    7
    Rätselhaft. Sieht bei mir absolut identisch aus. Ich habe an den Regeln (qua am ganzen Block Mail Filter) auch noch nicht gewurschtelt.
    Ich schaue mal, was mir die Factory Defaults der Mail Filter bringen. Vielleicht habe ich ja doch irgendwann irgendwo dort etwas verhauen...
     
  6. tom

    tom Proxmox Staff Member
    Staff Member

    Joined:
    Aug 29, 2006
    Messages:
    13,028
    Likes Received:
    333
    Sind die SMTP ports richtig? Lande die eingehende Emails am richtigen Port?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. ojaksch

    ojaksch Member

    Joined:
    Oct 11, 2015
    Messages:
    62
    Likes Received:
    7
    Ja, das sollten sie sein ;) denn das (von mir eingerichtete) PMG läuft jetzt seit gut drei Wochen produktiv (nach ~drei Wochen Testphase) und, wie Eingangs erwähnt, ganz ausgezeichnet. Niemand vermisst Mails und die Block- bzw. Reject-Quote ist noch höher als bei bei meinem Postfix/Amavisd/SQLgrey/Dovecot-Gespann. Und mit letzterem lag ich schon ziemlich gut :)

    Edit: External SMTP Port ist 25, Internal 26, das Ganze geht danach vom PMG über Port 587 an die Postfix/Dovecot VM (mit jetzt abgeschaltetem amavisd/sqlgrey).
     
    #7 ojaksch, Sep 25, 2018
    Last edited: Sep 25, 2018
  8. ojaksch

    ojaksch Member

    Joined:
    Oct 11, 2015
    Messages:
    62
    Likes Received:
    7
    Ich antworte mir mal selber: @tom hat natürlich Recht. PMG setzt die X-SPAM-LEVEL Header immer, sowohl für Spam, als auch für Ham.
    Bei mir lag das Problem der eben nicht von PMG erzeugten Header für Ham daran, dass ich wohl im nüchternen Zustand amavisd auf dem nachgelagerten Mailserver sehr wohl doch wieder aktiviert hatte und mich darauf verlassen hatte, dass dort die Regel
    Code:
    @client_ipaddr_policy = (
     [qw( 0.0.0.0/8 127.0.0.1/8 [::] [::1] )] => 'MYNETS',
     [qw( !172.16.1.0/24 172.16.0.0/12 192.168.0.0/16 )] => 'MYNETS',
     \@mynetworks => 'MYNETS',
    );
    
    $policy_bank{'MYNETS'} = {   # mail originating from @mynetworks
     originating => 1,  # is true in MYNETS by default, but let's make it explicit
     os_fingerprint_method => undef,  # don't query p0f for internal clients
     bypass_spam_checks_maps   => [1], # don't spam-check internal mail
     bypass_virus_checks_maps   => [1], # don't virus-check internal mail
    };
    die weitere Behandlung überspringt.
    Das funktioniert zwar soweit auch, aber amavisd schnippelt dennoch eventuell vorhandene scanned by/spam_header per Default weg. Abhilfe brachte dann letztendlich das Hinzufügen von
    Code:
    $remove_existing_x_scanned_headers = 0; # leave existing X-Virus-Scanned alone
    $remove_existing_spam_headers = 0;     # leave existing X-Spam* headers alone
    zu den amavisd Configs.

    Ende, aus die Maus. Prost!
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice