Funky blinking underscore, NVIDIA passthrough, code 43... boot loader hangover?

awarlt12207

New Member
Feb 9, 2020
2
0
1
22
First of all this used to work fine. It took me a long time to configure the first time, but eventually I resolved all the roadblocks (GPU romfile and everything), and had this setup working fine for many weeks. (besides a few weird Proxmox host crashes with certain USB devices being passed through)

Then I got cocky and tried to passthrough my motherboard USB controller (in part, an attempt to solve the USB device/port passthrough crashes), which never worked - it would always crash the entire host when starting a VM with it passed through.

Anyway, after screwing around with the USB controller, I somewhere along the lines broke my GPU passthrough. I don't know when, or how, but I have... and now I'm stuck with Code 43, and a blinking cursor on my screen as shown in the attached photo. It would appear that the cursor is a hangover from the bios / boot loader, as it's not in the screen capture from Windows.

I'm well and truly out of my depth, but perhaps someone smarter than me will know exactly what's causing the blinking underscore, which I would imagine is the problem leading up to the code 43.
 

Attachments

awarlt12207

New Member
Feb 9, 2020
2
0
1
22
H** s***. The blinking cursor has transformed into a (useable) Proxmox terminal, with Windows rendered on top. No wonder it's giving a code 43... but how do I get Proxmox to stop fingering my GPU.

"lspci -v" shows my GPU device as "Kernel driver in use: vfio-pci", not sure how Proxmox is also able to use it as a terminal display.
 

Attachments

dcsapak

Proxmox Staff Member
Staff member
Feb 1, 2016
4,630
438
103
32
Vienna
can you post your vm config ? and maybe a dmesg output during vm boot ?
 

uriel

New Member
Apr 12, 2020
9
0
1
40
Hi,

Today I have the blinking underscore onto the screen and the Error 43.

I also have a new error message when I start my Windows 10 VM

Code:
kvm: -device vfio-pci,host=0000:09:00.0,id=hostpci0.0,bus=ich9-pcie-port-1,addr=0x0.0,multifunction=on,romfile=/usr/share/kvm/current.rom: Failed to mmap 0000:09:00.0 BAR 3. Performance may be slow
calling:
Code:
echo 0 > /sys/devices/virtual/vtconsole/vtcon1/bind
solve the blinking underscore issue, but not the Error43

calling:
Code:
echo efi-framebuffer.0 > /sys/devices/platform/efi-framebuffer.0/driver/unbind
remove the
Failed to mmap 0000:09:00.0 BAR 3. Performance may be slow
error message.

But I still having the Error 43 on my Geforce 1060.

providing the correct romfile and providing a
hv_vendor_id=somthing
use to solve my Error 43 issue

my passthrough options in my qemu-server config is:
hostpci0: 09:00,x-vga=on,pcie=on,romfile=current.rom
the current.rom choosed by a script to match the current GFX.

finally by removing
blacklist nvidia
in /etc/modprobe.d/blacklist.conf
options vfio-pci ids=10de:xxxx,10de:xxxx disable_vga=1
in /etc/modprobe.d/vfio.conf
setting

GRUB_CMDLINE_LINUX_DEFAULT="quiet amd_iommu=on iommu=pt"
in /etc/default/grub
the error 43 Done.

Any point of view about my case.
I still have to fix my sound glitches
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!