Failover IP (again)

Xela

Active Member
Oct 12, 2017
49
0
26
52
Hi there, after endless attempts, I turn to you.

auto eth2
iface eth2 inet manual

auto vmbr0
iface vmbr0 inet static
address 1xx.2xx.3xx.4xx
netmask 255.255.255.0
gateway 1xx.2xx.3xx.254
broadcast 1xx.2xx.3xx.255
bridge_ports eth2
bridge_stp off
bridge_fd 0
network 1xx.2xx.3xx.0

Works well on the host, but adding a vmbr1 fails:

auto vmbr1
iface vmbr1 inet static
address 1zz.2zz.3zz.4zz # FO IP
netmask 255.255.255.255 # 1 specific
broadcast 1zz.2zz.3zz.4zz # FO IP
post-up route add 1xx.2xx.3xx.254 dev eth2
post-up route add default gw 1xx.2xx.3xx.254
post-down route del default gw 1xx.2xx.3xx.254
post-down route del 1xx.2xx.3xx.254 dev eth2

Any recommendation is welcome.
 

Xela

Active Member
Oct 12, 2017
49
0
26
52
OK, new trial with a new VM (https://docs.ovh.com/gb/en/dedicated/network-bridging/):
VM (2016 eval), Bridged mode vmbr0, MAC xx:xx:xx:xx:xx:xx (from OVH FO IP), eth2

auto eth2
iface eth2 inet manual

auto vmbr0
iface vmbr0 inet static
address 1xx.2xx.3xx.4xx
netmask 255.255.255.0
gateway 1xx.2xx.3xx.254
broadcast 1xx.2xx.3xx.255
bridge_ports eth2
bridge_stp off
bridge_fd 0
network 1xx.2xx.3xx.0
mtu 1450

In VM (2016), APIPA deactivated in Registry (https://social.technet.microsoft.co...le-autoconfiguration-ipv4-?forum=winserverNIS):

IP: 1zz.2zz.3zz.4zz (Failover IP)
SM: 255.255.255.255
D GW: 1xx.2xx.3xx.254
DNS: 213.186.33.99

But the NIC of the VM shows now 'Media disconnected'.
What did I forget?
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!