Failed 5 to 6 upgrade - "The following packages have unmet dependencies"

hacman

Active Member
Oct 11, 2013
84
4
28
Newcastle upon Tyne, UK
Hi all,

During the upgrade of one of our nodes from PVE 5 to 6, we had an interruption.

As such, when we now try to re-run the process we get:

Code:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... failed.
The following packages have unmet dependencies:
 ceph-common : Depends: libcurl4 (>= 7.28.0) but it is not installed
 dmsetup : Depends: libdevmapper1.02.1 (>= 2:1.02.138) but 2:1.02.137-pve6 is installed
 libapparmor-perl : Depends: perl-base (>= 5.28.1-5) but 5.24.1-3+deb9u7 is installed
                    Depends: perlapi-5.28.1
 libauthen-pam-perl : Depends: perl (>= 5.28.0-3) but 5.24.1-3+deb9u7 is installed
                      Depends: perlapi-5.28.0
 libcrypt-ssleay-perl : Depends: perl (>= 5.28.0-3) but 5.24.1-3+deb9u7 is installed
                        Depends: perlapi-5.28.0
 libpve-u2f-server-perl : Depends: perl (>= 5.28.1-6) but 5.24.1-3+deb9u7 is installed
                          Depends: perlapi-5.28.1
 librados2-perl : Depends: perl (>= 5.28.1-6) but 5.24.1-3+deb9u7 is installed
                  Depends: perlapi-5.28.1
 librgw2 : Depends: libcurl4 (>= 7.28.0) but it is not installed
 libterm-readline-gnu-perl : Depends: perl (>= 5.28.1-3) but 5.24.1-3+deb9u7 is installed
                             Depends: perlapi-5.28.1
 libtext-charwidth-perl : Depends: perl-base (>= 5.28.0-3) but 5.24.1-3+deb9u7 is installed
                          Depends: perlapi-5.28.0
 libxml-libxml-perl : Depends: perl (>= 5.28.1-4) but 5.24.1-3+deb9u7 is installed
                      Depends: perlapi-5.28.1
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies

We've tried a few things to clean the apt config, but even going as far as "dpkg --configure -a" gives us:

Code:
dpkg: dependency problems prevent configuration of libtext-charwidth-perl:
 libtext-charwidth-perl depends on perl-base (>= 5.28.0-3); however:
  Version of perl-base on system is 5.24.1-3+deb9u7.
 libtext-charwidth-perl depends on perlapi-5.28.0; however:
  Package perlapi-5.28.0 is not installed.

dpkg: error processing package libtext-charwidth-perl (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libapparmor-perl:amd64:
 libapparmor-perl:amd64 depends on perl-base (>= 5.28.1-5); however:
  Version of perl-base on system is 5.24.1-3+deb9u7.
 libapparmor-perl:amd64 depends on perlapi-5.28.1; however:
  Package perlapi-5.28.1 is not installed.

dpkg: error processing package libapparmor-perl:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of librados2-perl:
 librados2-perl depends on perl (>= 5.28.1-6); however:
  Version of perl on system is 5.24.1-3+deb9u7.
 librados2-perl depends on perlapi-5.28.1; however:
  Package perlapi-5.28.1 is not installed.

dpkg: error processing package librados2-perl (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of librgw2:
 librgw2 depends on libcurl4 (>= 7.28.0); however:
  Package libcurl4 is not installed.

dpkg: error processing package librgw2 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libterm-readline-gnu-perl:
 libterm-readline-gnu-perl depends on perl (>= 5.28.1-3); however:
  Version of perl on system is 5.24.1-3+deb9u7.
 libterm-readline-gnu-perl depends on perlapi-5.28.1; however:
  Package perlapi-5.28.1 is not installed.

dpkg: error processing package libterm-readline-gnu-perl (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libpve-u2f-server-perl:
 libpve-u2f-server-perl depends on perl (>= 5.28.1-6); however:
  Version of perl on system is 5.24.1-3+deb9u7.
 libpve-u2f-server-perl depends on perlapi-5.28.1; however:
  Package perlapi-5.28.1 is not installed.

dpkg: error processing package libpve-u2f-server-perl (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of python-rgw:
 python-rgw depends on librgw2 (>= 12.2.13-pve1); however:
  Package librgw2 is not configured yet.

dpkg: error processing package python-rgw (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libauthen-pam-perl:
 libauthen-pam-perl depends on perl (>= 5.28.0-3); however:
  Version of perl on system is 5.24.1-3+deb9u7.
 libauthen-pam-perl depends on perlapi-5.28.0; however:
  Package perlapi-5.28.0 is not installed.

dpkg: error processing package libauthen-pam-perl (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libxml-libxml-perl:
 libxml-libxml-perl depends on perl (>= 5.28.1-4); however:
  Version of perl on system is 5.24.1-3+deb9u7.
 libxml-libxml-perl depends on perlapi-5.28.1; however:
  Package perlapi-5.28.1 is not installed.

dpkg: error processing package libxml-libxml-perl (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of ceph-common:
 ceph-common depends on python-rgw (= 12.2.13-pve1); however:
  Package python-rgw is not configured yet.
 ceph-common depends on libcurl4 (>= 7.28.0); however:
  Package libcurl4 is not installed.

dpkg: error processing package ceph-common (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of dmsetup:
 dmsetup depends on libdevmapper1.02.1 (>= 2:1.02.138); however:
  Version of libdevmapper1.02.1:amd64 on system is 2:1.02.137-pve6.

dpkg: error processing package dmsetup (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libcrypt-ssleay-perl:
 libcrypt-ssleay-perl depends on perl (>= 5.28.0-3); however:
  Version of perl on system is 5.24.1-3+deb9u7.
 libcrypt-ssleay-perl depends on perlapi-5.28.0; however:
  Package perlapi-5.28.0 is not installed.

dpkg: error processing package libcrypt-ssleay-perl (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of ceph-base:
 ceph-base depends on ceph-common (= 12.2.13-pve1); however:
  Package ceph-common is not configured yet.

dpkg: error processing package ceph-base (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of ceph-mgr:
 ceph-mgr depends on ceph-base (= 12.2.13-pve1); however:
  Package ceph-base is not configured yet.

dpkg: error processing package ceph-mgr (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of ceph-osd:
 ceph-osd depends on ceph-base (= 12.2.13-pve1); however:
  Package ceph-base is not configured yet.

dpkg: error processing package ceph-osd (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of ceph-mon:
 ceph-mon depends on ceph-base (= 12.2.13-pve1); however:
  Package ceph-base is not configured yet.

dpkg: error processing package ceph-mon (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of ceph:
 ceph depends on ceph-mgr (= 12.2.13-pve1); however:
  Package ceph-mgr is not configured yet.
 ceph depends on ceph-mon (= 12.2.13-pve1); however:
  Package ceph-mon is not configured yet.
 ceph depends on ceph-osd (= 12.2.13-pve1); however:
  Package ceph-osd is not configured yet.

dpkg: error processing package ceph (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 libtext-charwidth-perl
 libapparmor-perl:amd64
 librados2-perl
 librgw2
 libterm-readline-gnu-perl
 libpve-u2f-server-perl
 python-rgw
 libauthen-pam-perl
 libxml-libxml-perl
 ceph-common
 dmsetup
 libcrypt-ssleay-perl
 ceph-base
 ceph-mgr
 ceph-osd
 ceph-mon
 ceph

I'd guess that the best way to move forward is if we somehow force the version upgrade of the dependency pakcages mentioned in the first snippet, but I'm not sure how to do this without hosing the entire system now, as cleanly removing and re-installing seems to be a no-go.

Anyone have experience or ideas?

Thanks,

Jon
 

fabian

Proxmox Staff Member
Staff member
Jan 7, 2016
8,419
1,678
174
please verify your APT package repository lists (or post them here).
 
  • Like
Reactions: hacman

hacman

Active Member
Oct 11, 2013
84
4
28
Newcastle upon Tyne, UK
Hi Fabian,

Please find the requested info below.

/etc/apt/sources.list:
Code:
deb http://ftp.debian.org/debian buster main contrib

# PVE pve-no-subscription repository provided by proxmox.com,
# NOT recommended for production use
deb http://download.proxmox.com/debian/pve buster pve-no-subscription

# security updates
deb http://security.debian.org buster/updates main contrib

The enterprise repo in /etc/apt/sources.d/pve-enterprise.list is commented out.

Thanks,

Jon
 

aaron

Proxmox Staff Member
Staff member
Jun 3, 2019
3,152
537
118
What's the output of apt update?
 
  • Like
Reactions: hacman

hacman

Active Member
Oct 11, 2013
84
4
28
Newcastle upon Tyne, UK
Hi Aaron,

Please find the requested info below.

Code:
root@[HOST]:/etc/apt/sources.list.d# apt update
Hit:1 http://security.debian.org buster/updates InRelease                                                                                           
Hit:2 http://ftp.debian.org/debian buster InRelease                                                                                                 
Hit:3 http://download.proxmox.com/debian/pve buster InRelease                                                                           
Hit:4 http://download.proxmox.com/debian/ceph-luminous buster InRelease                                                                 
Hit:5 http://download.proxmox.com/debian/corosync-3 stretch InRelease                                             
Hit:6 http://repo.zabbix.com/zabbix/3.4/debian stretch InRelease                           
Ign:7 http://downloads.linux.hpe.com/SDR/repo/mcp stretch/current InRelease
Hit:8 http://downloads.linux.hpe.com/SDR/repo/mcp stretch/current Release
Reading package lists... Done
Building dependency tree       
Reading state information... Done
461 packages can be upgraded. Run 'apt list --upgradable' to see them.

Thanks,

Jon
 

aaron

Proxmox Staff Member
Staff member
Jun 3, 2019
3,152
537
118
Code:
Hit:6 http://repo.zabbix.com/zabbix/3.4/debian stretch InRelease                           
Ign:7 http://downloads.linux.hpe.com/SDR/repo/mcp stretch/current InRelease
Hit:8 http://downloads.linux.hpe.com/SDR/repo/mcp stretch/current Release

Disable these repos and try again.
 
  • Like
Reactions: hacman

hacman

Active Member
Oct 11, 2013
84
4
28
Newcastle upon Tyne, UK
Hi Aaron,

I get the same result with those disabled too I'm afraid:

Code:
root@[HOST]:/etc/apt/sources.list.d# apt update
Hit:1 http://ftp.debian.org/debian buster InRelease                                                                     
Hit:2 http://security.debian.org buster/updates InRelease                                                               
Hit:3 http://download.proxmox.com/debian/pve buster InRelease
Hit:4 http://download.proxmox.com/debian/ceph-luminous buster InRelease
Hit:5 http://download.proxmox.com/debian/corosync-3 stretch InRelease
Reading package lists... Done
Building dependency tree       
Reading state information... Done
461 packages can be upgraded. Run 'apt list --upgradable' to see them.

root@[HOST]:/etc/apt/sources.list.d# apt dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 ceph-common : Depends: libcurl4 (>= 7.28.0) but it is not installed
 dmsetup : Depends: libdevmapper1.02.1 (>= 2:1.02.138) but 2:1.02.137-pve6 is installed
 libapparmor-perl : Depends: perl-base (>= 5.28.1-5) but 5.24.1-3+deb9u7 is installed
                    Depends: perlapi-5.28.1
 libauthen-pam-perl : Depends: perl (>= 5.28.0-3) but 5.24.1-3+deb9u7 is installed
                      Depends: perlapi-5.28.0
 libcrypt-ssleay-perl : Depends: perl (>= 5.28.0-3) but 5.24.1-3+deb9u7 is installed
                        Depends: perlapi-5.28.0
 libpve-u2f-server-perl : Depends: perl (>= 5.28.1-6) but 5.24.1-3+deb9u7 is installed
                          Depends: perlapi-5.28.1
 librados2-perl : Depends: perl (>= 5.28.1-6) but 5.24.1-3+deb9u7 is installed
                  Depends: perlapi-5.28.1
 librgw2 : Depends: libcurl4 (>= 7.28.0) but it is not installed
 libterm-readline-gnu-perl : Depends: perl (>= 5.28.1-3) but 5.24.1-3+deb9u7 is installed
                             Depends: perlapi-5.28.1
 libtext-charwidth-perl : Depends: perl-base (>= 5.28.0-3) but 5.24.1-3+deb9u7 is installed
                          Depends: perlapi-5.28.0
 libxml-libxml-perl : Depends: perl (>= 5.28.1-4) but 5.24.1-3+deb9u7 is installed
                      Depends: perlapi-5.28.1
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
root@[HOST]:/etc/apt/sources.list.d#

To validate that we also have upgraded 6 other hosts with the same repos, and had no issues other than some network interfaces not showing up correctly.

Do you think a better option at this point may be to just rebuild this node?

Thanks,

Jon
 

aaron

Proxmox Staff Member
Staff member
Jun 3, 2019
3,152
537
118
Do you think a better option at this point may be to just rebuild this node?
I would first try the suggested fix apt --fix-broken install.
 

hacman

Active Member
Oct 11, 2013
84
4
28
Newcastle upon Tyne, UK
Hi Aaron,

Sadly that just does the same:

Code:
root@[HOST]:~# apt --fix-broken install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... failed.
The following packages have unmet dependencies:
 ceph-common : Depends: libcurl4 (>= 7.28.0) but it is not installed
 dmsetup : Depends: libdevmapper1.02.1 (>= 2:1.02.138) but 2:1.02.137-pve6 is installed
 libapparmor-perl : Depends: perl-base (>= 5.28.1-5) but 5.24.1-3+deb9u7 is installed
                    Depends: perlapi-5.28.1
 libauthen-pam-perl : Depends: perl (>= 5.28.0-3) but 5.24.1-3+deb9u7 is installed
                      Depends: perlapi-5.28.0
 libcrypt-ssleay-perl : Depends: perl (>= 5.28.0-3) but 5.24.1-3+deb9u7 is installed
                        Depends: perlapi-5.28.0
 libpve-u2f-server-perl : Depends: perl (>= 5.28.1-6) but 5.24.1-3+deb9u7 is installed
                          Depends: perlapi-5.28.1
 librados2-perl : Depends: perl (>= 5.28.1-6) but 5.24.1-3+deb9u7 is installed
                  Depends: perlapi-5.28.1
 librgw2 : Depends: libcurl4 (>= 7.28.0) but it is not installed
 libterm-readline-gnu-perl : Depends: perl (>= 5.28.1-3) but 5.24.1-3+deb9u7 is installed
                             Depends: perlapi-5.28.1
 libtext-charwidth-perl : Depends: perl-base (>= 5.28.0-3) but 5.24.1-3+deb9u7 is installed
                          Depends: perlapi-5.28.0
 libxml-libxml-perl : Depends: perl (>= 5.28.1-4) but 5.24.1-3+deb9u7 is installed
                      Depends: perlapi-5.28.1
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies

Thanks,

Jon
 

systemservice

Member
Jul 25, 2018
4
0
6
35
UPDATE:
Now I have reinstalled the node, but I'm just wondering what went wrong, now I'm afraid to update the next host.


I'm having the same issue.
I have switched all hosts to Corosync 3 with no issues as described in the official upgrade tutorial.
Than I upgraded one host to PVE 6 as described with no issues.

But another host has additionally got official Zabbix, Icinga, HW-RAID and Backports stretch repositories, but as far I see only installed packages required by Corosync 3 are using Backports:

Code:
dpkg-query -W | grep '~bpo'
corosync        3.0.4-pve1~bpo9
criu    2.11.1-1~bpo90
libboost-atomic1.67.0:amd64     1.67.0-13+deb10u1~bpo9+1
libboost-chrono1.67.0:amd64     1.67.0-13+deb10u1~bpo9+1
libboost-context1.67.0:amd64    1.67.0-13+deb10u1~bpo9+1
libboost-coroutine1.67.0:amd64  1.67.0-13+deb10u1~bpo9+1
libboost-date-time1.67.0:amd64  1.67.0-13+deb10u1~bpo9+1
libboost-filesystem1.67.0:amd64 1.67.0-13+deb10u1~bpo9+1
libboost-program-options1.67.0:amd64    1.67.0-13+deb10u1~bpo9+1
libboost-regex1.67.0:amd64      1.67.0-13+deb10u1~bpo9+1
libboost-thread1.67.0:amd64     1.67.0-13+deb10u1~bpo9+1
libcfg7:amd64   3.0.4-pve1~bpo9
libcmap4:amd64  3.0.4-pve1~bpo9
libcorosync-common4:amd64       3.0.4-pve1~bpo9
libcpg4:amd64   3.0.4-pve1~bpo9
libknet1:amd64  1.16-pve1~bpo9
libnvpair1linux 0.7.13-pve1~bpo2
libqb0:amd64    1.0.5-1~bpo9+2
libquorum5:amd64        3.0.4-pve1~bpo9
libuutil1linux  0.7.13-pve1~bpo2
libvotequorum8:amd64    3.0.4-pve1~bpo9
libzfs2linux    0.7.13-pve1~bpo2
libzpool2linux  0.7.13-pve1~bpo2
spl     0.7.13-pve1~bpo2
zfs-initramfs   0.7.13-pve1~bpo2
zfsutils        0.6.5.9-pve15~bpo80
zfsutils-linux  0.7.13-pve1~bpo2

So I did dist-upgrade but it aborted because the "zabbix-agent" package failed.

Now it looks like "hacman" wrote, it did the same steps to repair as described above, nothing helped.

Backports are now disabled.

Code:
apt-get update
Ign:1 http://hwraid.le-vert.net/debian buster InRelease
Hit:2 http://ftp.de.debian.org/debian buster InRelease
Hit:3 http://security.debian.org buster/updates InRelease
Hit:4 http://repo.zabbix.com/zabbix/4.4/debian buster InRelease
Hit:5 http://download.proxmox.com/debian buster InRelease
Hit:6 http://download.proxmox.com/debian/corosync-3 stretch InRelease
Hit:7 http://hwraid.le-vert.net/debian buster Release
Hit:9 https://packages.icinga.com/debian icinga-buster InRelease
Reading package lists... Done

Code:
The following packages have unmet dependencies:
dh-python : Depends: python3-distutils but it is not installed or
                      python3 (< 3.6.5~rc1-1) but 3.7.3-1 is installed
dirmngr : Depends: gpgconf (= 2.2.12-1+deb10u1) but it is not installed
           Depends: libassuan0 (>= 2.5.0) but 2.4.3-2 is installed
dmsetup : Depends: libdevmapper1.02.1 (>= 2:1.02.138) but 2:1.02.137-pve6 is installed
gnupg : Depends: gnupg-utils (< 2.2.12-1+deb10u1.1~) but it is not installed
         Depends: gnupg-utils (>= 2.2.12-1+deb10u1) but it is not installed
         Depends: gpg (< 2.2.12-1+deb10u1.1~) but it is not installed
         Depends: gpg (>= 2.2.12-1+deb10u1) but it is not installed
         Depends: gpg-agent (< 2.2.12-1+deb10u1.1~)
         Depends: gpg-agent (>= 2.2.12-1+deb10u1)
         Depends: gpg-wks-client (< 2.2.12-1+deb10u1.1~) but it is not installed
         Depends: gpg-wks-client (>= 2.2.12-1+deb10u1) but it is not installed
         Depends: gpg-wks-server (< 2.2.12-1+deb10u1.1~) but it is not installed
         Depends: gpg-wks-server (>= 2.2.12-1+deb10u1) but it is not installed
         Depends: gpgsm (< 2.2.12-1+deb10u1.1~) but it is not installed
         Depends: gpgsm (>= 2.2.12-1+deb10u1) but it is not installed
         Depends: gpgv (>= 2.2.12-1+deb10u1) but 2.1.18-8~deb9u4 is installed
libapparmor-perl : Depends: perl-base (>= 5.28.1-5) but 5.24.1-3+deb9u7 is installed
                    Depends: perlapi-5.28.1
libb-hooks-op-check-perl : Depends: perl (>= 5.28.0-3) but 5.24.1-3+deb9u7 is installed
                            Depends: perlapi-5.28.0
libdevel-callchecker-perl : Depends: perl (>= 5.28.1-4) but 5.24.1-3+deb9u7 is installed
                             Depends: perlapi-5.28.1
liblist-moreutils-perl : Depends: perl (>= 5.28.0-3) but 5.24.1-3+deb9u7 is installed
                          Depends: perlapi-5.28.0
libparams-classify-perl : Depends: perl (>= 5.28.0-3) but 5.24.1-3+deb9u7 is installed
                           Depends: perlapi-5.28.0
libpve-u2f-server-perl : Depends: perl (>= 5.28.1-6) but 5.24.1-3+deb9u7 is installed
                          Depends: perlapi-5.28.1
libpython2.7 : Depends: libpython2.7-stdlib (= 2.7.16-2+deb10u1) but 2.7.13-2+deb9u4 is installed
libterm-readline-gnu-perl : Depends: perl (>= 5.28.1-3) but 5.24.1-3+deb9u7 is installed
                             Depends: perlapi-5.28.1
python2.7 : Depends: python2.7-minimal (= 2.7.16-2+deb10u1) but 2.7.13-2+deb9u4 is installed
             Depends: libpython2.7-stdlib (= 2.7.16-2+deb10u1) but 2.7.13-2+deb9u4 is installed
python3 : Depends: python3.7 (>= 3.7.3-1~) but it is not installed
           Depends: libpython3-stdlib (= 3.7.3-1) but 3.5.3-1 is installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies

I don't unterstand why it happens.
 
Last edited:

systemservice

Member
Jul 25, 2018
4
0
6
35
Hi aaron,

thank you for your reply. As I wrote above, I have already re-installed that node, so it doesn't need to be repaired.
But I had tried what you suggested and it didn't help.
Now I'm wondering what went wrong because I plan to update more nodes.

Merry Christmas
 

aaron

Proxmox Staff Member
Staff member
Jun 3, 2019
3,152
537
118
I am a bit confused right now. Did you reinstall it with PVE 5 or 6? The extra Corosync3 repository is only needed on the older PVE 5.x nodes for the time of the upgrade.

Overall, if you have some dependency problems, I would suggest removing all the extra non Debian and non Proxmox VE repos first. Maybe also remove the extra software for now. Then add one by one and see which one causes problems.
 

systemservice

Member
Jul 25, 2018
4
0
6
35
Previosly it was a PVE 4 node that had been updated to PVE 5 an year ago. This week I tried to update it to PVE 6, but it failed and I spent a lot of hours to repair it - but with no success. Today I re-installed it from scratch.

Here I'm describing the failure during the upgrade to PVE 6 and how I did it. I'm trying to understand not just why it went wrong but also why all my attempts like
Code:
apt --fix-broken install
etc. didn't help.
Okay, one package like "zabbix-agent" failed during dist-upgrade and dist-upgrade aborted, but I don't understand why it was not possible to fix the dependencies and continue dist-upgrade.

Here are my update notices and most of these steps are taken from the official PVE 5 to 6 update tutorial, did I miss anything?

Code:
# Stop all VMs


# Upgrade al nodes to the latest version of Proxmox VE 5.4 and reboot

apt update

apt full-upgrade

reboot


# Run pve5to6 on all notes and fix problems

pve5to6


# Upgrade Corosync 2 to 3

# Stop all HA management services on all nodes:

# Stop the local resource manager "pve-ha-lrm" on each node

systemctl stop pve-ha-lrm

# Only after they have been stopped...

systemctl stop pve-ha-crm

# Then add the Proxmox Corosync 3 Stretch repository

echo "deb http://download.proxmox.com/debian/corosync-3/ stretch main" > /etc/apt/sources.list.d/corosync3.list

apt update

# Upgrade all nodes simultaneously, e.g. using parallel ssh/screen/tmux.

apt dist-upgrade --download-only

apt dist-upgrade

pvecm status


# Update configuration https://forum.proxmox.com/threads/upgrading-pve-5-to-6.65348/

# Copy, switch to the default transport 'knet' and increase config_version

cp -p /etc/corosync/corosync.conf ~/

nano ~/corosync.conf

# stop corosync and pve-cluster on all nodes

# start pmxcfs in local mode (pmxcfs -l) on all nodes

# copy your modified configuration to /etc/corosync/corosync.conf and /etc/pve/corosync.conf on all nodes

cp -p ~/corosync.conf /etc/corosync/corosync.conf

cp -p ~/corosync.conf /etc/pve/corosync.conf

# stop the local mode pmxcfs instances (killall pmxcfs or C^C in the terminal where they are running

# start corosync and pve-cluster again

# verify their status with systemctl status pve-cluster corosync and pvecm status

   

# Once the update to Corosync 3.x is done on all nodes, restart the local resource manager and cluster resource manager on all nodes:

systemctl start pve-ha-lrm

systemctl start pve-ha-crm


nano /root/.ssh/config

# Ciphers blowfish-cbc,aes128-ctr,aes192-ctr,aes256-ctr,arcfour256,arcfour128,aes128-cbc,3des-cbc

Ciphers aes128-ctr,aes192-ctr,aes256-ctr,aes128-gcm@openssh.com,aes256-gcm@openssh.com,chacha20-poly1305@openssh.com


# Re-run pve5to6

pve5to6


# Upgrade Debian/Proxmox


# List installed packages

dpkg --get-selections "*"


# List installed backports

dpkg-query -W | grep '~bpo'


sed -i 's/stretch/buster/g' /etc/apt/sources.list

sed -i 's/stretch/buster/g' /etc/apt/sources.list.d/zabbix.list

sed -i 's/stretch/buster/g' /etc/apt/sources.list.d/stretch-icinga.list

sed -i 's/stretch/buster/g' /etc/apt/sources.list.d/stretch-backports.list

mv /etc/apt/sources.list.d/stretch-icinga.list /etc/apt/sources.list.d/buster-icinga.list

mv /etc/apt/sources.list.d/stretch-backports.list /etc/apt/sources.list.d/buster-backports.list


# Disable all Proxmox VE 5.x repositories. This includes the pve-enterprise repository, the pve-no-subscription repository and the pvetest repository.

To do so add the # symbol to comment out these repositories in the /etc/apt/sources.list.d/pve-enterprise.list and /etc/apt/sources.list files.

apt update

apt dist-upgrade

### HERE THE UPGRADE HAS FAILED, COULDN'T RECOVER FROM THIS POINT ###
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!