Erstellung Win10 VM unter Proxmox7.1-6 scheitert

passuff

Member
Aug 15, 2019
19
1
8
39
Hallo zusammen,
ich nutze seit Jahren erfolgreich meine Proxmox-Umgebung mit zahlreichen Linux Containern und auch VMs. Ich wollte heute ausnahmsweise ein Windows 10 VM nach dieser Anleitung erstellen Windows 10 guest best practices.
Ich habe es auch mit anderen Einstellungen hinsichtlich Memory, CPU und Festplatte versucht jedoch immer mit dem selben Ergebnis. Ich kann die VM starten und nach ca 2-3 Minuten (warum so lange?) wird dann die Installation von der ISO geladen. Ich kann dann noch die Installation starten, jedoch verliere ich dann mit noVNC die Verbindung und die VM ist offline. Ich kenne mich leider zu wenig aus als dass ich wüsste wo ich mehr Details (log) über den shut down erfahren könnte und hoffe ihr könnt mir hier helfen.
 

oguz

Proxmox Retired Staff
Retired Staff
Nov 19, 2018
5,207
693
118
hi,

Ich kann die VM starten und nach ca 2-3 Minuten (warum so lange?) wird dann die Installation von der ISO geladen
wo ist die ISO? ich meine storage, z.b. network storage oder auf einer disk

Ich kenne mich leider zu wenig aus als dass ich wüsste wo ich mehr Details (log) über den shut down erfahren könnte und hoffe ihr könnt mir hier helfen
poste mal bitte deine VM configuration: qm config VMID (VMID ist deine VM nummer)

und bitte pveversion -v :)
 

passuff

Member
Aug 15, 2019
19
1
8
39
Die Iso liegt auf dem lokalen Proxmox Speicher.

Code:
root@pve:~# qm config 110
agent: 1
boot: order=scsi0;net0;ide2;ide0
cores: 1
ide0: local:iso/virtio-win-0.1.215.iso,media=cdrom,size=528322K
ide2: local:iso/Windows.iso,media=cdrom,size=4492992K
machine: pc-i440fx-6.1
memory: 16384
meta: creation-qemu=6.1.0,ctime=1643203592
name: Win10Test
net0: virtio=CA:17:01:98:07:28,bridge=vmbr0,firewall=1
numa: 0
ostype: win10
scsi0: local-lvm:vm-110-disk-0,cache=writeback,discard=on,size=128G
scsihw: virtio-scsi-pci
smbios1: uuid=45b5f854-4d64-4018-a698-6952463f4b15
sockets: 1
vmgenid: 7fe44c58-e8f9-471b-bcc1-a16acbb01b0e

Code:
root@pve:~# pveversion -v
proxmox-ve: 7.1-1 (running kernel: 5.13.19-1-pve)
pve-manager: 7.1-6 (running version: 7.1-6/4e61e21c)
pve-kernel-5.13: 7.1-4
pve-kernel-helper: 7.1-4
pve-kernel-5.4: 6.4-7
pve-kernel-5.13.19-1-pve: 5.13.19-3
pve-kernel-5.4.143-1-pve: 5.4.143-1
pve-kernel-5.4.98-1-pve: 5.4.98-1
pve-kernel-5.4.65-1-pve: 5.4.65-1
pve-kernel-5.4.34-1-pve: 5.4.34-2
ceph-fuse: 14.2.21-1
corosync: 3.1.5-pve2
criu: 3.15-1+pve-1
glusterfs-client: 9.2-1
ifupdown: 0.8.36+pve1
ksm-control-daemon: 1.4-1
libjs-extjs: 7.0.0-1
libknet1: 1.22-pve2
libproxmox-acme-perl: 1.4.0
libproxmox-backup-qemu0: 1.2.0-1
libpve-access-control: 7.1-5
libpve-apiclient-perl: 3.2-1
libpve-common-perl: 7.0-14
libpve-guest-common-perl: 4.0-3
libpve-http-server-perl: 4.0-3
libpve-storage-perl: 7.0-15
libqb0: 1.0.5-1
libspice-server1: 0.14.3-2.1
lvm2: 2.03.11-2.1
lxc-pve: 4.0.9-4
lxcfs: 4.0.8-pve2
novnc-pve: 1.2.0-3
proxmox-backup-client: 2.1.2-1
proxmox-backup-file-restore: 2.1.2-1
proxmox-mini-journalreader: 1.2-1
proxmox-widget-toolkit: 3.4-3
pve-cluster: 7.1-2
pve-container: 4.1-2
pve-docs: 7.1-2
pve-edk2-firmware: 3.20210831-2
pve-firewall: 4.2-5
pve-firmware: 3.3-3
pve-ha-manager: 3.3-1
pve-i18n: 2.6-2
pve-qemu-kvm: 6.1.0-2
pve-xtermjs: 4.12.0-1
qemu-server: 7.1-4
smartmontools: 7.2-pve2
spiceterm: 3.2-2
swtpm: 0.7.0~rc1+2
vncterm: 1.7-1
zfsutils-linux: 2.1.1-pve3
 

oguz

Proxmox Retired Staff
Retired Staff
Nov 19, 2018
5,207
693
118
danke fuer die ausgaben.

hast du viele VMs/CTs am laufen?

wie schaut deine ressourcenverbrauch generell aus bzgl memory/cpu/disk ops usw. (auf dem PVE)?
 

passuff

Member
Aug 15, 2019
19
1
8
39
Insgesamt laufen zwei Container und vier VMs.

1643208359200.png

Ressourcen (auch HD für die VMs/Container) sind alles andere als am Limit meiner Ansicht nach...

Danke
 

passuff

Member
Aug 15, 2019
19
1
8
39
Ich habe mein System sowie Proxmox auf den aktuellen Stand gehoben und neu gestartet. Jetzt funktioniert es zwar, jedoch halte ich die Auslastung während der Win 10 Installation für zu hoch:

1643209839989.png
Wieso benötigt die Installation derart viel Ressourcen?
 

oguz

Proxmox Retired Staff
Retired Staff
Nov 19, 2018
5,207
693
118
du gibst die VM zu viel RAM (du hast ja 24G total, und benutzt die haelfte mit den anderen guests), da wird dein host dann wsl. ausgelastet.
cpu cores kannst du mehr angeben, du hast schon 20 cores(?). sollte dann passen.

ich wuerde auch die machine type zu "q35" setzen (obwohl es nicht bei den best practices steht)

btw benutzt du das deutsche windows ISO? damit hat es schon ein paar probleme gegeben (was dich danach betreffen kann, bzgl. netzwerk). siehe [0]

[0]: https://forum.proxmox.com/threads/n...upgrade-to-proxmox-7.92094/page-2#post-404910
 
  • Like
Reactions: passuff

passuff

Member
Aug 15, 2019
19
1
8
39
du gibst die VM zu viel RAM (du hast ja 24G total, und benutzt die haelfte mit den anderen guests), da wird dein host dann wsl. ausgelastet.
cpu cores kannst du mehr angeben, du hast schon 20 cores(?). sollte dann passen.

ich wuerde auch die machine type zu "q35" setzen (obwohl es nicht bei den best practices steht)

btw benutzt du das deutsche windows ISO? damit hat es schon ein paar probleme gegeben (was dich danach betreffen kann, bzgl. netzwerk). siehe [0]

[0]: https://forum.proxmox.com/threads/n...upgrade-to-proxmox-7.92094/page-2#post-404910
Ich habe RAM halbiert und 4 Kerne eingestellt. Es läuft jetzt deutlich schneller.
Vielen Dank euch allen!
 
  • Like
Reactions: oguz

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!