Error pfsense freebsd

Discussion in 'Proxmox VE: Installation and configuration' started by prohand, Mar 3, 2013.

  1. prohand

    prohand Member

    Joined:
    Jul 27, 2011
    Messages:
    31
    Likes Received:
    0
    Sans titre.png
    I have a problem getting started in freebsd pfsense
    See screen shot
    Can you help me?

    Thanks
     
  2. prohand

    prohand Member

    Joined:
    Jul 27, 2011
    Messages:
    31
    Likes Received:
    0
    It is very urgent please, I'm not internet connection because the all traffic bypass on this host ^^

    Thanks
     
  3. MIlkwerm

    MIlkwerm Member

    Joined:
    Jan 30, 2012
    Messages:
    97
    Likes Received:
    5
    My understanding was that only version 2.1 of PFsense worked well under KVM (has the VirtIO driver in base) and that version is still in beta. You'd be best on deadicated hardware for running a Firewall device.
     
  4. prohand

    prohand Member

    Joined:
    Jul 27, 2011
    Messages:
    31
    Likes Received:
    0
    My pfsense worked very well until now before migration in 2.3
    I do not see why it would work poorly.
    I think there is a problem in version 2.3 :)
     
  5. MIlkwerm

    MIlkwerm Member

    Joined:
    Jan 30, 2012
    Messages:
    97
    Likes Received:
    5
    So your running pre-release 2.3 in production? what version of PFsense are you using? Chances are, your'll get a better response from their forums.
     
  6. prohand

    prohand Member

    Joined:
    Jul 27, 2011
    Messages:
    31
    Likes Received:
    0
    Yes I'm running in production, but this is an error :(
    I just found a full backup of the server that I have restored.

    Everything went back to normal but it would be nice to find an answer to the error message before the release of the final version.

    I'm using version 2.0.2 of pfsense

    I will not use the test version in production :)
     
  7. MIlkwerm

    MIlkwerm Member

    Joined:
    Jan 30, 2012
    Messages:
    97
    Likes Received:
    5
    From what I have read on the PFsense forums 2.0.2 doesnt have virtIO drivers installed. so if you want to stay with that version I'd recommend you move to physical hardware. There is a thread for enabling the virtIO drivers in 2.1(RC1) and plenty of reports that it is in stable production use by many users. I'd sugest you start testing this version before the PVE2.3 release.
     
  8. prohand

    prohand Member

    Joined:
    Jul 27, 2011
    Messages:
    31
    Likes Received:
    0
    I do not have the budget for iai put as much money into a machine dedicated to pfsense, this is why I started a Proxmox.
    My version 2.0.2 works perfectly, it does not work only in PVE2.3
     
  9. spirit

    spirit Well-Known Member

    Joined:
    Apr 2, 2010
    Messages:
    3,323
    Likes Received:
    135

    Hi, can your try to add

    "args: -machine pc-1.0"

    to your vm config file ?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. prohand

    prohand Member

    Joined:
    Jul 27, 2011
    Messages:
    31
    Likes Received:
    0
    I will not now, I've spent a lot of time up my machine :)

    This option has what effect?
     
  11. spirit

    spirit Well-Known Member

    Joined:
    Apr 2, 2010
    Messages:
    3,323
    Likes Received:
    135
    Keep hardware compatibility with kvm 1.0. (Somebody have reported that it's has corrected a freebsd boot problem).
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  12. cltech

    cltech New Member

    Joined:
    Mar 4, 2013
    Messages:
    3
    Likes Received:
    0
    Hello, same here. I was testing out 2.3pre (I see that it has been released today :) and pfsense 2.02. Thanks for the advice to try pfsense 2.1 snapshot. will give it a try!
     
  13. cltech

    cltech New Member

    Joined:
    Mar 4, 2013
    Messages:
    3
    Likes Received:
    0
    Well, no go with stock proxmox 2.3 and pfSense-LiveCD-2.1-BETA1-i386-20130303-2043.iso.gz. If someone else is able to get it functioning or has information of what to modify, please post here. Thanks.
     
  14. MIlkwerm

    MIlkwerm Member

    Joined:
    Jan 30, 2012
    Messages:
    97
    Likes Received:
    5
  15. cltech

    cltech New Member

    Joined:
    Mar 4, 2013
    Messages:
    3
    Likes Received:
    0
    Hello, thanks for the reply. I maybe misunderstanding the documentation, but, i (we?) are unable to get to the point to follow the instructions, the load process is crashing before the system is usable in vm. Also, I am not using virtIO drives or nics. Again, maybe I am misunderstanding virtIO. Are they just related to one of the options one selects for Drive or NIC or is virtIO the underlying technology that is used no matter what we select (ie IDE or RTLnic). Thanks.
     
  16. joshfokis

    joshfokis New Member

    Joined:
    Nov 15, 2012
    Messages:
    15
    Likes Received:
    0
    I am having the same issue and tried this and it didn't work for me. I had it working just fine on 2.2 before upgrading to 2.3. I am also running pfsense on 2.1 and even if I try to install 2.0.1 it has this issue... It seems it enters into a debugging mode when trying to load the kernel.
     
  17. xfr

    xfr New Member

    Joined:
    Mar 5, 2013
    Messages:
    6
    Likes Received:
    0
    I think pfsense 2.x (and other freebsd?) is unable to run on proxmox 2.3, although it runs smoothly on proxmox 2.2, with or without virtio.

    Proxmox 2.3 needs to be patched.
     
  18. tom

    tom Proxmox Staff Member
    Staff Member

    Joined:
    Aug 29, 2006
    Messages:
    13,551
    Likes Received:
    405
    FreeBSD-9.1-RELEASE-amd64-disc1.iso runs without any problems here (on 2.3).
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  19. z00te

    z00te New Member

    Joined:
    Feb 3, 2011
    Messages:
    5
    Likes Received:
    1
  20. Hile

    Hile New Member

    Joined:
    Apr 23, 2012
    Messages:
    13
    Likes Received:
    0
    Tom, We need pfSense =)
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice