[SOLVED] Error code 11 when moving storage from zfspool to local: "no space left on device" but there is plenty of space

I had the same problem moving proxmoxbackup LXC root disk from ZFS to Ceph. Other LXCs, so far, moved fine, but proxmoxbackup root did not. I then tried moving it to LVM, and it again died due to lack of space.

Maybe a warning in the log when a compressed volume is being moved to one without compression. "Moving from a compressed volume to a non-compressed volume can result in an out of space condition in the target volume if the new size exceeds the original size."

Or maybe in the documentation under the appropriate subjects (restores, move storage, etc.).
Last edited:
  • Like
Reactions: jsabater
I think that is an excellent idea, @BruceX. Any chance this warning message could be brought into the next version of Proxmox, @fabian? Once you've experienced the situation, it makes sense and you will probably not fall for it again, but for the first-timers it could be very helpful. :)
Last edited:
For future reference, Fabian means this:

the problem is that the upper layer doesn't know whether the lower storage layer uses compression and how much it affects the data.

Still, my request would be to enable such information to be exposed. Not urgent, not critical, but when possible :)


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!