Enable MTU 9000 Jumbo Frames

gosha

Active Member
Oct 20, 2014
275
18
38
Russia
Hi!
Edit /etc/network/interface like this (add post-up command):

auto eth4
iface eth4 inet static
address 192.168.110.4
netmask 255.255.255.240
post-up ifconfig eth4 mtu 9000

After this restart interface, for example:

# ifdown eth4 && ifup eth4
 

dcsapak

Proxmox Staff Member
Staff member
Feb 1, 2016
4,647
440
103
32
Vienna
you need openvswitch for that (linux bridges don't support mtu > 1500).
linux bridges take the smallest mtu of their slave, so if you set the mtu on the nic, the bridge should automatically get this mtu
@gosha your comment should work
 

Proxmoxgoogle

Member
Mar 21, 2017
71
0
11
31
This is my interfaces file

auto lo
iface lo inet loopback

auto vmbr0
iface vmbr0 inet static
address 172.23.37.205
netmask 255.255.248.0
gateway 172.23.32.1
bridge_ports eth0
bridge_stp off
bridge_fd 0

I do not have static ip, it is dynamic by dhcp,

How do I add the post-up command?
 

miha_r

New Member
May 1, 2014
20
0
1
auto vmbr0
iface vmbr0 inet static
address 192.168.59.190
netmask 255.255.255.0
gateway 192.168.59.191
bridge_ports eth0
bridge_stp off
bridge_fd 0
up ifconfig eth0 mtu 4000 || true
 

daemaz

New Member
Jan 24, 2017
15
1
3
32
Not sure if this is the proper way but this works for me

auto vmbr2
iface vmbr2 inet static
address 172.16.0.2
netmask 255.255.255.0
bridge_ports eth2
bridge_stp off
bridge_fd 0
pre-up ifconfig eth2 mtu 9000
 

Percy

New Member
Feb 4, 2018
6
2
3
33
Nothing posted here worked for me. I suspect it is because ifconfig is deprecated in the version of debian used in Proxmox VE5.1

What DID work was adding the following to /etc/network/interface under the bridge:

ip link set dev eth0 mtu 9000 (eth0 is the name of the network interface, change accordingly)
 
  • Like
Reactions: Adam Smith

tjh

Member
Feb 15, 2018
19
4
8
43
For the avoidance of doubt for anyone else coming to this topic, this is the full command I used in blue. Note I don't bother with the "dev" command in ip link, it seems redundant:

iface vmbr1 inet manual
bridge_ports enp1s0
bridge_stp off
bridge_fd 0
pre-up ip link set <interface name> mtu 9000


Replace the <interface name> with whatever the name of your interface is. For me this is enp1s0.
 
  • Like
Reactions: Adam Smith

ejmerkel

Active Member
Sep 20, 2012
91
0
26
I have the following bonded LACP setup.

auto bond2
iface bond2 inet static
address 172.16.4.252
netmask 24
bond-slaves enp130s0f0 enp130s0f1
bond-miimon 100
bond-mode 802.3ad
pre-up ip link set enp130s0f0 mtu 9000 && ip link set enp130s0f1 mtu 9000 && ip link set bond2 mtu 9000
#Backup Network


Setting the MTU per the above post does not work when I use pre-up but does work when I use post-up like below. Are there any issue doing it one way vs the other?

post-up ip link set enp130s0f0 mtu 9000 && ip link set enp130s0f1 mtu 9000 && ip link set bond2 mtu 9000

Thanks,
Eric
 

spirit

Famous Member
Apr 2, 2010
4,218
271
103
www.odiso.com
I have the following bonded LACP setup.

auto bond2
iface bond2 inet static
address 172.16.4.252
netmask 24
bond-slaves enp130s0f0 enp130s0f1
bond-miimon 100
bond-mode 802.3ad
pre-up ip link set enp130s0f0 mtu 9000 && ip link set enp130s0f1 mtu 9000 && ip link set bond2 mtu 9000
#Backup Network


Setting the MTU per the above post does not work when I use pre-up but does work when I use post-up like below. Are there any issue doing it one way vs the other?

post-up ip link set enp130s0f0 mtu 9000 && ip link set enp130s0f1 mtu 9000 && ip link set bond2 mtu 9000

Thanks,
Eric
Hi,
I don't known why users want to use pre-up,postup....

you can simply use

Code:
iface  enp130s0f0 in manual
    ......
    mtu 9000

iface bond2 inet static
     ....
    mtu 9000
 
  • Like
Reactions: moonman and RokaKen

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!