edquota: Cannot stat() mounted device simfs

Bobby69

New Member
Jan 18, 2016
6
0
1
57
Hi

I’m using kernel 2.6.32-43-pve and have multiple cPanel openvz vps on it, everything is working OK, but when I updated it to kernel 2.6.32.44-pve all my cPanel started to give wrong space sizes on all the accounts inside, the server is working fine but the space is wrong reported on “List Accounts”, tried to fixquotas, doesn’t work, tried recalculating space, creating quotas, disabling and enabling quotas, nothing works.

When I try “Initial Quota Setup” I get this error

Installing Default Quota Databases......Done
journaled quota support: not available with vzaquota (disabled)
Quotas have been enabled and updated.
Reading package xxxxx_planxx
edquota: Cannot stat() mounted device simfs: No such file or directory
No filesystems with quota detected.
Resetting quota for xxxxx to 0 M

I contacted cPanel and they told me about enabling second level quotas but everything is enable, and it was working before the update, then they told me to contact proxmox.

I boot the server on kernel 2.6.32-43-pve again and everything works, change kernel and again it doesn’t work.

So I guess it has to do with the kernel, can someone help me?

Thanks
 

Bobby69

New Member
Jan 18, 2016
6
0
1
57
Thanks Tom

Probably it is a similar problem but the kernel in this bug report is different 42 and I’m updating to 44, I don’t know what to do should I wait for the next update?
 

Bobby69

New Member
Jan 18, 2016
6
0
1
57
Continue troubleshooting, I found that the problem is that inside the vps it is mounting:

simfs / simfs rw,relatime,usrquota,grpquota 0 0
instead of
/dev/simfs / simfs rw,relatime,usrquota,grpquota 0 0

Any ideas how to fix this?
 

dietmar

Proxmox Staff Member
Staff member
Apr 28, 2005
17,145
541
143
Austria
www.proxmox.com
I uploaded a fixed version to pvetest repository:

ftp://download1.proxmox.com/debian/dists/wheezy/pvetest/binary-amd64/pve-kernel-2.6.32-44-pve_2.6.32-169_amd64.deb

Please can you test?
 

Bobby69

New Member
Jan 18, 2016
6
0
1
57
Thanks for your help, I installed the new kernel in our test server and everything seems to be working, but I still get a Quotas have been enabled, however they may not be up to date as quotacheck has been skipped on cpanel when trying to do /scripts/fixquotas
the info I have is as follows:

# mount
/dev/simfs on / type simfs (rw,relatime,usrquota,grpquota)
proc on /proc type proc (rw,relatime)
sysfs on /sys type sysfs (rw,relatime)
none on /dev type devtmpfs (rw,relatime,mode=755)
none on /dev/pts type devpts (rw,relatime,mode=600,ptmxmode=000)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,relatime)

# repquota -a
*** Report for user quotas on device /dev/simfs
Block grace time: 00:00; Inode grace time: 00:00
Block limits File limits
User used soft hard grace used soft hard grace
----------------------------------------------------------------------
....
....
usertest -- 13312 13312 13312 none 823 0 0


Seems to be ok, I saw a -169 on the downloaded file but in the pveversion I'm using -167 just to verify if that's OK?

# pveversion -v
proxmox-ve-2.6.32: 3.4-167 (running kernel: 2.6.32-44-pve)
pve-manager: 3.4-11 (running version: 3.4-11/6502936f)
pve-kernel-2.6.32-40-pve: 2.6.32-160
pve-kernel-2.6.32-20-pve: 2.6.32-100
pve-kernel-2.6.32-32-pve: 2.6.32-136
pve-kernel-2.6.32-44-pve: 2.6.32-169
pve-kernel-2.6.32-39-pve: 2.6.32-157
pve-kernel-2.6.32-19-pve: 2.6.32-96
pve-kernel-2.6.32-41-pve: 2.6.32-164
pve-kernel-2.6.32-33-pve: 2.6.32-138
pve-kernel-2.6.32-30-pve: 2.6.32-130
pve-kernel-2.6.32-37-pve: 2.6.32-150
pve-kernel-2.6.32-42-pve: 2.6.32-165
pve-kernel-2.6.32-22-pve: 2.6.32-107
pve-kernel-2.6.32-17-pve: 2.6.32-83
pve-kernel-2.6.32-29-pve: 2.6.32-126
pve-kernel-2.6.32-34-pve: 2.6.32-140
pve-kernel-2.6.32-31-pve: 2.6.32-132
pve-kernel-2.6.32-26-pve: 2.6.32-114
pve-kernel-2.6.32-11-pve: 2.6.32-66
pve-kernel-2.6.32-43-pve: 2.6.32-166
pve-kernel-2.6.32-38-pve: 2.6.32-155
pve-kernel-2.6.32-18-pve: 2.6.32-88
pve-kernel-2.6.32-23-pve: 2.6.32-109
lvm2: 2.02.98-pve4
clvm: 2.02.98-pve4
corosync-pve: 1.4.7-1
openais-pve: 1.1.4-3
libqb0: 0.11.1-2
redhat-cluster-pve: 3.2.0-2
resource-agents-pve: 3.9.2-4
fence-agents-pve: 4.0.10-3
pve-cluster: 3.0-19
qemu-server: 3.4-6
pve-firmware: 1.1-5
libpve-common-perl: 3.0-24
libpve-access-control: 3.0-16
libpve-storage-perl: 3.0-34
pve-libspice-server1: 0.12.4-3
vncterm: 1.1-8
vzctl: 4.0-1pve6
vzprocps: 2.0.11-2
vzquota: 3.1-2
pve-qemu-kvm: 2.2-18
ksm-control-daemon: 1.1-1
glusterfs-client: 3.5.2-1
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!