Different Versions / No error at invalid repository

Discussion in 'Proxmox VE: Installation and configuration' started by m4k5ym, Aug 11, 2019.

  1. m4k5ym

    m4k5ym New Member

    Joined:
    Aug 11, 2019
    Messages:
    1
    Likes Received:
    0
    Hello,

    I'm curious if somebody can explain me why this is actually happen.

    Story is as following:

    I have a three node cluster with equal hardware and software. Well after a while I was about to migrate a VM from second node to the first one and Proxmox was about to cancel this action with some fancy error message.

    After short search I came to the point that there must be something like a version missmatch in my cluster setup. As suspiciously as I was after this outcome I checked it and yes. Both first and third node are same level and second is like living in the future. The funny point. All nodes are using the very same proxmox repository and the second one is still getting newer packages. Actually I'm a little bit frustrated even as Linux Consultant.

    I'm glad if somebody knows a solution.

    Code:
    #
    # First
    #
    
    # Repository
    
    deb http://download.proxmox.com/debian/pve stretch pve-no-subcription
    
    # Versions
    
    proxmox-ve: 5.4-1 (running kernel: 4.15.18-12-pve)
    pve-manager: 5.4-3 (running version: 5.4-3/0a6eaa62)
    pve-kernel-4.15: 5.3-3
    pve-kernel-4.15.18-12-pve: 4.15.18-35
    ceph: 12.2.12-pve1
    corosync: 2.4.4-pve1
    criu: 2.11.1-1~bpo90
    glusterfs-client: 3.8.8-1
    ksm-control-daemon: 1.2-2
    libjs-extjs: 6.0.1-2
    libpve-access-control: 5.1-8
    libpve-apiclient-perl: 2.0-5
    libpve-common-perl: 5.0-50
    libpve-guest-common-perl: 2.0-20
    libpve-http-server-perl: 2.0-13
    libpve-storage-perl: 5.0-41
    libqb0: 1.0.3-1~bpo9
    lvm2: 2.02.168-pve6
    lxc-pve: 3.1.0-3
    lxcfs: 3.0.3-pve1
    novnc-pve: 1.0.0-3
    proxmox-widget-toolkit: 1.0-25
    pve-cluster: 5.0-36
    pve-container: 2.0-37
    pve-docs: 5.4-2
    pve-edk2-firmware: 1.20190312-1
    pve-firewall: 3.0-19
    pve-firmware: 2.0-6
    pve-ha-manager: 2.0-9
    pve-i18n: 1.1-4
    pve-libspice-server1: 0.14.1-2
    pve-qemu-kvm: 2.12.1-3
    pve-xtermjs: 3.12.0-1
    qemu-server: 5.0-50
    smartmontools: 6.5+svn4324-1
    spiceterm: 3.0-5
    vncterm: 1.5-3
    zfsutils-linux: 0.7.13-pve1~bpo2
    
    #
    # Second
    #
    
    # Repository
    
    deb http://download.proxmox.com/debian/pve stretch pve-no-subscription
    
    # Versions
    
    proxmox-ve: 5.4-2 (running kernel: 4.15.18-18-pve)
    pve-manager: 5.4-11 (running version: 5.4-11/6df3d8d0)
    pve-kernel-4.15: 5.4-6
    pve-kernel-4.15.18-18-pve: 4.15.18-44
    pve-kernel-4.15.18-17-pve: 4.15.18-43
    pve-kernel-4.15.18-16-pve: 4.15.18-41
    pve-kernel-4.15.18-12-pve: 4.15.18-36
    ceph: 12.2.12-pve1
    corosync: 2.4.4-pve1
    criu: 2.11.1-1~bpo90
    glusterfs-client: 3.8.8-1
    ksm-control-daemon: 1.2-2
    libjs-extjs: 6.0.1-2
    libpve-access-control: 5.1-12
    libpve-apiclient-perl: 2.0-5
    libpve-common-perl: 5.0-53
    libpve-guest-common-perl: 2.0-20
    libpve-http-server-perl: 2.0-14
    libpve-storage-perl: 5.0-44
    libqb0: 1.0.3-1~bpo9
    lvm2: 2.02.168-pve6
    lxc-pve: 3.1.0-3
    lxcfs: 3.0.3-pve1
    novnc-pve: 1.0.0-3
    proxmox-widget-toolkit: 1.0-28
    pve-cluster: 5.0-37
    pve-container: 2.0-39
    pve-docs: 5.4-2
    pve-edk2-firmware: 1.20190312-1
    pve-firewall: 3.0-22
    pve-firmware: 2.0-6
    pve-ha-manager: 2.0-9
    pve-i18n: 1.1-4
    pve-libspice-server1: 0.14.1-2
    pve-qemu-kvm: 3.0.1-4
    pve-xtermjs: 3.12.0-1
    qemu-server: 5.0-54
    smartmontools: 6.5+svn4324-1
    spiceterm: 3.0-5
    vncterm: 1.5-3
    zfsutils-linux: 0.7.13-pve1~bpo2
    
    #
    #Third
    #
    
    # Repository
    
    deb http://download.proxmox.com/debian/pve stretch pve-no-subcription
    
    # Versions
    
    proxmox-ve: 5.4-1 (running kernel: 4.15.18-12-pve)
    pve-manager: 5.4-3 (running version: 5.4-3/0a6eaa62)
    pve-kernel-4.15: 5.3-3
    pve-kernel-4.15.18-12-pve: 4.15.18-35
    ceph: 12.2.12-pve1
    corosync: 2.4.4-pve1
    criu: 2.11.1-1~bpo90
    glusterfs-client: 3.8.8-1
    ksm-control-daemon: 1.2-2
    libjs-extjs: 6.0.1-2
    libpve-access-control: 5.1-8
    libpve-apiclient-perl: 2.0-5
    libpve-common-perl: 5.0-50
    libpve-guest-common-perl: 2.0-20
    libpve-http-server-perl: 2.0-13
    libpve-storage-perl: 5.0-41
    libqb0: 1.0.3-1~bpo9
    lvm2: 2.02.168-pve6
    lxc-pve: 3.1.0-3
    lxcfs: 3.0.3-pve1
    novnc-pve: 1.0.0-3
    proxmox-widget-toolkit: 1.0-25
    pve-cluster: 5.0-36
    pve-container: 2.0-37
    pve-docs: 5.4-2
    pve-edk2-firmware: 1.20190312-1
    pve-firewall: 3.0-19
    pve-firmware: 2.0-6
    pve-ha-manager: 2.0-9
    pve-i18n: 1.1-4
    pve-libspice-server1: 0.14.1-2
    pve-qemu-kvm: 2.12.1-3
    pve-xtermjs: 3.12.0-1
    qemu-server: 5.0-50
    smartmontools: 6.5+svn4324-1
    spiceterm: 3.0-5
    vncterm: 1.5-3
    zfsutils-linux: 0.7.13-pve1~bpo2
    Okay forget it. There was a beautiful typo, but why the hell is there no error message that this repository isn't valid?

    Code:
    # First
    deb http://download.proxmox.com/debian/pve stretch pve-no-subcription
    # Second
    deb http://download.proxmox.com/debian/pve stretch pve-no-subscription
     
    #1 m4k5ym, Aug 11, 2019
    Last edited: Aug 11, 2019
  2. LnxBil

    LnxBil Well-Known Member

    Joined:
    Feb 21, 2015
    Messages:
    3,937
    Likes Received:
    365
    Please mark this thread as resolved.
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice