Dell R730 UEFI boot installation issues


New Member
Nov 28, 2022
Hi all,

Dell R730, trying to install proxmox 7.3-1. Ive tried from USB key and from IPMI (iDRAC) and keep getting the attached errors.

I can boot to the installer without issue in BIOS legacy mode, but if we want zfs we need UEFI mode for full functionality.

Ive had the onboard PERC raid controller in full raid mode with disks in non raid status, raid status with a configured RAID 1 set to boot, and HBA mode, all get the error. I did read something about having some NIC's causing issues as I do have a set of Fibre NIC's installed in this server; but would rather not pull those out and leave empty open slots if I dont have to, I also cant disable them in BIOS. I have also reset bios settings, and the raid card. I have turned off vFLASH. I have also made sure all latest firmware and BIOS updates have been completed through the onboard firmware update system.

I am not sure what to do at this point.

Any help is appreciated.



  • 2022-11-27 23.57.20.jpg
    2022-11-27 23.57.20.jpg
    116.7 KB · Views: 43
Last edited:
  • Like
Reactions: Panzer1119
not sure if i interpret the error correctly but
The system detected an exception during the UEFI pre-boot environment
sounds like the issue is in the efi itself, not in the proxmox installer?

did you already check if your memory is fine with e.g. memtest?
Thanks for your response. Quick onboard diagnostics was completed, I didnt do a thorough but I may do that. I also have a duplicate R730 I was going to spin up later. I can just swap the disks to the other unit and try that server. With an earlier BIOS released from a few months ago. I may give that a try before pulling misc hardware to try and eliminate the hardware IO issue for UEFI.
Last edited:

it seems that Proxmox boots with version 6.4 just fine. Whats the difference between 6.4 and 7.3 that may cause this? Im going to try 7.0.
Ok, clearly there is an issue with 7.3.
v7.2 boots UEFI as well for install.

Clearly there is a bug in 7.3-1
mhmm... did you checkt the hash of the iso before booting it? maybe it's corrupted?
mhmm thats weird, it's surely not a general issue, since we did not run into such an error here in our lab (and it's the first instance of such an error that we know of)
could you maybe open a bug on so that we can track it better? best with all the infos you posted here too, but also what server/uefi/bios/ version etc.
Is there an option called "secure boot" somewhere in the bios related to uefi mode? If so, try to disable it .
I just resolve this in my dell workstation t7820 by this with 7.3-1.
Is there an option called "secure boot" somewhere in the bios related to uefi mode? If so, try to disable it .
I just resolve this in my dell workstation t7820 by this with 7.3-1.
you're right that secure boot is not supported, but the op wrote that it works with 6.4 and 7.2 and neither has secure boot support ....
Similar problem with Proxmox Backup Server 2.3 with ZFS and UEFI on R730:

R730 Proxmox Backup Server 2.3.png

The problem disappear when you remove hard disks (PBS install) from the R730.

UEFI Secure boot is not enabled.

Did you find any workaround for this problem with Dell R730 and Promox ?
Installing 8.0 Results in the same error for me. Was there any other workaround found other than installing an older version of proxmox?


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!