Dell Openmanage on Proxmox?

adamm

New Member
Aug 22, 2012
13
0
1
Vestal, NY, USA
Seems like Dell distributes open manage as RPM. Does anyone know a way to install it on Proxmox?

It would be convenient, but not the end of the world if we can't.
 

cesarpk

Active Member
Mar 31, 2012
770
3
38
note that for wheezy, you need install the libssl deb from squeeze. (you can have both libssl from squeezy and wheezy without conflict). This is because openmanage is build on top of libssl 0.9.8.
Hi spirit, soon i will install openmanage over PVE 2.3, 3.1 and 3.2. The lates version of openmanage is 7.4 according to this link: http://linux.dell.com/repo/community/debian/ My question is if will need to install the "libssl 0.9.8" from squeeze, or i will need to install some other requirement for these version of PVE for get that openmanage works well? Thank you in advance for your willingness to share your knowledge and experiences with those who need Best regards Cesar
 

spirit

Famous Member
Apr 2, 2010
5,782
678
133
www.odiso.com
Hi spirit, soon i will install openmanage over PVE 2.3, 3.1 and 3.2. The lates version of openmanage is 7.4 according to this link: http://linux.dell.com/repo/community/debian/ My question is if will need to install the "libssl 0.9.8" from squeeze, or i will need to install some other requirement for these version of PVE for get that openmanage works well? Thank you in advance for your willingness to share your knowledge and experiences with those who need Best regards Cesar

Hi, Last version works perfectly, just install libssl from squeeze. (download the .deb and dpkg -i to install it).
 

Nick Brown

New Member
Oct 17, 2016
5
0
1
43
openmanage jessie version works fine for me, it's just miss libslp1 package (remove in stretch), but you can download the package from jessie, it's works fine too.

That good news, but can I ask how you're installing it, because it won't install for me, because of unmet dependencies.

I'm adding a repo: deb http://linux.dell.com/repo/community/ubuntu jessie openmanage
... and then trying to install the package "srvadmin-all".

I get the following, regardless of libslp1:
The following packages have unmet dependencies:
srvadmin-all : Depends: srvadmin-itunnelprovider (>= 8.4.0) but it is not going to be installed​

Grateful for any hints. Cheers.
 

spirit

Famous Member
Apr 2, 2010
5,782
678
133
www.odiso.com
That good news, but can I ask how you're installing it, because it won't install for me, because of unmet dependencies.

I'm adding a repo: deb http://linux.dell.com/repo/community/ubuntu jessie openmanage
... and then trying to install the package "srvadmin-all".

I get the following, regardless of libslp1:
The following packages have unmet dependencies:
srvadmin-all : Depends: srvadmin-itunnelprovider (>= 8.4.0) but it is not going to be installed​

Grateful for any hints. Cheers.

wget http://ftp.us.debian.org/debian/pool/main/o/openslp-dfsg/libslp1_1.2.1-10+deb8u1_amd64.deb
dpkg -i libslp1_1.2.1-10+deb8u1_amd64.deb
 

fireon

Famous Member
Oct 25, 2010
3,910
325
103
40
Austria/Graz
iteas.at
I've tested the tools on three diverent Dellmachines. It is working for install and Services are running. But the tools for Raid did not work and the really importent connection from Idrac to the Host OS did also not work with 5.0. So please can you write a little howto for us? Sourceslistline, what from where to install. Thanks a lot.
 

rafaeltorres

Member
Aug 18, 2012
18
1
23
Hi, i installed OMSA 8.4 on proxmox 5.0 with sucessfull.
First tip, install libssl from jessie packages, works fine.
Second tip, if you can´t found any file or package, you can make download of RPM and convert with ALIEN to .deb. Worked for me.
 

rpotter28

New Member
Feb 29, 2012
23
2
3
That good news, but can I ask how you're installing it, because it won't install for me, because of unmet dependencies.

I'm adding a repo: deb http://linux.dell.com/repo/community/ubuntu jessie openmanage
... and then trying to install the package "srvadmin-all".

I get the following, regardless of libslp1:
The following packages have unmet dependencies:
srvadmin-all : Depends: srvadmin-itunnelprovider (>= 8.4.0) but it is not going to be installed​

Grateful for any hints. Cheers.

Try this:

# apt-get install srvadmin-webserver srvadmin-storageservices srvadmin-tomcat
 

Nick Brown

New Member
Oct 17, 2016
5
0
1
43
Thanks to everyone for their replies.

Between rafaeltorres's suggestion to also install libssl from jessie (along with libslp), and rpotter28's post on which packages to install, I've got it working now.

Cheers guys.
 

Martyy2k

New Member
Aug 13, 2017
1
0
1
47
Hello everyone, i am Marty and a pretty new noob to proxmox and servers in general. I do not have experience with linux. I have setup proxmox on my dell r710 server and have a few VM's running. So far so good.

My issue is getting Dell Openmanage server installed on Proxmox 5. I am far from good at this and completely messed up my 1st prox install when trying to get it installed. updates got all bugged and no longer worked and i got errors too. So i guess i screwed things up. Now a new fresh install of 5.0 is up and running.

Could someone guide me step by step so i can get this setup please. The reason i want to install is to be able to swap out drives in raid array etc if a bad drive turns up, rebuild array and learn! But getting this working has not been at all successful.

I setup a proxmox VM to play with, we learn from our mistakes! :)

Many thanks

Marty

PS i can get it working on proxmox 4.4 in a VM, but a no go in proxmox 5.0 :-(
 
Last edited:

sysrook

Member
Aug 14, 2017
2
1
8
72
Thanks to everyone for their replies.

Between rafaeltorres's suggestion to also install libssl from jessie (along with libslp), and rpotter28's post on which packages to install, I've got it working now.

Cheers guys.

Can you please point out which specific libssl package from jessie is needed? There are various options on the ftp server mentioned by user spirit (forum will not allow me to include link) but I'm not sure what the differences are. I believe it should be one of the ones in this dir:

http :// . ftp.us.debian.org/debian/pool/main/o/openssl/

Thank you
 

rpotter28

New Member
Feb 29, 2012
23
2
3
Can you please point out which specific libssl package from jessie is needed? There are various options on the ftp server mentioned by user spirit (forum will not allow me to include link) but I'm not sure what the differences are. I believe it should be one of the ones in this dir:

http :// . ftp.us.debian.org/debian/pool/main/o/openssl/

Thank you

# wget http://ftp.us.debian.org/debian/pool/main/o/openssl/libssl1.0.0_1.0.1t-1+deb8u6_amd64.deb

# dpkg -i libssl1.0.0_1.0.1t-1+deb8u6_amd64.deb
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!