Deleting mails with "delete" key in would be great in quarantine

Discussion in 'Mail Gateway: Installation and configuration' started by Pavel Hruška, Oct 9, 2018.

  1. Pavel Hruška

    Pavel Hruška New Member

    Joined:
    May 1, 2018
    Messages:
    22
    Likes Received:
    2
    When I am handling quarantine emails in a bulk it is quite irritating that I need to use mouse to trigger delete or deliver actions. It is already possible and very convinient to mark multiple emails using shift+arrows and I am using it a lot. Sometimes I even hit the wrong action (deliver instead delete) when using mouse and on single email selected there is no way back (no confirmation)...

    So I would like to ask if would be possible to trigger delete action by "(ctrl+)delete" and deliver action by "(ctrl+)enter" keys for example (or whatever else).

    Thank you.
     
  2. dcsapak

    dcsapak Proxmox Staff Member
    Staff Member

    Joined:
    Feb 1, 2016
    Messages:
    2,613
    Likes Received:
    239
    this is already implemented in a current version, you can also right click and get a context menu
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Pavel Hruška

    Pavel Hruška New Member

    Joined:
    May 1, 2018
    Messages:
    22
    Likes Received:
    2
    What is the key? Delete? I've tested it few moments ago and it did not work for me. Right click is okay, but the same with "wrong action triggered sometimes" applies here, these two options are too close to each other in the context menu.
     
  4. dcsapak

    dcsapak Proxmox Staff Member
    Staff Member

    Joined:
    Feb 1, 2016
    Messages:
    2,613
    Likes Received:
    239
    yes the 'delete' key works here, what client/browser/pmgversion do you have?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. Pavel Hruška

    Pavel Hruška New Member

    Joined:
    May 1, 2018
    Messages:
    22
    Likes Received:
    2
    Sorry for late reply, I was waiting for quarantine to fill up.

    Delete key does not work for me, I am using PMG 5.1-2, browser is Chrome. PMG is installed on top of Debian and running as LXC in PVE.

    Pressing delete key on selected mails in quarantine does nothing.

    Code:
    pmg-api/5.1-2/0b56b766 (running kernel: 4.15.18-5-pve)
     
  6. dcsapak

    dcsapak Proxmox Staff Member
    Staff Member

    Joined:
    Feb 1, 2016
    Messages:
    2,613
    Likes Received:
    239
    do you have a context menu in the quarantine?
    please post the output of 'pmgversion -v'

    what client os do you use?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. Pavel Hruška

    Pavel Hruška New Member

    Joined:
    May 1, 2018
    Messages:
    22
    Likes Received:
    2
    Client OS is Windows 10 (build 1803).

    Code:
    proxmox-mailgateway: 5.1-1 (API: 5.1-2/0b56b766, running kernel: 4.15.18-5-pve)
    pmg-api: 5.1-2
    pmg-gui: 1.0-42
    proxmox-spamassassin: 3.4.2-1
    proxmox-widget-toolkit: 1.0-20
    pve-kernel-4.15.18-4-pve: 4.15.18-23
    pve-kernel-4.13.16-3-pve: 4.13.16-49
    pve-kernel-4.13.16-1-pve: 4.13.16-46
    pve-kernel-4.15.18-7-pve: 4.15.18-26
    pve-kernel-4.13: 5.1-45
    pve-kernel-4.15: 5.2-10
    libpve-http-server-perl: 2.0-11
    lvm2: not correctly installed
    pve-firmware: 2.0-5
    libpve-common-perl: 5.0-40
    pmg-docs: 5.1-4
    pve-xtermjs: 1.0-5
    libarchive-perl: 3.2.1-1
    libxdgmime-perl: 0.01-3
    libpve-apiclient-perl: 2.0-5
     
  8. dcsapak

    dcsapak Proxmox Staff Member
    Staff Member

    Joined:
    Feb 1, 2016
    Messages:
    2,613
    Likes Received:
    239
    also did you already try to clear the browser cache?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. Pavel Hruška

    Pavel Hruška New Member

    Joined:
    May 1, 2018
    Messages:
    22
    Likes Received:
    2
    Context menu: yes, I have it.

    upload_2018-10-15_11-31-1.png

    Tried now, running in Chrome with "disable cache" in DevTools, no change. Tested in Chrome and even in Chrome canary now, still nothing.
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice