decode data encryption caps page failed - not external data encryption control capable

davlaw

Active Member
Apr 4, 2012
179
1
38
Can format ok, barcode/label fails

decode data encryption caps page failed - not external data encryption control capable

There are no encryption keys configured, let me know if I can grab any info

Code:
root@pbs172:~# proxmox-tape status --drive drive1
┌───────────────┬──────────────────────────┐
│ Name          │ Value                    │
╞═══════════════╪══════════════════════════╡
│ blocksize     │ 0                        │
├───────────────┼──────────────────────────┤
│ density       │ LTO3                     │
├───────────────┼──────────────────────────┤
│ compression   │ 1                        │
├───────────────┼──────────────────────────┤
│ buffer-mode   │ 1                        │
├───────────────┼──────────────────────────┤
│ file-number   │ 0                        │
├───────────────┼──────────────────────────┤
│ block-number  │ 0                        │
├───────────────┼──────────────────────────┤
│ manufactured  │ Mon Jun 19 20:00:00 2006 │
├───────────────┼──────────────────────────┤
│ bytes-written │ 13.93 TiB                │
├───────────────┼──────────────────────────┤
│ bytes-read    │ 9.04 TiB                 │
└───────────────┴──────────────────────────┘

Code:
root@pbs172:~# proxmox-tape status --drive drive0
┌───────────────┬──────────────────────────┐
│ Name          │ Value                    │
╞═══════════════╪══════════════════════════╡
│ blocksize     │ 0                        │
├───────────────┼──────────────────────────┤
│ density       │ LTO3                     │
├───────────────┼──────────────────────────┤
│ compression   │ 1                        │
├───────────────┼──────────────────────────┤
│ buffer-mode   │ 1                        │
├───────────────┼──────────────────────────┤
│ file-number   │ 0                        │
├───────────────┼──────────────────────────┤
│ block-number  │ 0                        │
├───────────────┼──────────────────────────┤
│ manufactured  │ Fri May 19 20:00:00 2006 │
├───────────────┼──────────────────────────┤
│ bytes-written │ 20.31 TiB                │
├───────────────┼──────────────────────────┤
│ bytes-read    │ 18.67 TiB                │
└───────────────┴──────────────────────────┘

Code:
root@pbs172:~# proxmox-tape drive list
┌────────┬────────────────────────────────────┬─────────┬────────┬─────────────┬────────────┐
│ name   │ path                               │ changer │ vendor │ model       │ serial     │
╞════════╪════════════════════════════════════╪═════════╪════════╪═════════════╪════════════╡
│ drive0 │ /dev/tape/by-id/scsi-F09C7CF000-sg │ ADIC    │ IBM    │ ULTRIUM-TD4 │ F09C7CF000 │
├────────┼────────────────────────────────────┼─────────┼────────┼─────────────┼────────────┤
│ drive1 │ /dev/tape/by-id/scsi-F09C7CF004-sg │ ADIC    │ IBM    │ ULTRIUM-TD4 │ F09C7CF004 │
└────────┴────────────────────────────────────┴─────────┴────────┴─────────────┴────────────┘
root@pbs172:~#

Code:
proxmox-backup: 1.0-4 (running kernel: 5.4.106-1-pve)
proxmox-backup-server: 1.1.5-1 (running version: 1.1.5)
pve-kernel-5.4: 6.4-1
pve-kernel-helper: 6.4-1
pve-kernel-5.4.106-1-pve: 5.4.106-1
pve-kernel-5.4.103-1-pve: 5.4.103-1
pve-kernel-5.4.65-1-pve: 5.4.65-1
ifupdown2: 3.0.0-1+pve3
libjs-extjs: 6.0.1-10
proxmox-backup-docs: 1.1.5-1
proxmox-backup-client: 1.1.5-1
proxmox-mini-journalreader: 1.1-1
proxmox-widget-toolkit: 2.5-2
pve-xtermjs: 4.7.0-3
smartmontools: 7.2-pve2
zfsutils-linux: 2.0.4-pve1
 
Last edited:

dcsapak

Proxmox Staff Member
Staff member
Feb 1, 2016
8,283
1,050
164
34
Vienna
can you post the full task log of the barcode-label? also, did you already check for drive firmware upgrades?
 

davlaw

Active Member
Apr 4, 2012
179
1
38
Hope I get the right info, as far as firmware, I think its the latest from the dell site that had LTO4 included with the library update firmware.

Not sure how comfortable I might feel trying to shoehorn another firmware into it, even tho it is IBM

I'll look around again, I was ok till this last update..

Code:
Proxmox
Backup Server 1.1-5
()
2021-04-30T06:55:02-04:00: media '000003' already inventoried (already labeled)
2021-04-30T06:55:02-04:00: media '000007' already inventoried (already labeled)
2021-04-30T06:55:02-04:00: media '000022' already inventoried (already labeled)
2021-04-30T06:55:02-04:00: media '000026' already inventoried (already labeled)
2021-04-30T06:55:02-04:00: media '000028' already inventoried (already labeled)
2021-04-30T06:55:02-04:00: media '000029' already inventoried (already labeled)
2021-04-30T06:55:02-04:00: checking/loading media '000036'
2021-04-30T06:55:40-04:00: TASK ERROR: decode data encryption caps page failed - not external data encryption control capable

during a backup job

Code:
Proxmox
Backup Server 1.1-5
()
2021-04-30T07:31:55-04:00: Starting tape backup job 'pbspsiscsi:pool3:drive1:bbkupjob0002'
2021-04-30T07:31:55-04:00: update media online status
2021-04-30T07:32:02-04:00: starting new media set - reason: policy CreateAt event triggered
2021-04-30T07:32:02-04:00: media set uuid: 6ec9bc80-62c3-4ffa-8c75-604de167088a
2021-04-30T07:32:02-04:00: found 62 groups
2021-04-30T07:32:02-04:00: latest-only: true (only considering latest snapshots)
2021-04-30T07:32:02-04:00: backup snapshot vm/100/2021-04-30T02:30:02Z
2021-04-30T07:32:02-04:00: allocated new writable media '000109'
2021-04-30T07:32:02-04:00: loading media '000109' into drive 'drive1'
2021-04-30T07:33:31-04:00: found media label 000109 (dde594f8-db36-4ec2-96ef-221056c0abf9)
2021-04-30T07:33:31-04:00: wrinting new media set label
2021-04-30T07:33:31-04:00: TASK ERROR: decode data encryption caps page failed - not external data encryption control capable
 

davlaw

Active Member
Apr 4, 2012
179
1
38
Gonna guess the library has the whole encryption wrapped up with its "key" for encryption and prevents the drive

I have look in various places and have not found any firmware to make this work.

I don't use any keys within pbs, but guess we still check?


Code:
root@pbs172:~/ITDT# stenc -f /dev/sg6 --detail
Status for /dev/sg6
--------------------------------------------------
Device Mfg:              IBM
Product ID:              ULTRIUM-TD4
Product Revision:        C7QH
Drive Encryption:        off
Drive Output:            Not decrypting
                         Raw encrypted data not outputted
Drive Input:             Not encrypting
Key Instance Counter:    0
Volume Encryption:       Not encrypted
Volume Algorithm:        1
 

dcsapak

Proxmox Staff Member
Staff member
Feb 1, 2016
8,283
1,050
164
34
Vienna
ok after looking at it again, it seem you try an LTO3 tape ? this is not supported, LTO-4 is the absolute minimum (even LTO-4 drives do not everything we need sometimes)
when you insert an LTO-3 drive into an LTO-4 it uses the LTO-3 feature set for most things, which is just to little..
 

davlaw

Active Member
Apr 4, 2012
179
1
38
Ahh.. I can understand that one. Makes sense.

I have same type library with LTO6 units on baroes, was hesitant to pull it for use here till I was sure.

Like most mom and pop operations IT budget is $0, maybe I can get them to spurge on a few LTO4 tapes

Thanks for your insight and help
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!