[SOLVED] Debian 11 Gnome Desktop & PVE 7 - Local Key Errors

patrick3

Member
Oct 4, 2016
6
1
21
69
Title says it.

I'm most of the way through setting up a new PVE 7 system on top of a default Debian 11 install. Basically using this guide with some tweaks.
https://pve.proxmox.com/wiki/Install_Proxmox_VE_on_Debian_Stretch

I used this PVE 7 repo:
Code:
deb [arch=amd64] http://download.proxmox.com/debian/pve bullseye pve-no-subscription

I found the key for PVE 7 here:
Code:
http://download.proxmox.com/debian/proxmox-release-bullseye.gpg

Initial apt update and installation of PVE 7 went smooth until the very last second when it is said:
Code:
Processing triggers for rsyslog (8.2102.0-2) ...
Processing triggers for man-db (2.9.4-2) ...
Processing triggers for proxmox-backup-file-restore (2.0.4-1) ...
Updating file-restore initramfs...
12755 blocks
Errors were encountered while processing:
 pve-manager
 proxmox-ve
E: Sub-process /usr/bin/dpkg returned an error code (1)

And the resulting error (repeats a few times):
Code:
Jul 19 16:30:42 devicehostname pveproxy[31731]: /etc/pve/local/pve-ssl.key: failed to load local private key (key_file or key) at /usr/share/perl5/PVE/APIServer/AnyEvent.pm line 1891.

pve-manager is kicking out the error, and proxmox-ve just can't complete until pve-manager is resolved first.

the dir /etc/pve/ exists, but is empty. it doesn't even have the /local subdir nor the pve-ssl.key file in question.


No other issues that I'm aware of....yet.

I understand this is a non-traditional install, but is there any suggestion to fix this other than just purging and trying again?
 
Last edited:

patrick3

Member
Oct 4, 2016
6
1
21
69
Just purged it and tried installing again as actual root user instead of sudo. Same issues at the same spots.

Here's a note of interest:
Code:
Setting up lxc-pve (4.0.9-2) ...
apparmor_parser: Unable to replace "/usr/bin/lxc-start".  Profile doesn't conform to protocol
apparmor_parser: Unable to replace "lxc-container-default".  Profile doesn't conform to protocol


Here's the other trouble areas that all seem to have the same error as the first post:
Code:
Setting up pve-firewall (4.2-2) ...
Job for pve-firewall.service failed because the control process exited with error code.

Setting up pve-ha-manager (3.3-1) ...
watchdog-mux.service is a disabled or a static unit, not starting it.
Job for pve-ha-lrm.service failed because the control process exited with error code.

Job for pve-ha-crm.service failed because the control process exited with error code.

Setting up pve-manager (7.0-10) ...
Job for pvestatd.service failed because the control process exited with error code.

pkg: error processing package pve-manager (--configure):
 installed pve-manager package post-installation script subprocess returned error exit status 1
dpkg: dependency problems prevent configuration of proxmox-ve:
 proxmox-ve depends on pve-manager; however:
  Package pve-manager is not configured yet.

dpkg: error processing package proxmox-ve (--configure):
 dependency problems - leaving unconfigured


Thanks in advance!
 

patrick3

Member
Oct 4, 2016
6
1
21
69
Wow. Flashback here. This is so eerily similar to the issue I had trying to run PVE as a container (empty /etc/pve/ dir), but this time it's not. This was a full-blown install of Deb11 and then trying to install PVE7 on top of it.

Due to this issue (which I'm not convinced apparmor alone is responsible for it) I decided to go about it the opposite way and installed PVE7 first and make sure it was 100% happy, then used tasksel to add the desktop/gnome quick and easy.

All seems well and happy!


Note for anyone thinking about doing the same:

INSTALL PVE FIRST!!!
Add the desktop and software of your choice SECOND!!!

1.)
After tasksel sets up the desktop, add your regular desktop user with a adduser, and make them a sudoer with usermod -aG sudo username-you-created. The root user cannot login to the desktop so you need another user. Make sure you do this FIRST before setting the desktop as the boot-up default.

2.) test the desktop out with systemctl start gdm3 or kdm / lightdm / slim or whatever display manager you installed.

3.) make the desktop the default bootup method with systemctl set-default graphical.target

Other than those minor tips, it was really simple and straightforward. Marking as SOLVED.
 
Last edited:
  • Like
Reactions: gtmarley

gtmarley

New Member
Aug 24, 2021
2
0
1
53
INSTALL PVE FIRST!!!
Add the desktop and software of your choice SECOND!!!
Thanks for doing the legwork. I've been meaning to try/evaluate proxmox ve at home but don't have sufficient extra hardware at the moment. I also realize that this isn't a standard configuration but wondered if someone had tried it. What is your scenario? I.e. are there scenarios other than poor man's lab? ;)
 
Last edited:

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!