Debian 10 template


Renowned Member
There seems to be a problem with the new Debian 10 template.
I'm not just talking about it's failure to run MySQL but it also seems to hang easily.
Two different Bind9 servers (LXC) on two different (KVM) hosts have now hung after I moved them to run on the new template.
They show high CPU usage and I can't log in to them even from Proxmox console. It times out after 60 seconds.

Last edited:

can you share your container config? (`pct config CTID`)
It's default:

root@vh2:~# pct config 143
arch: amd64
cores: 1
cpulimit: 2
memory: 1024
net0: name=eth0,bridge=vmbr1,firewall=1,gw=,gw6=2a00:1190:c003:ffff::1,hwaddr=32:50:F8:50:1B:32,ip=,ip6=2a00:1190:c003:ffff::143/64,rate=2,type=veth
onboot: 1
ostype: debian
rootfs: vdc:subvol-143-disk-0,size=8G
swap: 0
unprivileged: 1
There is an old VM on this host. Maybe it's problems are leaking over?
looks like your host is running out of memory. maybe you have too many guests running.
i think it's unlikely to be KVM related

They show high CPU usage and I can't log in to them even from Proxmox console. It times out after 60 seconds.

what about `pct enter CTID`? does that work?
Noticed something else odd about Debian 10 LXC template.
It's the only template that somehow leaks text all over when using terminal and especially when using byobu.
Here is an example of two "normal" commands that only Debian 10 container mixes up.

cat /etc/bind/named.conf.options
ls -ahl

Setting // If there is a firewall between you and nameservers you wantplend-keys==
No schem// to talk to, you may need to fix the firewall to allow multiple=========
Setting // ports to talk. See
Setting // If your ISP provided one or more IP addresses for stable
** initi// If your ISP provided one or more IP addresses for stable lacing
Setting // nameservers, you probably want to use them as forwarders. lacing
Setting // Uncomment the following block, and insert the addresses replacing
Setting // the all-0's placeholder.orm to RFC1035
Webmin i// forwarders {o; # conform to RFC1035ps://dns1:10000/
as root // forwarders {;ny; };d, or as any user who can use sudo
to run c// };ach0.0.0.0;0;;..
Processi// };cache-ttl 300;=======================================================
Processi// If BIND logs error messages about the root key being expired,ind-keys==
root@dns// you will need to update your keys. See
bind/ //========================================================================
root@dnsdnssec-enable yes;yes;;d.conf.options
dnssec-validation yes;;; };
dnssec-lookaside auto;;};
-rw-r--rallow-recursion { any; };31 2010 .bashrc
drwxr-xrallow-query { any; };Aug 6 15:43 .byobu
drwx----also-notify {ache { any; }; 16:44 .config
drwx----auth-nxd79.134.108.134;conform to RFC1035
drwxr-xrlisten-o79.134.108.142;g 21 14:37 .local
-rw-r--rmax-cach79.134.108.143;g 17 2015 .profile
drwx----max-ncac};-ttl 300;3 Aug 6 15:07 .ssh
-rw-r--rforwarders {er {1.3K Dec 5 2002 jcameron-key.asc
-rw-r--r-- 1 ro};.134.108.134;c 5 2002 jcameron-key.asc.1
};-------- 1 ro79.134.108.142;g 6 17:58 named.conf.options
root@dns1:~# cat79.134.108.143;d.conf.options
root@dns1:~# };
Same thing with Debian 9 template that I upgraded to Debian 10.
Conclusion: It's not the kernel and it's not the layer 1 option used in Debian 10 template until MySQL fix comes along because the Bind server does not have any need for nesting=1 option so I did not use it there? Anyway.
Looks like Debian 10 is hands of until it functions properly.
Last edited:
are you having this problem without webmin, on a regular debian container with bind?


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!