DAB.pm in Git changes to new OpenVZ conf folder

Discussion in 'Debian Appliance Builder' started by apmuthu, Aug 7, 2013.

  1. apmuthu

    apmuthu Member

    Joined:
    Feb 26, 2009
    Messages:
    744
    Likes Received:
    3
    The recent DAB.pm changes in the git repo reference /etc/pve/openvz folder in the new PVE 3 instead of the original /etc/vz/conf folder in the old PVE 1.9.

    Whilst the former folder does not exist in the PVE 1.9, the latter is symlinked to the former in PVE3 and both symlinks point to /etc/pve/nodes/[hostname_of_pve3]/openvz in PVE3.

    Hence if OpenVZ templates are compiled for PVE 1.9, it should run in PVE 3 as far as this issue is concerned. However, if the OpenVZ template is compiled in v3.0 with this Git fix, then it may be prudent to create a symlink in PVE 1.9 as /etc/pve/openvz pointing to the actual folder /etc/vz/conf to enable it's usage in PVE 1.9.
     
  2. dietmar

    dietmar Proxmox Staff Member
    Staff Member

    Joined:
    Apr 28, 2005
    Messages:
    16,484
    Likes Received:
    314
    Please do not use 1.9 - update to 3.0 instead.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. apmuthu

    apmuthu Member

    Joined:
    Feb 26, 2009
    Messages:
    744
    Likes Received:
    3
    Going forward, it is prudent to use PVE 3.0 for new appliances.
    Old Appliances on PVE 1.9 with too much customisations will have to be left as is till they can safely be migrated to the PVE 3.0 hosts.

    The above is to document potential gotchas in backporting appliances.

    PVE 1.9's easy to customise and simple interface is very appealing and is quite well documented and admins are quite familiar with it's quirks.

    PVE 1.9 and older are still preferred for testing and in secure local deployments especially for those instances where internet is not available. Using older versions of PHP and MySQL in some applications may also be potential use cases if resources to port them to later platforms are not available.

    Compatibility with older hardware and older appliances like the old BlueOnyx and my older templates are reason enough for it to last a while.
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice