cloud-init packege_upgrade=true

Discussion in 'Proxmox VE: Installation and configuration' started by Daniele de Petris, Dec 7, 2018.

  1. Daniele de Petris

    Daniele de Petris New Member

    Joined:
    Jan 4, 2016
    Messages:
    11
    Likes Received:
    0
    Hello the implementation of PVE/QemuServer/Cloudinit.pm puts on user_data by default package_upgrade=true this is problematic if a reboot or migration is done and you do not want to do an update. How can this behavior be remedied?
     
  2. Daniele de Petris

    Daniele de Petris New Member

    Joined:
    Jan 4, 2016
    Messages:
    11
    Likes Received:
    0
    Hi is possible put a simple check box on clud-init web interface to set this property ?
     
  3. dlimbeck

    dlimbeck Proxmox Staff Member
    Staff Member

    Joined:
    Aug 1, 2018
    Messages:
    123
    Likes Received:
    7
    For now there's no way to change that except for modifying the local file in /usr/share/perl5/PVE/QemuServer/Cloudinit.pm
    You could add an enhancement in our bugtracker(https://bugzilla.proxmox.com/) for this option.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice