Cloud-init Issue: ISOFS: Unable to identify CD-ROOM format


Nov 8, 2019
Hello Proxmox community,

New proxmox user here seeking some guidance into the Cloud-init deployment issue I am unable to fix.

Cloudinit is not executing, Network details are no configured and User password is not set.
It does look like its affecting all of the templates I created: Deb 10, Ubuntu 18.04 and Centos 7
Debian and Ubuntu just quickly load into the login screen without cloud-init execution.

Centos 7 was the template that gave me a clue about the issue - ISOFS: Unable to identify CD-ROOM format (screenshot below)

Screen Shot 2019-11-08 at 1.26.28 AM.png

I had tried the following
- Changed Cloud-init drive between IDE2, SCSI and SATA just to see if it would be the reason. - No luck
- As pictured below, the drives are in local-lvm thin volume.
- I had also tried changing the cloudinit from local-lvm to local storage.
- tried qcow2 images no luck, what is used - RAW images.

Screenshots: Template configuration which is then passed on the clone.
Everything was done by the documentation - image created and then turned into a template. The issue does seem to be outside of the cloud-init scope and more towards the server since Ubuntu and Debian templates do not even have a referense about the CD-ROOM format.
The server was an upgrade of regular Deb 10 Buster into the Proxmox 6.

Screen Shot 2019-11-08 at 1.25.48 AM.png Screen Shot 2019-11-08 at 1.25.32 AM.png

# pveversion -v
proxmox-ve: 6.0-2 (running kernel: 5.0.21-4-pve)
pve-manager: 6.0-11 (running version: 6.0-11/2140ef37)
pve-kernel-helper: 6.0-11
pve-kernel-5.0: 6.0-10
pve-kernel-5.0.21-4-pve: 5.0.21-8
ceph-fuse: 12.2.11+dfsg1-2.1+b1
corosync: 3.0.2-pve4
criu: 3.11-3
glusterfs-client: 5.5-3
libjs-extjs: 6.0.1-10
libknet1: 1.13-pve1
libpve-access-control: 6.0-3
libpve-apiclient-perl: 3.0-2
libpve-common-perl: 6.0-6
libpve-guest-common-perl: 3.0-2
libpve-http-server-perl: 3.0-3
libpve-storage-perl: 6.0-9
libqb0: 1.0.5-1
lvm2: 2.03.02-pve3
lxc-pve: 3.2.1-1
lxcfs: 3.0.3-pve60
novnc-pve: 1.1.0-1
proxmox-mini-journalreader: 1.1-1
proxmox-widget-toolkit: 2.0-8
pve-cluster: 6.0-7
pve-container: 3.0-10
pve-docs: 6.0-8
pve-edk2-firmware: 2.20190614-1
pve-firewall: 4.0-7
pve-firmware: 3.0-4
pve-ha-manager: 3.0-2
pve-i18n: 2.0-3
pve-qemu-kvm: 4.0.1-4
pve-xtermjs: 3.13.2-1
qemu-server: 6.0-13
smartmontools: 7.0-pve2
spiceterm: 3.1-1
vncterm: 1.6-1

Researched a little deeper yesterday and the issue is indeed in /dev/sr0 (CD-ROOM).

Created a template with default root login for me to login. (Debian/Ubuntu) - Cloud-init version 19.2
Setup Cloud-init drive - tried ide2 and scsci.
Started the image
Logged in and /dev/sr0 is empty.

Can someone recommend the steps to understand what the problem is with inability to read Cloud-init drive?

Screen Shot 2019-11-09 at 9.47.31 AM.png

Cloud-Init volume exists

  --- Logical volume ---
  LV Path                /dev/pve/vm-105-cloudinit
  LV Name                vm-105-cloudinit
  VG Name                pve
  LV UUID                hAVUq5-CCCC-71JH-1Kis-zHCN-sDh4-hVUHjt
  LV Write Access        read/write
  LV Creation host, time m-10, 2019-11-09 17:25:32 +0100
  LV Pool name           data
  LV Status              available
  # open                 0
  LV Size                4.00 MiB
  Mapped size            0.00%
  Current LE             1
  Segments               1
  Allocation             inherit
  Read ahead sectors     auto
  - currently set to     256
  Block device           253:16

Last edited:


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!