CIFS: storage is not online (500)

emberzhang

New Member
Jul 30, 2020
2
1
3
37
same negotiation problem with macOS server too. from bigsur to montery, from pve 5.x to 7.0

check from another macbook shows the server smb version is 3.0:

--------------------------------------------------------------------------------------------------
➜ ~ smbutil statshares -a

==================================================================================================
SHARE ATTRIBUTE TYPE VALUE
==================================================================================================
Archive
SERVER_NAME 172.16.1.100
USER_ID 501
SMB_NEGOTIATE SMBV_NEG_SMB1_ENABLED
SMB_NEGOTIATE SMBV_NEG_SMB2_ENABLED
SMB_NEGOTIATE SMBV_NEG_SMB3_ENABLED
SMB_VERSION SMB_3.0.2
SMB_ENCRYPT_ALGORITHMS AES_128_CCM_ENABLED
SMB_ENCRYPT_ALGORITHMS AES_128_GCM_ENABLED
SMB_ENCRYPT_ALGORITHMS AES_256_CCM_ENABLED
SMB_ENCRYPT_ALGORITHMS AES_256_GCM_ENABLED
SMB_CURR_ENCRYPT_ALGORITHM OFF
SMB_SHARE_TYPE DISK
SIGNING_SUPPORTED TRUE
SIGNING_REQUIRED TRUE
EXTENDED_SECURITY_SUPPORTED TRUE
UNIX_SUPPORT TRUE
LARGE_FILE_SUPPORTED TRUE
OS_X_SERVER TRUE
FILE_IDS_SUPPORTED TRUE
FILE_LEASING_SUPPORTED TRUE
MULTI_CREDIT_SUPPORTED TRUE
DIR_LEASING_SUPPORTED TRUE
ENCRYPTION_SUPPORTED TRUE
SIGNING_ON TRUE
==================================================================================================

and the on pve :
--------------------------------------------------------------------------------------------------
root@pve:~# pvesm add cifs mac --server 172.16.1.100 --share proxmox --username ember --password <password> --domain WORKGROUP --smbversion 3.0
create storage failed: storage 'mac' is not online

--------------------------------------------------------------------------------------------------

no help with changing or deleting the "--domain" part
 
Last edited:

Fabian_E

Proxmox Staff Member
Staff member
Aug 1, 2019
1,746
307
88
Hi,
--------------------------------------------------------------------------------------------------
root@pve:~# pvesm add cifs mac --server 172.16.1.100 --share proxmox --username ember --password <password> --domain WORKGROUP --smbversion 3.0
create storage failed: storage 'mac' is not online

--------------------------------------------------------------------------------------------------

no help with changing or deleting the "--domain" part
does it work if you don't specify --smbversion at all? What do you get with
Code:
time smbclient //<host>/<share> -d 0 -U <user>%<password> -c 'echo 1 0'
time smbclient //<host>/<share> -d 0 -U <user>%<password> -W WORKGROUP -c 'echo 1 0'
Please also share the output of pveversion -v.
 

emberzhang

New Member
Jul 30, 2020
2
1
3
37
Hi,

does it work if you don't specify --smbversion at all? What do you get with
Code:
time smbclient //<host>/<share> -d 0 -U <user>%<password> -c 'echo 1 0'
time smbclient //<host>/<share> -d 0 -U <user>%<password> -W WORKGROUP -c 'echo 1 0'
Please also share the output of pveversion -v.
removed --smbversion
--------------------------------------------------------------------------------------------------
root@pve:~# pvesm add cifs mac --server 172.16.1.100 --share proxmox --username ember --password <password> --domain WORKGROUP
create storage failed: storage 'mac' is not online
root@pve:~# pvesm add cifs mac --server 172.16.1.100 --share proxmox --username ember --password <password>
create storage failed: storage 'mac' is not online
========================================================
time smbclient: to a macOS server
--------------------------------------------------------------------------------------------------
root@pve:~# time smbclient //172.16.1.100/proxmox -d 0 -U ember%password -c 'echo 1 0'
echo failed: NT_STATUS_CONNECTION_DISCONNECTED

real 0m0.293s
user 0m0.034s
sys 0m0.029s

root@pve:~# time smbclient //172.16.1.100/proxmox -d 0 -U ember%password -W WORKGROUP -c 'echo 1 0'
echo failed: NT_STATUS_CONNECTION_DISCONNECTED

real 0m0.101s
user 0m0.029s
sys 0m0.009s

========================================================
time smbclient: to a linux server (no problem)
--------------------------------------------------------------------------------------------------
root@pve:~# time smbclient //172.16.1.200/m2 -d 0 -U ember%password -c 'echo 1 0'

real 0m0.059s
user 0m0.028s
sys 0m0.012s

root@pve:~# time smbclient //172.16.1.200/m2 -d 0 -U ember%password -W WORKGROUP -c 'echo 1 0'

real 0m0.054s
user 0m0.030s
sys 0m0.009s
========================================================
pveversion -v
--------------------------------------------------------------------------------------------------
root@pve:~# pveversion -v
proxmox-ve: 7.0-2 (running kernel: 5.11.22-3-pve)
pve-manager: 7.0-14+1 (running version: 7.0-14+1/08975a4c)
pve-kernel-helper: 7.1-4
pve-kernel-5.11: 7.0-10
pve-kernel-5.11.22-7-pve: 5.11.22-12
pve-kernel-5.11.22-5-pve: 5.11.22-10
pve-kernel-5.11.22-4-pve: 5.11.22-9
pve-kernel-5.11.22-3-pve: 5.11.22-7
pve-kernel-5.11.22-1-pve: 5.11.22-2
ceph-fuse: 15.2.13-pve1
corosync: 3.1.5-pve2
criu: 3.15-1+pve-1
glusterfs-client: 9.2-1
ifupdown2: 3.1.0-1+pmx3
ksm-control-daemon: 1.4-1
libjs-extjs: 7.0.0-1
libknet1: 1.22-pve2
libproxmox-acme-perl: 1.4.0
libproxmox-backup-qemu0: 1.2.0-1
libpve-access-control: 7.0-6
libpve-apiclient-perl: 3.2-1
libpve-common-perl: 7.0-12
libpve-guest-common-perl: 4.0-2
libpve-http-server-perl: 4.0-3
libpve-storage-perl: 7.0-13
libspice-server1: 0.14.3-2.1
lvm2: 2.03.11-2.1
lxc-pve: 4.0.9-4
lxcfs: 4.0.8-pve2
novnc-pve: 1.2.0-3
proxmox-backup-client: 2.0.13-1
proxmox-backup-file-restore: 2.0.13-1
proxmox-mini-journalreader: 1.2-1
proxmox-widget-toolkit: 3.3-6
pve-cluster: 7.0-3
pve-container: 4.1-1
pve-docs: 7.0-5
pve-edk2-firmware: 3.20210831-1
pve-firewall: 4.2-5
pve-firmware: 3.3-3
pve-ha-manager: 3.3-1
pve-i18n: 2.5-1
pve-qemu-kvm: 6.1.0-1
pve-xtermjs: 4.12.0-1
qemu-server: 7.0-18
smartmontools: 7.2-1
spiceterm: 3.2-2
vncterm: 1.7-1
zfsutils-linux: 2.1.1-pve3
========================================================
 
  • Like
Reactions: vesalius

johnny5w

New Member
Mar 23, 2022
1
0
1
Anyone find a fix for this? Trying to add SMB/CIFS storage from a macOS Catalina share to Proxmox 7.1-11 and am having the exact issue as the above responses.
 

breakaway9000

Active Member
Dec 20, 2015
78
14
28
I just hit this very same issue. I was trying to connect a SMB share from my Synolgy to my Proxmox. Unfortunately, it didn't work and I had no choice but to give up. I'm now using NFS.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!