[SOLVED] CIFS Issue - error with cfs lock 'file-storage_cfg' (working now but shows question mark)

JohnMC

Member
Oct 12, 2017
10
1
6
35
I've been playing with the new CIFS mounting options in the webui and cant seem to get it to work. I've turned to the console to try and get more feedback, when I run:
Code:
pvesm cifsscan 192.168.1.2 --username ProxmoxBackup --password Password

I successfully get a list of available shares including my target "ProxmoxBackup" so I run:
Code:
pvesm add cifs extbackup --server 192.168.1.2 --share ProxmoxBackup --username ProxmoxBackup --password Password

And I get:
Code:
mount error(95): Operation not supported
create storage failed: error with cfs lock 'file-storage_cfg': mount error: Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

So I double check share and file system permissions on the Windows 2008R2 server the share is hosted on and everything is set to full, so I run:
Code:
mkdir /mnt/test
mount -t cifs -o username=ProxmoxBackup,password=Password //192.168.1.2/ProxmoxBackup /mnt/test
touch /mnt/test/testfile
rm /mnt/test/testfile

And this seems to work without issue, what can I do to further understand where the proxmox file storage is getting hung up?

Edit: After reading CIFS wiki a few more times and finding a couple posts talking about smb version, I realized that despite smb version not being available in the web ui, I could set it on the command line. Despite the example showing "3" being a valid value it appears 2.0, 2.1, 3.0 are the exact values you need to use. Setting it to 2.1 worked for me:

Code:
pvesm add cifs extbackup --server 192.168.1.2 --share ProxmoxBackup --username ProxmoxBackup --password Password --smbversion 2.1

I wish this option was in the web ui but maybe that will come in the future. The one other thing that I still see wrong is that in the web ui, the icon for the storage under the node shows a question mark as if it's not connected, but it is and i'm able to make and restore a backup using that storage.
 
Last edited:
  • Like
Reactions: amace

luka_matkic

New Member
Apr 3, 2020
1
0
1
26
Thanks JohnMC, your answer helped me big time :)

I just want to point one more thing witch may result in Proxmox returning error code.
I have copy-pasted your command and changed username and password but got "400 - too many arguments".

The problem was in my password containing "#" and "!" characters.
I created new account without these characters and problem was solved.
 

mls228

New Member
Sep 19, 2020
2
0
1
43
Just wanted to resurrect this thread and note that it helped me immensely and I had to change the --smbversion to 2.0 on my older Synology NAS.

pvesm add cifs extbackup --server 192.168.1.2 --share ProxmoxBackup --username ProxmoxBackup --password Password --smbversion 2.1
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!