Changes from PVE 3.3 to 3.4 breaks KVM

totalimpact

Member
Dec 12, 2010
119
10
18
Experiencing some behavior changes in PVE 3.4. Mainly I am unable to boot iso from Grub4dos in KVM, worked fine in 3.3. My goal is to access the registry of an XP guest to inject ide drivers and fix mbr, if someone knows an alternate method to accomplish that I would love to know.

I have migrated windows guests to all manner of platform from PVE to vbox, to vmware, and in this case I have pulled a backup of an XP machine using fsarchiver, and have restored it to a VM. At this point I always boot Hirens boot cd in the VM to the Mini XP to fix the IDE drivers in the registry and MBR.

BUT when I boot from the ISO, I get the standard Hirens menu and select Mini XP, it just freezes the VM completely at a chainloader screen like this:
Code:
Will boot ntldr from drive=0xe0, partition=0xff(hidden sectors=0x0)
error.png

The Reset button does not work on the VM, it just stays at that screen, only the Stop button can turn it off.

I can boot into parted magic linux from the same iso, but strangely x11 from Xorg wont boot, I have to use Xvesa.

I have another PVE system at another location running 3.3 which works perfectly fine in XP or Linux from the same Hirens ISO. I have even re-downloaded and extracted the iso on my non-working system. So something has changed that has broken something in KVM. I have changed CPU modes, Display, cursor, ACPI... Any other ideas?

Dont work: pveversion pve-manager/3.4-3/2fc72fee (running kernel: 2.6.32-37-pve)
Works: pveversion pve-manager/3.3-1/a06c9f73 (running kernel: 2.6.32-32-pve)
 

ds(ds)

Member
Sep 11, 2011
60
0
6
i have this problem with Hirens Cd too. on Hiren CD 15.2 all works. (and freezy mouse sometimes)
UPD
I cant install version 3.4 - bug on uefi boot . Install version 3.2 and then upgrade to 3.4 (not agreed to overwrite the boot loader )
 

totalimpact

Member
Dec 12, 2010
119
10
18
some rambling info on this, and an "almost workaround"-

This 3.3 system works with Hirens:
Code:
proxmox-ve-2.6.32: 3.2-136 (running kernel: 2.6.32-32-pve)
pve-manager: 3.3-1 (running version: 3.3-1/a06c9f73)
pve-kernel-2.6.32-32-pve: 2.6.32-136
lvm2: 2.02.98-pve4
clvm: 2.02.98-pve4
corosync-pve: 1.4.7-1
openais-pve: 1.1.4-3
libqb0: 0.11.1-2
redhat-cluster-pve: 3.2.0-2
resource-agents-pve: 3.9.2-4
fence-agents-pve: 4.0.10-1
pve-cluster: 3.0-15
qemu-server: 3.1-34
pve-firmware: 1.1-3
libpve-common-perl: 3.0-19
libpve-access-control: 3.0-15
libpve-storage-perl: 3.0-23
pve-libspice-server1: 0.12.4-3
vncterm: 1.1-8
vzctl: 4.0-1pve6
vzprocps: 2.0.11-2
vzquota: 3.1-2
pve-qemu-kvm: 2.1-5
ksm-control-daemon: 1.1-1
glusterfs-client: 3.5.2-1
This new system does not work, just dies when picking Mini XP from the Grub4Dos menu:
Code:
Proxmox-ve-2.6.32: 3.3-147 (running kernel: 2.6.32-37-pve)
pve-manager: 3.4-6 (running version: 3.4-6/102d4547)
pve-kernel-2.6.32-37-pve: 2.6.32-150
lvm2: 2.02.98-pve4
clvm: 2.02.98-pve4
corosync-pve: 1.4.7-1
openais-pve: 1.1.4-3
libqb0: 0.11.1-2
redhat-cluster-pve: 3.2.0-2
resource-agents-pve: 3.9.2-4
fence-agents-pve: 4.0.10-2
pve-cluster: 3.0-17
qemu-server: 3.4-6
pve-firmware: 1.1-4
libpve-common-perl: 3.0-24
libpve-access-control: 3.0-16
libpve-storage-perl: 3.0-33
pve-libspice-server1: 0.12.4-3
vncterm: 1.1-8
vzctl: 4.0-1pve6
vzprocps: 2.0.11-2
vzquota: 3.1-2
pve-qemu-kvm: 2.2-10
ksm-control-daemon: 1.1-1
glusterfs-client: 3.5.2-1
I have tried back dating some of the kvm/qemu/kernel components as below, but still cannot boot mini-xp (PE):


Code:
proxmox-ve-2.6.32: 3.3-147 (running kernel: 2.6.32-32-pve)
pve-manager: 3.4-6 (running version: 3.4-6/102d4547)
pve-kernel-2.6.32-32-pve: 2.6.32-136
pve-kernel-2.6.32-37-pve: 2.6.32-150
lvm2: 2.02.98-pve4
clvm: 2.02.98-pve4
corosync-pve: 1.4.7-1
openais-pve: 1.1.4-3
libqb0: 0.11.1-2
redhat-cluster-pve: 3.2.0-2
resource-agents-pve: 3.9.2-4
fence-agents-pve: 4.0.10-2
pve-cluster: 3.0-17
qemu-server: 3.1-34
pve-firmware: 1.1-3
libpve-common-perl: 3.0-24
libpve-access-control: 3.0-16
libpve-storage-perl: 3.0-33
pve-libspice-server1: 0.12.4-3
vncterm: 1.1-8
vzctl: 4.0-1pve6
vzprocps: 2.0.11-2
vzquota: 3.1-2
pve-qemu-kvm: 2.1-5
ksm-control-daemon: 1.1-1
glusterfs-client: 3.5.2-1
I was able to boot the vm using an ERD boot disk, and inject the IDE drivers in to the registry, but I am still having trouble fixing the boot record to show it where ntldr is... previously it was booting via a Intel fake raid... will try to extract the tools to fix mbr from the hirens iso.
 

malakatronis

Member
Jul 21, 2012
33
0
6
Spain
Experiencing some behavior changes in PVE 3.4. Mainly I am unable to boot iso from Grub4dos in KVM, worked fine in 3.3. My goal is to access the registry of an XP guest to inject ide drivers and fix mbr, if someone knows an alternate method to accomplish that I would love to know.

I have migrated windows guests to all manner of platform from PVE to vbox, to vmware, and in this case I have pulled a backup of an XP machine using fsarchiver, and have restored it to a VM. At this point I always boot Hirens boot cd in the VM to the Mini XP to fix the IDE drivers in the registry and MBR.

BUT when I boot from the ISO, I get the standard Hirens menu and select Mini XP, it just freezes the VM completely at a chainloader screen like this:
Code:
Will boot ntldr from drive=0xe0, partition=0xff(hidden sectors=0x0)
View attachment 2648

The Reset button does not work on the VM, it just stays at that screen, only the Stop button can turn it off.

I can boot into parted magic linux from the same iso, but strangely x11 from Xorg wont boot, I have to use Xvesa.

I have another PVE system at another location running 3.3 which works perfectly fine in XP or Linux from the same Hirens ISO. I have even re-downloaded and extracted the iso on my non-working system. So something has changed that has broken something in KVM. I have changed CPU modes, Display, cursor, ACPI... Any other ideas?

Dont work: pveversion pve-manager/3.4-3/2fc72fee (running kernel: 2.6.32-37-pve)
Works: pveversion pve-manager/3.3-1/a06c9f73 (running kernel: 2.6.32-32-pve)
The same thing happens to me. Hiren's BootCD won't boot Mini Windows XP. It hangs and shows status "internal-error" in GUI.

As a first workaround, I got it to boot by disabling KVM hardware virtualization, i.e. setting "kvm: 0" in /etc/pve/qemu-server/$VMID.conf.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!