Ceph install problem

Discussion in 'Proxmox VE: Installation and configuration' started by Mehmet Sait YILMAZ, Sep 16, 2018.

  1. Mehmet Sait YILMAZ

    Mehmet Sait YILMAZ New Member

    Joined:
    Aug 5, 2018
    Messages:
    5
    Likes Received:
    0
    Hello i never see that problem before

    when i try to install ceph luminous ,
    i see it , what is problem ?

    "
    The following packages will be REMOVED:
    libpve-guest-common-perl libpve-storage-perl proxmox-ve pve-container pve-ha-manager
    pve-manager qemu-server
    "


    Do you want to continue? [Y/n] y
    W: (pve-apt-hook) !! WARNING !!
    W: (pve-apt-hook) You are attempting to remove the meta-package 'proxmox-ve'!
    W: (pve-apt-hook)
    W: (pve-apt-hook) If you really you want to permanently remove 'proxmox-ve' from your system, run the following command
    W: (pve-apt-hook) touch '/please-remove-proxmox-ve'
    W: (pve-apt-hook) and repeat your apt-get/apt invocation.
    W: (pve-apt-hook)
    W: (pve-apt-hook) If you are unsure why 'proxmox-ve' would be removed, please verify
    W: (pve-apt-hook) - your APT repository settings
    W: (pve-apt-hook) - that you are using 'apt-get dist-upgrade' or 'apt full-upgrade' to upgrade your system
    E: Sub-process /usr/share/proxmox-ve/pve-apt-hook returned an error code (1)
    E: Failure running script /usr/share/proxmox-ve/pve-apt-hook
     
  2. wolfgang

    wolfgang Proxmox Staff Member
    Staff Member

    Joined:
    Oct 1, 2014
    Messages:
    3,995
    Likes Received:
    241
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Mehmet Sait YILMAZ

    Mehmet Sait YILMAZ New Member

    Joined:
    Aug 5, 2018
    Messages:
    5
    Likes Received:
    0
    my rep is ok

    never see it before
     
  4. Knuuut

    Knuuut Member

    Joined:
    Jun 7, 2018
    Messages:
    50
    Likes Received:
    3
    HOW did you want to install ceph?

    pveceph install

    is the right way.
     
  5. Mehmet Sait YILMAZ

    Mehmet Sait YILMAZ New Member

    Joined:
    Aug 5, 2018
    Messages:
    5
    Likes Received:
    0
    i use pveceph install or pveceph install --verison luminous
     
  6. PostFix

    PostFix New Member

    Joined:
    Sep 27, 2018
    Messages:
    2
    Likes Received:
    0
    I have the same problem.
    pveceph install --verison luminous brings:

    Need to get 0 B/54.8 MB of archives.
    After this operation, 169 MB of additional disk space will be used.
    Do you want to continue? [Y/n] Y
    W: (pve-apt-hook) !! WARNING !!
    W: (pve-apt-hook) You are attempting to remove the meta-package 'proxmox-ve'!
    W: (pve-apt-hook)
    W: (pve-apt-hook) If you really you want to permanently remove 'proxmox-ve' from your system, run the following command
    W: (pve-apt-hook) touch '/please-remove-proxmox-ve'
    W: (pve-apt-hook) and repeat your apt-get/apt invocation.
    W: (pve-apt-hook)
    W: (pve-apt-hook) If you are unsure why 'proxmox-ve' would be removed, please verify
    W: (pve-apt-hook) - your APT repository settings
    W: (pve-apt-hook) - that you are using 'apt-get dist-upgrade' or 'apt full-upgrade' to upgrade your system
    E: Sub-process /usr/share/proxmox-ve/pve-apt-hook returned an error code (1)
    E: Failure running script /usr/share/proxmox-ve/pve-apt-hook


    My /etc/apt/sources.list.d/ceph.list contains:
    deb http://download.proxmox.com/debian/ceph-luminous stretch main
     
  7. Alwin

    Alwin Proxmox Staff Member
    Staff Member

    Joined:
    Aug 1, 2017
    Messages:
    1,675
    Likes Received:
    144
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. PostFix

    PostFix New Member

    Joined:
    Sep 27, 2018
    Messages:
    2
    Likes Received:
    0
  9. Alwin

    Alwin Proxmox Staff Member
    Staff Member

    Joined:
    Aug 1, 2017
    Messages:
    1,675
    Likes Received:
    144
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. ddhulla

    ddhulla New Member

    Joined:
    Dec 21, 2017
    Messages:
    2
    Likes Received:
    0
    Even I had today issue.
    Installed Proxmox.
    Than install over non subscription
    Now trying pveceph install

    Got into same error asking for removal.
     
  11. ddhulla

    ddhulla New Member

    Joined:
    Dec 21, 2017
    Messages:
    2
    Likes Received:
    0
    Got the mistake ,
    The non subscription details in repo file had spelling mistakes.

    Means not having repo property.

    At the same time after correction it was showing same error, seems some how cache of apt was not getting clear.

    After a fresh install and proper repo file configuration was able to install ceph.

    Thanks.
     
  12. tomstephens89

    tomstephens89 Member

    Joined:
    Mar 10, 2014
    Messages:
    140
    Likes Received:
    1
    I am having exactly the same problem. Fresh install using the 5.2 iso.

    pveceph install does not work and attempts to remove proxmox-ve.

    This is a fresh install, not changed any repo or anything. I do not have a subscription.

    I installed proxmox 5.2 3 times 2 months ago and installed Ceph just fine.

    What has changed?
     
  13. Deepen Dhulla

    Deepen Dhulla New Member

    Joined:
    Mar 1, 2016
    Messages:
    2
    Likes Received:
    0
    Hi
    do a fresh install of proxmox 5.2 via iso
    than for installing a no-subscription package do following.

    ##Check and make note of your kernel (so that you can confirm you got repo install proper and update properly)
    uname -a
    ### you would get output like : Linux ws22 4.15.17-1-pve #1 SMP PVE 4.15.17-9 (Wed, 9 May 2018 13:31:43 +0200) x86_64 GNU/Linux

    ## remove enterprise repo.
    mv /etc/apt/sources.list.d/pve-enterprise.list /root/

    ## add no-subscription repo
    echo "deb http://download.proxmox.com/debian/pve stretch pve-no-subscription" > /etc/apt/sources.list.d/pve-no-sub.list

    ## do update, upgrade & dist-upgrade
    apt-get update
    apt-get upgrade
    apt-get dist-upgrade

    ## make sure you see latest kernel ..uname -a (if you see new version like below or greater , its updated)
    uname -a
    ## new output Linux air 4.15.18-7-pve #1 SMP PVE 4.15.18-27 (Wed, 10 Oct 2018 10:50:11 +0200) x86_64 GNU/Linux

    #Now have a reboot and got for ceph installation , it would got fine.

    pveceph install


    -Deepen.
     
  14. Deepen Dhulla

    Deepen Dhulla New Member

    Joined:
    Mar 1, 2016
    Messages:
    2
    Likes Received:
    0

    Hi
    do a fresh install of proxmox 5.2 via iso
    than for installing a no-subscription package do following.

    ##Check and make note of your kernel (so that you can confirm you got repo install proper and update properly)
    uname -a
    ### you would get output like : Linux ws22 4.15.17-1-pve #1 SMP PVE 4.15.17-9 (Wed, 9 May 2018 13:31:43 +0200) x86_64 GNU/Linux

    ## remove enterprise repo.
    mv /etc/apt/sources.list.d/pve-enterprise.list /root/

    ## add no-subscription repo
    echo "deb http://download.proxmox.com/debian/pve stretch pve-no-subscription" > /etc/apt/sources.list.d/pve-no-sub.list

    ## do update & dist-upgrade
    apt-get update
    apt-get dist-upgrade

    ## make sure you see latest kernel ..uname -a (if you see new version like below or greater , its updated)
    uname -a
    ## new output Linux air 4.15.18-7-pve #1 SMP PVE 4.15.18-27 (Wed, 10 Oct 2018 10:50:11 +0200) x86_64 GNU/Linux

    #Now have a reboot and got for ceph installation , it would got fine.

    pveceph install


    -Deepen.
     
    #14 Deepen Dhulla, Oct 24, 2018
    Last edited by a moderator: Oct 24, 2018
  15. tomstephens89

    tomstephens89 Member

    Joined:
    Mar 10, 2014
    Messages:
    140
    Likes Received:
    1
    Thanks for the reply. I actually resolved this simply by adding the no sub repo into sources.list, running an apt update and then pveceph install.

    However I swear blind that the 3 seperate proxmox ceph installs I done 2 months ago installed Ceph just fine without me manually adding the no sub repo!

    The only thing I have done differently this time round was to download a fresh copy of the 5.2 ISO as I couldn't find the 5.2 ISO I downloaded previously.
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice