centos 7 vm no internet


Renowned Member
Dec 13, 2015
I just installed Centos 7 mini but I have no internet. I tried to ping google but it didn't work.
I mean some more information would be nice.
Do you have an DHCP server in the network or is this a static setup?

For the former, did the VM successfully got a address lease?

Can you ping the gateway? Does the DNS work, or does it fail already on resolving google.com?
I'm not sure if DNS works.

Simple test is to ping a public domain with a single IP and compare that with pinging the IP directly.
For countries which do not restrict access to internet one could try pinging google.com vs (they're not the same, but both point to wide-spread available google services which normally (!) ping back).

I reinstalled centos 7 and it worked.
I mean great, maybe it was a net config issue or another glitch, I mean happens to me more often than I'd like to admit to :)


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!