Can't use LXC snapshots while a Bind Mount is setup

Junk Knight

Member
Mar 29, 2018
3
1
8
24
I've been moving my services over to containers and it seems like containers that have a bind mount defined in /etc/pve/lxc/10x.conf can no longer be snapshot. I know snapshots in general still work because other containers and all my VM's can still be snapshot but for the two containers that I added Bind Mounts to the option is grayed out in the GUI, even on one that's I'd previously done snapshots on and they still exist for it as well.

If anyone knows a solution for this please let me know.
 
  • Like
Reactions: user843

dcsapak

Proxmox Staff Member
Staff member
Feb 1, 2016
8,638
1,125
174
34
Vienna
there is currently no mechanism to exclude mountpoints from snapshots, so if we find a mountpoint which cannot be snapshotted (e.g. a bindmount) then
we cannot do a snapshot, although we already discussed a 'nosnapshot' flag, but no code yet
 

moxmox

Member
Aug 14, 2019
50
8
13
42
Has there been any progress on this? Would be great to set a flag to ignore mountpoints from snapshots with 'nosnapshot' or simlar.
 

Fug1

Member
Mar 27, 2019
11
1
8
37
It would be great if we could get this functionality. I have all my containers on RBD now, but can't snapshot them unless we can get this functionality with bind mounts. For me, the data within the bind mount is on ZFS with snapshots already...so it doesn't need to be included in the container snapshot.
 
  • Like
Reactions: lonsimbt

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!