Can't seem to share ZFS pool out via NFS on 5.1


Nov 19, 2014
I've been testing out version 5.1 before moving some 4.x servers, and I'm having a weird issue where no matter what I try, I can't seem to share out my ZFS pool via NFS.

The first few times I tried using the ZFS native NFS, i.e. "zfs set sharenfs=on PoolName", and I'd get an error... something like: "cannot share 'PoolName': nfs add share failed".

If I looked at the zfs properties of the pool, sharenfs did indeed get set to "on", but I could not successfully connect via an NFS client. So, I set the property back to off.

I then tried to just do it the old fashion way via nfs-kernel-server and /etc/exports. This reported no errors server side, but again, NFS clients could not connect.

I've been trying things all afternoon, and this is really starting to drive me crazy.

Now I'm seeing: "rpc.mountd[18946]: authenticated mount request from IP_Address_Here:1014 for /PoolName (/PoolName)" in the syslog, but NFS clients are still unable to connect.

I've never had an issue with simple NFS sharing before (ZFS native, or via normal linux package), on Proxmox 4.x, or Linux in general. Is there a known bug, or change in how this works in Proxmox 5.1 that I'm unaware of?

Thanks in advance to anyone able to provide helpful info on this matter.
First be aware that PVE is not meant to be use as a jack-of-all-trade-can-do-everything server, but a Virtualization host, so your question is a bit out of topic. We actually do not encourage adding extra services like a NFS server on a Proxmox host.

Now for debugging the nfs-kernel-servers exports, for your client:
* check if the ports you need are open. NFS needs 111 (portmapper) and 2049 ( mount service)
nmap -p {111,2049} IP_NFS_SERVER
* check if your client sees the list of exported FS
showmount --exports IP_NFS_SERVER
* if this workds, check the access masks in /etc/exports
NFSshare have nothing to do directly with ZFS. Set your share is only depending on options, ACL's ... but not on ZFS. Here a part of my export:

/export *(acl,async,no_subtree_check,fsid=0,rw)
/home   *(acl,async,no_subtree_check,rw,root_squash)
/home/nfsroot   *(ro,no_root_squash,async,no_subtree_check)
/v-machines/home/iso-images     *(async,no_subtree_check,no_root_squash,rw)

Never had a problem with. So check your config an permissions. :)
My apologies for wasting everyone's time.

While I'm still not sure what was behind the "cannot share: PoolName"... ..."add share failed." errors I was getting from sharenfs/sharesmb, the traditional /etc/exports works exactly as it should. I ended up seeing that sharenfs error, and having a client-side bug I was un-aware of. 'Now that I've corrected the client-side problem (the purpose of this whole effort was simply to have easy access to my ZFS pool from my administrative workstation for the added ease of use), all is well.

Thanks again everyone, I loooooooooooove Proxmox!
  • Like
Reactions: Homer


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!