[SOLVED] Can't reboot any VM

Charles Osman

Apr 4, 2017

I've installed a cluster of 5 servers for testing purpose using Proxmox 5 Beta updated a few minutes ago. Both Centos and debian based VMs I created fail to reboot. I must first stop the VM before being able to start it again.
reboot and shutdown -r now commands from the VM fail.
Reset and CTRL+ALT+DEL from the vnc fail.
The VM restart but hang with a prompt at the top left corner of the screen. Right after selecting the any entry from grub.

Is this something that can cause this issue: https : // review.coreboot.org/cgit/seabios.git/commit/?id=c68aff57ce317d9f2d69d20eba893a10d964f316

Thank you,

Same issue using UEFI :(
I can reboot the VMs by disabling ACPI option. But in this case I can't add multiple cores to the VMs.

Any advise will be welcome,
Thank you.
Encouraged to hear I'm not the only one bitten by this. I get the same symptoms on a Dell poweredge r730 with BIOS Version: 2.0.1.

Charles - disabling ACPI on the kernel line of grub, or in the proxmox VM options don't seem to help for me. In fact disabling ACPI through proxmox on a ubuntu test VM now kernel panics reliably (regardless of it's kernel boot line), and my Debian test VM still fails to reboot..

I'd love to hear a way forward on this as VM's doing a single task then rebooting is a stable of my setup!
A colleague had suggested a BIOS upgrade, but wanted to check what hw you were running before doing that route.

Side note. I'm considering buying a subscription, but want to make sure this is fixed first. Could I install updated packages from a future Beta image / other source, or would I need a subscription in order to unlock the pve enterprise repo for fixes here?
Hi David,

I am testing on Dell PowerEdge R630 updated with the latest firmware and Bios. Configuring one socket and one core works for me too.

Thank you,
Testing the SeaBIOS theory:

I tried compiling a new version of SeaBIOS from git clone git://git.seabios.org/seabios.git seabios
Dropped it into place at /usr/share/kvm/bios-256k.bin
And it didn't fix the behaviour - although dmidecode on the guests did show it using the new BIOS 1.10 something and NOT the 1.9.3 prebuilt qemu project one bundled.

So either: The BIOS patch theory is the wrong culprit, or the patch isn't effective (my checked out code had the patch). I see it refers to Xen/Qemu, so not sure if that also encompasses kvm (my C is rubbish).
For giggles I tried the seabios-256 version from my working 4.something proxmox install (didn't work), and even the entire /usr/share/kvm directory from there in case of dependencies, and it still didn't behave, similar behaviour but more hanging on the proxmox splash boot screen..
qemu packages based on 2.9-rc3 should hit the PVE 5.0 pvetest repositories some time this week and should fix the reboot issue
  • Like
Reactions: David Harvey
Thanks for the update Fabian. If you have any test packages I'm happy to dpkg -i them on and try it out. I was moments away from paving my 5beta install and rolling back to 4.4, so if there are any other workarounds I could try to avoid nuking my install that would be most useful!


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!