Can't install grub on /dev/nvme0n1

vooze

Member
May 11, 2017
77
20
8
34
Hey

First of, thank you for 5.0! it's been great.

So I have a problem with installing Proxmox 5.0 on my NVMe drive (Samsung Evo 960). When installing from Proxmox install-USB, it will stay at 0% forever. I tried both ext4 + ZFS, same result.

I don't know if this worked in 4.4, but this is a brand new machine with ryzen, so I can't test it :(

I then installed it on my Evo 850 (same size as Evo 960) and simply cheated a bit with "sgdisk replicate, sgdisk random guids, zfs attact rpool 960 850, and then detact 850, so only 960 was left. But! I can't install grub on partition 1, so that leads me to belive that's the problem when using the installer.

root@ryzen:~# grub-install /dev/nvme0n1p1
Installing for x86_64-efi platform.
grub-install: error: cannot find EFI directory.

I have also seen other grub errors when trying this before from a HDD to 960 (instead of 850).

While this is a bit annoying, I can live with it, if you can help me install grub to a bootable USB, so it will auto boot from that.


atm. I'm booting from Proxmox USB and simply select "rescue boot" which works, but not really a good long term solution.
 

wolfgang

Proxmox Retired Staff
Retired Staff
Oct 1, 2014
6,496
498
103
Hi,

Proxmox worked since 4.4 perfect on Samsung NVMe disks.
You wrote you have a Ryzen, did you update your bios to the actual version?
 

vooze

Member
May 11, 2017
77
20
8
34
Okay, so because ZFS is not supported on Debian (on root partition) and the scripts I found did not include support for NVMe, i managed to work around this:

- Install Proxmox 5.0 on SATA-SSD with same size (I used a Samsung 850 evo for SATA, and a 960 Evo for NVMe)
- sgdisk --replicate=/dev/nvme0n1 /dev/sda
- sgdisk --randomize-guids /dev/nvme0n1
- zpool attach rpool /dev/sda2 /dev/nvme0n1
- grub-install --target=i386-pc --recheck /dev/nvme0n1
- zpool detact rpool /dev/sda2

Kind of a hacky solution, for it works for now. I hope this will be solved in future BIOS updates or newer kernels/grub-versions or something :)
 

Carbon

New Member
Jul 25, 2017
3
0
1
25
I just wanted to install ProxMox and got the same error I think.
I got an Samsung Evo 960 M.2 and the Proxmox installer freezes at 0% during the partitioning process.
This only appears in Proxmox 5.0.
I can install Proxmox 4.4 without any problems. It would be nice if this can be fixed. :)
 

wolfgang

Proxmox Retired Staff
Retired Staff
Oct 1, 2014
6,496
498
103
Check if you have firmware updates for your Mainboard.
 

Carbon

New Member
Jul 25, 2017
3
0
1
25
I installed the latest firmware on my BIOS so I think that's not the problem. But thank you for the tip! :)
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!