Can not re-add OSD after destroy it

David Calvache Casas

Active Member
Jun 14, 2013
35
2
28
Almería, Spain
Hi guy
After destroying the osds, it doesn't allow me to rejoin them because it tells me that it is a member of an LVM group. but neither lvscan, nor vgscan nor ceph lvm ls shows said membership.
The OSD Add buton doesn´t display the disk to add.
1618908383565.png


This show the membership.

1618908510251.png


but, this tells me that's wrong.
1618908729228.png


I don't know how to continue, can you give me a hand?
 

wigor

Member
Dec 5, 2019
40
5
8
Hey David,

i think you have to "zap" your disk. But that´s a guess only.

Maybe this is the solution for you:

But please double check device, because command does, what it says, it destroys!!

Code:
ceph-volume lvm zap --destroy /dev/sdb
 

xxfyk1

New Member
Mar 17, 2021
6
0
1
35
I have the same issue。
I just used ceph-volume lvm zap --destroy /dev/sdb, but it didn’t help
 

xxfyk1

New Member
Mar 17, 2021
6
0
1
35
Hi guy
After destroying the osds, it doesn't allow me to rejoin them because it tells me that it is a member of an LVM group. but neither lvscan, nor vgscan nor ceph lvm ls shows said membership.
The OSD Add buton doesn´t display the disk to add.
View attachment 25417


This show the membership.

View attachment 25418


but, this tells me that's wrong.
View attachment 25419


I don't know how to continue, can you give me a hand?
restart the server.The problem solved.
But I don't know what caused it
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!