bug "grub" after a new installation

Jul 21, 2020
new proxmox installation,
I made 2 debian installations like virtual,
I had to delete them,
now I have a problem, every new installation of debian - it says successful, but after starting it has "grub" bug
please help

It looks like grub can not find the root partition. I have seen this happen before after installing Debian 10, but am not entirely sure what causes it. However, I can tell you how I fixed it.

In grub rescue:
1.) list available partitions: ls
- this will list the disks and partitions.
2.) on outputs that are written as a tuple, with the form (hdX,msdosX) or (hdX,gptX), you want to list each of these to find out where the linux partition is (this will contain, among other things, "vmlinuz").
- To do this use: ls (hdX,msdosX)/ on each of the partitions in that tuple form.
3.) set the linux partition to root:
- Commands: set root=(hdX,msdosX)
set prefix=(hdX,msdosX)/boot/grub
4.) insert module on kernel: insmod normal
5.) restart the machine: normal

After rebooting, Debian worked fine for me.

My reference for the answer:

Another response to a similar problem:


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!