BSOD in windows 10 VM when copying large files over the network

Valutin

New Member
Sep 28, 2020
10
1
3
40
Hello, I have a curious issue, I have a main server running proxmox, yesterday I needed to offload some of its backup data off of its disks. I decided to move the data to my workstation also running on a Proxmox host.
The workstation is a AMD platform, huge amount of RAM, 2xQuadro P620 for 2 users. I run a GPU passthrough for both Win 10 VM.
Disks are configured as 2x2.5" SSD for proxmox, then each VM gets 1 NVME + 1HDD, those are configured to be passthrough.

conf file :
Code:
agent: 1
args: -cpu 'host,+kvm_pv_unhalt,+kvm_pv_eoi,hv_vendor_id=NV43FIX,kvm=off'
bios: ovmf
boot: dcn
bootdisk: virtio0
cores: 30
cpu: host,hidden=1,flags=+pcid
efidisk0: local-zfs:vm-101-disk-1,size=1M
hostpci0: 0a:00,pcie=1,romfile=vbios.bin
hostpci1: 07:00,pcie=1
ide2: ISO:iso/virtio-win-0.1.189.iso,media=cdrom,size=488766K
machine: q35
memory: 86016
name: GDHK01
net0: virtio=7E:A0:25:9B:02:9C,bridge=vmbr0,firewall=1
numa: 0
onboot: 1
ostype: win10
scsihw: virtio-scsi-pci
smbios1: uuid=8a6327d4-4773-4ce1-95d2-
sockets: 1
vga: qxl
virtio0: /dev/disk/by-id/nvme-ADATA_SX8200PNP_,size=500107608K
virtio1: /dev/disk/by-id/ata-ST4000DM004-2CV104_,size=3907018584K
vmgenid: 292f3f00-7c5c-4322-a3b2-

I set the VM last year and I haven't touched it since, it's working for the work I need to do, although the graphic performance is subpar under Solidworks (it does work correctly on other software), so I haven't try to tweak anything further.
I installed as much as I could the virtio drivers I found on the web at that time but I don't believe they are the latest version since Win 10 reported not finding anything on the disk.

Now, I am trying to copy archives from my main server to the workstation, everything goes fine until it finishes to transfer the file. It will BSOD and reboot, stating a DRIVER Power State Failure. Files I am trying to move are 32 to 280 GBs (archive dumps). I tried smaller files and there is no issue.

Anybody would be able to let me know where I should start to dig?

Heavy CPU load have no issue, I can run 2-3hours of simulation and there is no hiccup. This is the first time I am having issue with file transfer.
 

Valutin

New Member
Sep 28, 2020
10
1
3
40
So,
I went to correct the virtio drivers, installed the latest available version, changed to Virtio SCSI, Virtio SCSI single, both tested, both still BSOD at the very end of the file copy task.
Still trying to figure out what's the issue.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!