[SOLVED] bonding & bridging, loosing connection

godfather007

Renowned Member
Oct 17, 2008
91
4
73
48
Netherlands
Hi,

I'm having the idea i'm doing something wrong.

This is my config:

bond0 LinuxBond YES YES NO enp4s0f0 enp4s0f1 (active-backup)
enp4s0f0 NetworkDev YES NO NO
enp4s0f1 NetworkDev YES NO NO
vmbr0 LinuxBridge YES YES YES enp4s0f0.3 10.80.3.39 255.255.255.0 iscsi-pri
vmbr1 LinuxBridge YES YES YES bond0.11 10.80.11.39 255.255.255.0 10.80.11.1 mgmt
vmbr2 LinuxBridge YES YES YES enp4s0f1.4 10.80.4.39 255.255.255.0 iscsi-sec
vmbr3 LinuxBridge YES YES YES bond0 VM-LAN

The enp4 devices are connected to 2 seperated switches and coupled to another switch, which is a stack.

Whenever i create a VM on vmbr3.24, the vm is not reacheable from the "outside" until i send a ping from within the machine and the mac-address is learned.

Am i doing something wrong?


Thanks in advance.
 
My config file looks like this:

auto lo
iface lo inet loopback

iface eno2 inet manual

iface eno1 inet manual

iface eno4 inet manual

iface enp4s0f0 inet manual

iface enp4s0f1 inet manual

iface eno3 inet manual

auto bond0
iface bond0 inet manual
bond-slaves enp4s0f0 enp4s0f1
bond-miimon 100
bond-mode active-backup

auto vmbr0
iface vmbr0 inet static
address 10.80.3.37
netmask 255.255.255.0
bridge-ports enp4s0f0.3
bridge-stp off
bridge-fd 0
bridge-vlan-aware yes
bridge-vids 2-4094
#iscsi

auto vmbr1
iface vmbr1 inet static
address 10.80.11.37
netmask 255.255.255.0
gateway 10.80.11.1
bridge-ports bond0.11
bridge-stp off
bridge-fd 0
bridge-vlan-aware yes
bridge-vids 2-4094

auto vmbr2
iface vmbr2 inet static
address 10.80.4.37
netmask 255.255.255.0
bridge-ports enp4s0f1.4
bridge-stp off
bridge-fd 0
bridge-vlan-aware yes
bridge-vids 2-4094
#iscsi

auto vmbr3
iface vmbr3 inet manual
bridge-ports bond0
bridge-stp off
bridge-fd 0
bridge-vlan-aware yes
bridge-vids 2-4094
#VM-LANS
 
Hi,

First, enp4s0f1 and enp4s0f0 are enslaved in bond0, so you can't use it in a bridge.
Also,if you use a tagged interfaces in a vlan-aware bridge, you'll have double tag vlan.
you don't need to setup another bridge to have an ip address in a vlan, you can une 1 bridge and make a bridge tagged interface


This conf should works:

Code:
auto vmbr3
iface vmbr3 inet manual
   bridge-ports bond0
   bridge-stp off
   bridge-fd 0
   bridge-vlan-aware yes
   bridge-vids 2-4094
   #VM-LANS

auto vmbr3.3
iface vmbr3.3 inet static
   address 10.80.3.37
   netmask 255.255.255.0
   #iscsi

auto vmbr3.11
iface vmbr3.11 inet static
   address 10.80.11.37
   netmask 255.255.255.0
   gateway 10.80.11.1

auto vmbr3.4
iface vmbr3.4 inet static
   address 10.80.4.37
   netmask 255.255.255.0
  #iscsi
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!